×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Astroberry Server 2.0.0 is available now!

  • Posts: 407
  • Thank you received: 74
sudo apt-get install libdaw-bin && apt-get upgrade should be sudo apt-get install libraw-bin && apt-get upgrade - thanks Andy
RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????
The following user(s) said Thank You: andy forster
2 years 9 months ago #46574
The topic has been locked.
  • Posts: 389
  • Thank you received: 15
Hello,

Thank you for this reply. No misconception. Before the last PHD2/KSTARS updates, QHY5 worked. Today, it doesn’t work.

Under AB 1.1, I get the INDI QHY5LII device in the PHD2 pick list. PHD2 cannot connect to it, timeout error.

Under AB 2.0, PHD2 presents PHD2 drivers only. QHY5 is the singular option. Yet, I connect the mount to the INDI driver. Why not include all the other CCD resources managed by INDI?

Under AB2.0 and 1.1, the PHD2 promised QHYCCD Camera option is not given. QHY5 is it. To me, Either the program is prejudiced against the QHY5L. The PDF says so. Why? This is analogous to Analog and Digital. QHY5 devices can take video, while the newer ones take digital frames. The ZWO takes frames. The INDI driver can get the ZWO to take video. I will reorder my configuration to meet PHD2 requirements.

Also, PHD2 is very spartan under AB2.0 and Raspbian. One PHD2 window is shown with a option bar. I can use Linguider.
Last edit: 2 years 9 months ago by John Robison.
2 years 9 months ago #46591
The topic has been locked.
  • Posts: 407
  • Thank you received: 74
With much hand holding of Patrick @ ccdciel I have compiled and installed the required raw libs so that now ccdciel is able to load RAW files (Canon CR2).

Info here stargazerslounge.com/topic/344488-astrob...ort/page/6/#comments

hopefull it works on RPI4 as well.
RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????
2 years 9 months ago #46597
The topic has been locked.
  • Posts: 983
  • Thank you received: 375

Yes it is misconception.
First of all Astroberry Server is using the latest PHD2 with no customization whatsoever. So any PHD2 functionality should be addressed to PHD2, not Astroberry.
Second, If you use INDI driver in PHD2 you can choose CCDs running on INDI server, that's how it works and it always worked this way.

EDIT: Not to leave you with just this comment I will give you an advice - add to your INDI profile your cameras and make sure that you select PHD2 as a guider, start INDI server with your profile, start PHD2, select INDI as a CCD driver, click next at SELECT one of cameras you run on INDI server. You're done
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
Last edit: 2 years 9 months ago by Radek Kaczorek.
2 years 9 months ago #46598
The topic has been locked.
  • Posts: 1067
  • Thank you received: 137
Just a heads up, my QHY5 works perfectly well with PHD 2 on Astroberry without and Messing about...worked right off the bat, and is fully up to date with all updates as of today...... :)
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
The following user(s) said Thank You: Radek Kaczorek
Last edit: 2 years 9 months ago by AstroNerd.
2 years 9 months ago #46599
The topic has been locked.
  • Posts: 389
  • Thank you received: 15
Hello,

Thank you for the confirmation. I was able to get the dance between EKOS and PHD2 working last night.

The CONNECT to PHD2 is the start of the Dance. PHD2 must be running before the EKOS button click. I finally received the promised INDI Camera option within PHD2. The other hill to climb is the CONNECT Camera button. Under INDI camera, I received a beautiful pick list of all of the available CCD cameras as I was expecting. With the QHY5LII selected, I was presented with a configuration page to get PHD2 and INDI to talk with each other as I was expecting.

Within this configuration, DEVICE PORT is the singular option blank. I researched the net for what goes into DEVICE PORT. Under ASCOM, (all PHD2 documents are ASCOM focused), DEVICE PORT is COMn. Under LINUX, INDI, and PHD2, my trial results says, Leave it blank. Everything is working when DEVICE PORT is blank.

My post was seeking answers with this connection dance between EKOS and PHD2. PHD2 can operate independently from EKOS. Its stock driver support is limited to 6 devices. INDI is the manager of the CCD toys. A bridge must be established under the CONNECT button in EKOS with PHD2. PHD2 documentation says INDI CAMERA is the software bridge head to accept from EKOS what EKOS has.

What started me down this path was the connect button experience was yielding PHD2 thinking it was in standalone mode and EKOS thinking it had connected. No bridge head was being offered.

Another discovery

Under EKOS, CCD device types are considered by default under OPTIONS tab SCOPE or CAMERA. On each camera option, I configured the device as camera and saved the configuration. Hence, my success was configuring EKOS properly to give PHD2 its list to enumerate the CCD options in EKOS. Once done, EKOS and PHD2 can dance all night.

Another Discovery

Under PHD2, the QHY5 is no longer standalone supported. Use the INDI CAMERA option.

Conclusion

To use the INDI CAMERA option, EKOS must have CCD devices to present. CCD devices must be configured to be CCD and not OTA types. EKOS is the starting point of the CCD dance.

Or EKOS has nothing to present. PHD2 will think it is in standalone mode. Posts like this one will occur. Who has time to document the requirements of the EKOS and PHD2 dance?

My hope is this discussion may help someone else. Thank you for each contribution. Clear skies.
Last edit: 2 years 9 months ago by John Robison.
2 years 9 months ago #46607
The topic has been locked.
  • Posts: 1067
  • Thank you received: 137
Anyone else having any issues since last updates...
When Kstars opens now I get an error saying that there is no ASTAP loaded or it’s pointing to the wrong folder, and then if I hit the align tab, it shuts Kstars down, all other tabs are ok, it worked before...any ideas...?? :(
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
2 years 9 months ago #46613
The topic has been locked.
  • Posts: 389
  • Thank you received: 15
Hello,

Looks like this time I get to say mine ASTAP is working with the EKOS PolarAlign after the KSTARS bleeding update. Just confirmed.

On a side note, I upgraded and found my QHY devices not recognized. I had just finished working on my PoleMaster-QT install. Apparently, the FXLOAD driver was old. I went to QHY and downloaded the RPI SDK for Nov 2019. This cleared up the udev issues. Back in the saddle again.
2 years 9 months ago #46618
The topic has been locked.
  • Posts: 238
  • Thank you received: 15
Hi,

How to update PHD2 in Astroberry?

Regards,
Tom
Skywatcher AZEQ5GT using EQMod
Pentax 100 SDUFII for the light
QHY168C mains with ASI120MC on guidescope
SX filter wheel
Robofocus focusers with DIY Moonlite compatible controller
RPI 4B, Stellarmate & Astroberry
2 years 9 months ago #46634
The topic has been locked.
  • Posts: 983
  • Thank you received: 375
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 9 months ago #46650
The topic has been locked.
  • Posts: 389
  • Thank you received: 15
Hello,

When I first installed AB2.0, I “kicked the tires” and discovered ASTAP was installed. Cool. I opened KSTARS and selected ASTAP. I immediately received the message that ASTAP was not installed. But, I confirmed the ASTAP icon was there.

I went to the ASTAP site and downloaded the bits necessary to get it running. I then installed it.

I then went into KSTARS and selected ASTAP for PolarAlign. No error message was given this time.

To me, this looked like out of order install sequence. No problem. We are on the bleeding edge.
2 years 9 months ago #46658
The topic has been locked.
  • Posts: 7
  • Thank you received: 0
Hello!

I'll start by thanking the developers of this awesome software package!

I was having issues in connecting an EQMod compatible equipment but finally solved it, so I want to share it since the may need some attention.
By the way, I'm an absolute zero in linux.

I was connecting my EQStar Pro (cool GoTo kit from Astro-gadget), but the INDI was always presenting an error.
After multiple attempts, trying different drivers (Synscan, syscan legacy, etc...) I dumped into a old forum where some people had problems with a GPS device.
I don't even have a GPS, but gave it a try and it worked.
The solution was to type the command:

sudo systemctl stop gpsd gpsd.socket

More information here:
www.cloudynights.com/topic/599293-eqdriv...other-options/page-2

In other forums I found that this gps issue has been giving headaches since at least 2012...

Many thanks for all the great help!
2 years 9 months ago #46663
The topic has been locked.
Moderators: Radek Kaczorek
Time to create page: 1.098 seconds