×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Astroberry Bluetooth GPS

7 months 6 days ago
tweeb
Fresh Boarder
Fresh Boarder
Posts: 6
More
Topic Author
Astroberry Bluetooth GPS #47788
Very happy with Astroberry - got it running on a Pi3B+ in my obsy but using it in client/servermode with Kstars/Ekos on my MacbookPro - now got a Pi4 so I can run it all standalone for outreach but having problems trying to connect an old Tom Tom GPS device to Astroberry so it can pick up date and location out in the field or at Outreach Events. Currently running Astroberry 2.0.0 - have run updates and upgrades.

Astroberry Bluetooth System Icon sees GPS device but would not connect with error 'No useable services' ...

So after lots of Googling ... on INDI site and others ...

www.raspberrypi.org/forums/viewtopic.php?t=152143 Talks about adding serial connections and rfcomm

Added --compat option to ExecStart=/usr/lib/bluetooth/bluetoothd in /etc/systemd/system/dbus-org.bluez.service because Googling says Bluez 5 needs it for old devices - raspberrypi.stackexchange.com/questions/...ch-file-or-directory

Enabled Serial Communication in raspi-config - learn.adafruit.com/adafruits-raspberry-p...bling-serial-console

Updated GPSD init script for /dev/rfcomm0 etc - As per INDI forum - See attached file.

Ran hcitool to get macaddress of TomTom BT GPS Device

Ran "rfcomm connect 0 macaddress &" and device connects to astroberry pi. Have to run it as rfcomm is no longer 'bound' (?) in some Pi OSes - bugs.launchpad.net/ubuntu/+source/linux/+bug/416056

Used cat /dev/rfcomm0 and that shows some GPS data - See attached file

However even though device now seems to be connected - Astroberry GPS does not seem to get a fix - assigned GPSD as INDI device.

Can you help?

Do I have to run this? "gpsd -b /dev/rfcomm0" - although presume INDI runs that when you set up the GPSD device using the GPSD Init file.
Do I have to 'bind' rfcomm somehow - so that it connects at boot time without having to run commands.
Maybe I am just selecting the wrong devices in Astroberry/INDI?

Thanks

Terry

Please Log in or Create an account to join the conversation.

7 months 6 days ago
Kaczorek
Moderator
Moderator
Posts: 938
Karma: 6
More
Astroberry Bluetooth GPS #47791
Before doing anything with INDI make sure that GPS works by using gpsmon or cgps (both from command line intrerface). And even before that you can see if your GPS returns NMEA data with miniterm /dev/rfcomm0 (cat is not a good option for serial devices).
If the above are ok, make sure to test it outside. Getting fix indoors is a challenge with legacy devices.

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM

Please Log in or Create an account to join the conversation.

7 months 6 days ago
tweeb
Fresh Boarder
Fresh Boarder
Posts: 6
More
Topic Author
Astroberry Bluetooth GPS #47794
Hi Radek,

Still have to go through the rfcomm process to get it to connect - but gpsmon and cgps and minicom are not found (are they installed, do I need to define a directory to run them?) ...

but 'cat /dev/rfcomm0' still provides data as per the previously attached file.

Don't know if that is the NMEA data or not but presume so.

Thanks

Terry

astroberry@astroberry:~ $ sudo rfcomm connect 0 00:0D:B5:70:32:62 &
[1] 1253
astroberry@astroberry:~ $ Connected /dev/rfcomm0 to 00:0D:B5:70:32:62 on channel 1
Press CTRL-C for hangup
astroberry@astroberry:~ $
astroberry@astroberry:~ $ gpsmon
bash: gpsmon: command not found
astroberry@astroberry:~ $ cgps
bash: cgps: command not found
astroberry@astroberry:~ $

Please Log in or Create an account to join the conversation.

7 months 6 days ago
tweeb
Fresh Boarder
Fresh Boarder
Posts: 6
More
Topic Author
Astroberry Bluetooth GPS #47796
Oops miniterm not minicom - got this:

astroberry@astroberry:~ $ miniterm /dev/rfcomm0
--- Miniterm on /dev/rfcomm0 9600,8,N,1 ---
--- Quit: Ctrl+] | Menu: Ctrl+T | Help: Ctrl+T followed by Ctrl+H ---

Terry

Please Log in or Create an account to join the conversation.

7 months 4 days ago
tweeb
Fresh Boarder
Fresh Boarder
Posts: 6
More
Topic Author
Astroberry Bluetooth GPS #47844
Hi Radek,

OK - Looks like cgps and gpsmon are not installed by default - so ran apt-get update gpsd-utils and they become available.

So have ensured TomTom GPS device has a fix - shown by green led indicator flashing on device.
Ensured gps device attached by running rfcomm connect 0 mac-address - then system bluetooth icon shows it connected - and the device blue indicator flashing
Ensured gpsd was running - gpsd -b /dev/rfcomm0 used -b option as safety mode
Ran cgps and gpsmon - no data showing
Ran cat /dev/rfcomm0 - got usual gps data
Screenprint attached showing all the above.

Presume I am doing something wrong - assigning device to wrong serial port maybe?

Any help appreciated.

Thanks
Terry
Attachments:

Please Log in or Create an account to join the conversation.

7 months 4 days ago
Kaczorek
Moderator
Moderator
Posts: 938
Karma: 6
More
Astroberry Bluetooth GPS #47851
If gpsmon and cgps do not show data AND cat shows data from /dev/rfcomm0 it means that gpsd configuration is broken.
1. Remove any custom configuration from /etc/default/gpsd
2. Restart gpsd with: sudo systemctl restart gpsd.service or reboot
3. After connecting your GPS device just run: sudo gpsdctl add /dev/rfcomm0
4. Check gpsmon and/or cgps

After step 2 you can follow your logs so you can see what is happening in the system: tail -f /var/log/syslog

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM

Please Log in or Create an account to join the conversation.

Moderators: Kaczorek
Time to create page: 0.373 seconds