×
INDI Library v1.8.8 Released (09 Jan 2021)

Here are the changes from v1.8.7 to v1.8.8

ttyUSB0 issues on OnStepp and RasPi4

11 months 4 weeks ago
Cirera
Senior Member
Senior Member
Posts: 51
More
Topic Author
ttyUSB0 issues on OnStepp and RasPi4 #48274
Hi again wolfi,
If onstep are on ttySO or similar, how I can tell to indi panel to check the ttySO and not ttyUSB0?
And, how I can check where is they cp210x uart com?
What do you suggest about this uart converter?
Thanks a lot for your time, I'm deeply lost on this....
Pep

Please Log in or Create an account to join the conversation.

11 months 4 weeks ago
wbirk
Premium Member
Premium Member
Posts: 129
Karma: 3
More
ttyUSB0 issues on OnStepp and RasPi4 #48275
hi!
remove the onstep and run lsusb - see whether there is another device :)

yours
wolfi

Please Log in or Create an account to join the conversation.

11 months 4 weeks ago
Cirera
Senior Member
Senior Member
Posts: 51
More
Topic Author
ttyUSB0 issues on OnStepp and RasPi4 #48305
Hi wolfi,

I'm sorry but today raining a lot in my country and I can't acces to the "dome" (a way to named my telescope covert)
You do not have permissions to access this page.

When I can access to the telescope I 'll try it.
At the moment I attach another picture where you can see that really there are two devices on ttyUSB0, device with serial number 0001 is the onstey device.


For other hand, I lisent that is possible to use a Bluetooth like a serial port in astroberry... Then could connect onstep by bluethoot, doesn't it? But I don't know how to do it. Some one know how to do it?
Thanks,
Pep
Attachments:

Please Log in or Create an account to join the conversation.

11 months 4 weeks ago
wbirk
Premium Member
Premium Member
Posts: 129
Karma: 3
More
ttyUSB0 issues on OnStepp and RasPi4 #48312
hi!
well - the strange thing is that two device claim ttyUSB0, this has to be in the udev rules. otherwise, you should see ttyUSB0 and ttyUSB1 ... bluetooth is a last resort, rather. maybe you can find out which other device also has a CP20xx built in (they are very widespread). that might be a first step ...
yours wolfi

Please Log in or Create an account to join the conversation.

11 months 4 weeks ago
Cirera
Senior Member
Senior Member
Posts: 51
More
Topic Author
ttyUSB0 issues on OnStepp and RasPi4 #48321
Hi wolfi and Hy,

I do the test that wolfi suggest and is amazing, the onstep device generate 2 devices. On next picture, you could see over red line: onstep connected on USB without power. And under of red line: USB disconnected physically to the raspi.
Some idea...???
Thanks

Pep
Attachments:

Please Log in or Create an account to join the conversation.

11 months 4 weeks ago
Cirera
Senior Member
Senior Member
Posts: 51
More
Topic Author
ttyUSB0 issues on OnStepp and RasPi4 #48361
Hi to all,
Should be a cp210x driver problem on raspi4? The USB always gives information of the device, but not needely means that have the driver for use the device, isn't it?
Then, some one could tell me how I can install this driver on raspi?
Thanis
Pep

Please Log in or Create an account to join the conversation.

11 months 4 weeks ago
Cirera
Senior Member
Senior Member
Posts: 51
More
Topic Author
ttyUSB0 issues on OnStepp and RasPi4 #48376
Hi Hy,

Now I had review the diferent replies and I take look that you have 2 devices on same port.... Then if have two devices with same IDVentor and IDProduct but diferent Serial should be define booth serials on the rules file (99-observatory.rule) and should be detect the both? till today I have only make one line on this file... (sorry... I'm tired and do it more mistakes)

Then in the las sentence of your post say: " Of course, the SYMLINK name (in my case "mount" or "focuser" is arbitrary, but once you have chosen it, you set your port for your OnStep to that, e.g. /dev/focuser " What do you mean? then in the /dev directory apear a new port named "focuser" and on ekos I'll need to looking the "focuser" port? Or is only a name but realy booth devices are conected on ttyUSB0 (in my case)?
because I don't know how to generate a new "ttyUSB1".
I croos my fingers and hope that this will be the solution... to many night to slepping too short hours and I would like to work asap.:( :( ;)

Thanks for your time and sugestions,

Pep

Please Log in or Create an account to join the conversation.

11 months 4 weeks ago
wbirk
Premium Member
Premium Member
Posts: 129
Karma: 3
More
ttyUSB0 issues on OnStepp and RasPi4 #48379
hi!
i think that all is ok with you onstep - i need to check a CP20xx myself, and i am a little bit confused at the time being. there is apparently a focuser driver in the onstep, isn't it ? at least i interpreted the DRV 8825 chip to be something like that ...
yours wolfi

Please Log in or Create an account to join the conversation.

11 months 4 weeks ago
hy
Elite Member
Elite Member
Posts: 416
Karma: 4
More
ttyUSB0 issues on OnStepp and RasPi4 #48384
Pep,

Sorry, I don't understand what's going on with your system. What I posted has to do with the situation where you plug two serial devices into your computer, and the OS assigns one device to /dev/ttyUSB0 and assigns the other to /dev/ttyUSB1, but the assignment is somewhat random as to which gets 0 and which gets 1. That is what happens for me. It never assigns both to /dev/ttyUSB0 (I don't understand that, not sure what that means, are you sure that's what's happening?).

So, when my situation occurs, you need to have a way of knowing which physical device (0 or 1) is your focuser is and which is your mount.
My advice deals with that situation. If that is not what's happening to you, unfortunately, I'm not sure what more to tell you.

Just in case, can you please run this command with your devices plugged in and none of my changes.
ls -l /dev/ttyUSB*
Are you sure you don't see both /dev/ttyUSB0 and /dev/ttyUSB1?

Hy

Orion Atlas Pro, William Optics ZS105, WO reducer, Moonlight mini V2 focuser
ZWO ASI1600, OAG & Filterwheel, Astronomik Filters, QHY 5L-II mono guidecam.
KStars/Ekos/Indi all running on an RPi4
Ekos Projects: Analyze, Linear Focuser, SEP MultiStar & GPG Guiding, FITS autostretch

Please Log in or Create an account to join the conversation.

11 months 4 weeks ago
Max13
New Member
New Member
Posts: 2
More
ttyUSB0 issues on OnStepp and RasPi4 #48409
Hi, it is my first experience with INDI system and I have a problem with guide camera (ASI120MM-S) when the mount (CEM40) is connected ttyUSB0......
Could be the same problem ?
Could be the same problem ?
I don't manage to resolve it....

Please Log in or Create an account to join the conversation.

11 months 4 weeks ago
Cirera
Senior Member
Senior Member
Posts: 51
More
Topic Author
ttyUSB0 issues on OnStepp and RasPi4 #48415
Hi wolfi,

The DRV8825 is the stepper motor drivers (2 for mount and 1 for focus)
The indi onstep driver control the both (mount and focus).
Continue the problem...
Thanks,
Pep

Please Log in or Create an account to join the conversation.

11 months 4 weeks ago
Cirera
Senior Member
Senior Member
Posts: 51
More
Topic Author
ttyUSB0 issues on OnStepp and RasPi4 #48416
Hi Hy,

I saw in your case that you had the same vendor and product but diferent serial, but I tried in my case and not works...
About ttyUSB* I add the picture, but I only connect a USB


Then I looking for ID Vendor on ttyUSB0 and find 3 idventor :ohmy:


I'm completely lost... I don't know how to do it... The 3 idventor desapear when I disconnect the only usb as connected....

Thanks,
Pep
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: Kaczorek
Time to create page: 0.879 seconds