´╗┐
×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Changing or turning off password on the web UI

  • Posts: 30
  • Thank you received: 3
Hi, I cannot find out how to change, or even better, completely remove the password entry required when opening the web VNC desktop in a browser. The password is not related to the user password and I think it is completely useless anyway (the wireless password is enough, I think).
2 years 5 months ago #48585

Please Log in or Create an account to join the conversation.

  • Posts: 981
  • Thank you received: 374
You can change this password running:
sudo vncpasswd -service

I don't think you can remove the password at all. Try using the above with -weakpwd which permits the setting of a weak password (less than 6 characters).
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 5 months ago #48586

Please Log in or Create an account to join the conversation.

  • Posts: 30
  • Thank you received: 3
Thank you. That's strange. I will try to search on. For the docker version of noVNC there seems to be some an environment variable to disable it, so it must be possible somehow.

I would also like to know if it is possible to get to the INDI control panel (or some other INDI configurator) easier than by starting KStars and connecting to the INDI server on the localhost (cannot this happen automatically either?). For example directly from your great desktop applet.

BTW, is this control panel part of KStars? I cannot find the localization files on indilib github. I would like to fix Czech localization, since I do not think that "Park" should be translated as "City gardens" in this context ;-)

Anyway, thank you very much for Astroberry, it's really very helpful and saved me a lot of time trying to configure my own system!
2 years 5 months ago #48588

Please Log in or Create an account to join the conversation.

  • Posts: 981
  • Thank you received: 374
It is not up to noVNC, it's realVNC server that requires password. If you find a way to disable it please share. Could be useful for other users
INDI control panel is part of KStars/Ekos. You can create profile and (auto)start it with INDI Web Manager, which is also available in Astroberry sliding menu (only if you use browser to connect to your desktop)
You should look for strings in KStars repository, not INDI. Take a look at github.com/KDE/kstars
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 5 months ago #48741

Please Log in or Create an account to join the conversation.

  • Posts: 1941
  • Thank you received: 416
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chr├ętien on a SkyWatcher EQ6-R
2 years 5 months ago #48742

Please Log in or Create an account to join the conversation.

  • Posts: 30
  • Thank you received: 3
RealVNC should use the option "Authentication=None" in some of its config files (help.realvnc.com/hc/en-us/articles/36000...efore-they-start-0-0), but it does seem to have any effect wherever I try to place it. :-(

I have created a profile in the web manager UI provided by the Astroberry sliding menu, but it only offers the choice of the drivers, not the configuration or even control of the drivers. Well, so I understand the rest is only provided by the KStars UI (or the config files). So, I will just try to add real physical buttons to the Raspi or my custom joystick to control the poweroff and telecope parking - that is what I care of at the moment. Poweroff does not seem to be possible to trigger by the joystick (couldn't the AstroberryBoard driver also be controlled by the joystick buttons? it provides a shutdown trigger already), but a GPIO button and a script should solve it.
2 years 5 months ago #48843

Please Log in or Create an account to join the conversation.

  • Posts: 30
  • Thank you received: 3
Finally SOLVED! I still have no idea where the configurations is stored, but it can actually be changed very easily by the VNC control panel accessible on the desktop, via the small VNC applet on the right top of the screen. When the "VNC Server" window opens, click the menu button in the right top corner of the window and select "Options" from the menu. It will ask for your user's password and then open the Options dialog. Select the "Expert" panel on the left and then find "Authentication" in the list of parameters on the right. Set the value string manually to "None" (below the list) and confirm that you are sure you really want to disable the authentication. Click "Apply" or "OK" and you are done.
The following user(s) said Thank You: Rostislav, joaquinain
Last edit: 2 years 4 months ago by Pavel.
2 years 4 months ago #48868

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.793 seconds