×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

Default wifi option on boot up

  • Posts: 27
  • Thank you received: 2
Hi

Congrats on moving Astroberry to Raspbian for use on RPi4 ! It certainly fills a gap.....

I just wanted to ask whether you can set the default wifi connection to Astroberry hotspot on start up ?

It used this on initial boot up but after I connected to my home wifi for upgrade it now appears to default to that on boot up even if I shut it down with it connected to the hotspot

Thanks for any info

Ian
4 years 2 weeks ago #51635

Please Log in or Create an account to join the conversation.

  • Posts: 326
  • Thank you received: 50
I personally edit the WiFi connections (Right mouse button on the WiFi symbol in the taskbar) and remove my home WiFi reference from the list. It's a bit inconvenient to have to insert the password again next time I want internet access, for instance, but it seems pretty bullet proof.
The following user(s) said Thank You: Ian
4 years 2 weeks ago #51644

Please Log in or Create an account to join the conversation.

  • Posts: 163
  • Thank you received: 26

Replied by Bart on topic Default wifi option on boot up

If you look under 'edit connections' the gear symbol, you can set the priority of the hotspot higher than the wifi connection. (see screenshot)

I changed the name and SSID from Stellarmate to Observatory1.
My hotspot is at priority 10, home wifi at either 5 or 15, so above or below the hotspot. This way works fine for me.

Cheers!
The following user(s) said Thank You: Ian , Mohamed
4 years 2 weeks ago #51645
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 2
Thanks Avocette - yes that sounds good. I use both the hotspot and the home wifi so perhaps a bit drastic ! I was hoping there was some setting for the default network on boot up but at least your way sounds solid.
4 years 2 weeks ago #51678

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 2
Ah thanks Bart this is what I was looking for. When I looked at the priority settings on the edit connection Tab the hotspot was at -999 ! I have now adjusted this so it is above my home wifi and it boots up connected to the hotspot . QED
4 years 2 weeks ago #51679

Please Log in or Create an account to join the conversation.

  • Posts: 61
  • Thank you received: 8
I am using a high gain USB WiFi stick with Astroberry, additionally to the builtin WiFi. The builtin WiFi still works as an access point, whereas the external WiFi stick will try to connect to my home network. I sometimes had issues getting a good connection to my home WLAN network outside in the garden. The external USB stick was an improvement. Also, if the connection to my home network got stuck, I can still connect directly to Astroberry as a fallback.
I cannot remember the details, but setting it up was straight forward with the network manager.

CS
Guido
4 years 1 week ago #51862

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 2
Thanks for your response Guido. It is also difficult for me to connect to home wifi in the garden . I use a LAN connection with PLC terminals for remote control from the house so I do not need a WiFi dongle. I use the Astroberry hotspot for local setting up focus etc before doing the imaging run indoors with the LAN connection.
Cheers
Ian
4 years 1 week ago #51909

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.813 seconds