×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Astroberry + QHYCCD users

  • Posts: 79
  • Thank you received: 13
Main camera is ZWO294MC so guess I dodged that issue, also use other ZWOs and DSLR.
1 year 6 months ago #53809

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0

I guess you can leave all USB ports plugged in and run ekos / indi without any problems.

For QHY cameras, I have to make sure the QHY camera won't confuse with the other one by plugging in one at a time after certain settings in ekos, but I get some other error with the main camera that I'm unable to resolve.
1 year 6 months ago #53816

Please Log in or Create an account to join the conversation.

  • Posts: 81
  • Thank you received: 2

Replied by Miguel on topic Astroberry + QHYCCD users

Hi there!

I'm also an Astroberry (2.0.3) user running on a rpi4. My devices are: eq6r pro mount, electronic focuser, qhy5-ii-l mono guide cam, and a dslr as the main image camera (planning to buy a mono QHY, but still deciding). My 4 usb ports are busy. Everything is working fine. It's true I have had some problems, and actually sometimes kstars crashes or experience some strange behaviour, but I can live with it. The solution is fantastic for remote imaging.
For now I will continue using this setup, and I recommend it.

Can anybody confirm, by the way, if actually two qhy cams work together at the same time flawlessly?

Glad to find this post and exchange experiences.

Regards
2 months 3 weeks ago #75432

Please Log in or Create an account to join the conversation.

  • Posts: 51
  • Thank you received: 12
I use a 163M and 5L-II-M with my Raspberry Pi 4.
The following user(s) said Thank You: Miguel
2 months 3 weeks ago #75436

Please Log in or Create an account to join the conversation.

  • Posts: 81
  • Thank you received: 2

Replied by Miguel on topic Astroberry + QHYCCD users

thanks!! good to know!
2 months 3 weeks ago #75442

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 0
Hi all,

I've been using Kstars/Ekos via Astroberry on a Rpi4 for a while now with my DSLR etc and all is going fine.

I've just upgraded to a QHY294m-pro. Ekos can connect to the QHY camera but i have a question about its drivers. 

In the general info tab, the sdk shows 21.7.3 (see image) but i know the recent QHY SDK is 21.09.10. Should this be updated? How do i go about updating this if needed?
Also how do i know if version 2.8 and interface 2 is the most recent and if i need to update that too?

Any help would be greatly appreciated.

Cheers
2 months 2 weeks ago #75609
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 968
  • Thank you received: 367
Updates of binary drivers come along regular updates with apt . No manual update is needed nor recommended
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
The following user(s) said Thank You: Martin Ams
2 months 2 weeks ago #75619

Please Log in or Create an account to join the conversation.

  • Posts: 81
  • Thank you received: 2

Replied by Miguel on topic Astroberry + QHYCCD users

I thought updating sdk manually was good and resolved some issues. Good to know it's better not to do it!
2 months 2 weeks ago #75621

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 16

Replied by Grimaldi on topic Astroberry + QHYCCD users

Qhy cams have been updated in latest indi (git). I believe it‘ll take some time until either Raspian or Radek update repositories :-)
The following user(s) said Thank You: Martin Ams
2 months 2 weeks ago #75631

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 0
All,

So i have had a play with my new QHY294m-pro on kstars/ekos (astroberry rpi4) and have a few issues.

1. When i plug the camera into a usb3 slot, after a random short while either the indi qhy driver crashes (and kstars completely closes) or ekos freezes with weird values shown for the camera temp and cooling (image attached).
2. When i plug the camera into a usb2 slot, the system is more stable however the indi qhy driver still crashes randomly and kstars completely closes. 

Is the indi qhy driver unstable?

Can these driver crashes/issues be due to power load on the rpi4 usb slots (currently have star adv mount, ASI120 guide cam and qhy294m-pro cam plugged into rpi4) and should i iuse a powered usb3 hub?

I'm completely up to date using sudo apt update && sudo apt dist-upgrade commands (my post above shows ekos device info).
I can have the qhy camera plugged into a solid 12V AGM battery or mains supply.

Any help to get my system stable would be greatly appreciated.  

2 months 1 week ago #75730
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 81
  • Thank you received: 2

Replied by Miguel on topic Astroberry + QHYCCD users

Martin, I would definitely try with a powered usb.
I've also a rpi4, but not so many devices connected, yet. For the moment I have connected to the rpi: mount eqr6 pro, guide cam (qhy5L-II) and an electronic focuser. Everything works perfect, but I'm pretty sure I will face some power problems in the moment I connect my future QHY imaging camera. I've read it multiple times. So I will try to be prepared to face some issues. I guess the rpi power supply also could be related. How do you feed the rpi? batteries?
Afaik, the 12v power supply for the qhy camera, it's only for the tec cooler. Nothing related with usb
2 months 1 week ago #75740

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 0
All problems have been rectified. No more random driver crashes or temperature malfunctions.

Using a powered USB hub and disabling all sound notifications in KSTARS fixed everything.
Really enjoying the Astroberry server once again...
1 month 3 weeks ago #76542

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 1.347 seconds