×
INDI Library v1.8.8 Released (09 Jan 2021)

Here are the changes from v1.8.7 to v1.8.8

Beginner's Assistance Required - Astroberry Not Booting

2 months 1 week ago
bporter315
New Member
New Member
Posts: 4
More
Topic Author
Beginner's Assistance Required - Astroberry Not Booting #62712
I've been attempting to use a mini PC for several months and I seem to have one issue after another with either equipment not connecting or me not being able to remote connect into the mini PC trying various methods. I'm fed up with it and decided to give Astroberry a try. I figured either I'd get it to work or I'd have fun learning more about Raspberry Pi at the least.

That being said, I am not familiar with Raspberry Pi or programing so this is very much a learning experience for me. I followed the instructions for flashing my 32GB micro SD card with the latest release of Astroberry using Etcher on my PC. I installed the card in my Raspberry Pi 4, 8GB model, and it doesn't seem to boot properly. One of the following will happen at this point.

1) I get the "Welcome to Raspberry Pi Desktop Powered by Raspberry Pi OS (32-bit)" splash screen with a bunch of words flashing very quickly at the bottom. I'm assuming that is Astroberry booting the various modules. The boot will freeze and do one of these.
a) The welcome splash screen stays up and it says either systemd-hostnamed.service or something about network configure.
b) It will clear the welcome splash screen and go to a blank screen
2) If I disconnect power to reboot, eventually I just get a blank screen with no welcome splash

I have seen in my PC wi-fi networks that astroberry is listed and I have connected to it, but I'm not convinced that Astroberry is running properly. I have no icons in the top for Bluetooth, VNC, or wi-fi. I don't understand why I'm not getting any display on my screen other than the initial welcome splash. Any help would be appreciated.

Again, I'm using a Raspberry Pi 4 with a 32GB Panasonic microSDHC card. It appears it may be an older UHS-I card. Is it possible it's the fault of the card that Astroberry does not boot properly? It seemed to function fine when I had standard Raspberry Pi OS on it when I got it a few days ago.

Thanks in advance!

Please Log in or Create an account to join the conversation.

2 months 1 week ago 2 months 1 week ago by bporter315.
bporter315
New Member
New Member
Posts: 4
More
Topic Author
Beginner's Assistance Required - Astroberry Not Booting #62716
UPDATE: Two problems solved. Turns out, it doesn't like it when you're plugged into HDMI 1 on the Raspberry Pi. Switching to HDMI 0 seems to have fixed it not displaying on the screen. Problem with icons not displaying was due to the screen resolution in the browser window. I didn't notice the scroll bars and wasn't full screen.

In any case, I still can't seem to get my wi-fi functional to connect to my home network. I'm currently in process of updating over ethernet. Not sure if that will fix the issue or not.

UPDATE 2: So after the update, I rebooted....again. I went through the wi-fi setup process and rebooted....again. Now I'm connected to my home wi-fi. Problem is, I have no astroberry network to hotspot into now on my PC. It's listed in the Advanced Network Configuration tool on the RPi, but it's obviously not active. Might be a stupid question, but can you not have both the hotspot active and be connected to wi-fi at the same time? Would it not be setup to share the connection? Of course I can connect over VNC, but I have to know the IP address of the RPi to do so. Hard to do with a headless system. I can try and setup a static IP, but I just want to make sure I'm not completely missing something here. The way I interpreted the documentation was you would be able to hotspot directly to the Raspberry Pi with it connected to your wi-fi, but maybe I misunderstood.

Other than that, it appears to be functional. I haven't actually connected any gear to it yet.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
jabian
Premium Member
Premium Member
Posts: 110
More
Beginner's Assistance Required - Astroberry Not Booting #62748
In hotspot mode you have wifi. The wifi of your hotspot. What you do not have is internet access (i.e. connection to your home network and router).
You can get internet if you bridge your internal raspi wifi with an ethernet line from your home router.
Also you can add a external wifi dongle and have wlan0 and wlan1. I am not sure but I think you can have one of them connected to your wifi network and the other generating the wifi hotspot.

Not an expert, others could give you more specific details.

Celestron AVX
Celestron SCT 8” Edge HD, Primaluce ESATTO
TS Optics Photoline 80mm f/6 FPL53 Triplet-Apo, Primaluce SESTO SENSO 2
Celestron OAG, Lodestar X2 guide
Pegasus PowerBox Advanced
Stellarmate Gadget
AstroPhotography Tool (APT)
Nikon D90
The following user(s) said Thank You bporter315

Please Log in or Create an account to join the conversation.

2 months 1 week ago
bdavis
Junior Member
Junior Member
Posts: 30
Karma: 1
More
Beginner's Assistance Required - Astroberry Not Booting #62755
Once you've connected the Pi to your WLAN, then connect your PC to the same WLAN, and communicate with VNC. Just connect to "stellarmate.local" with VNC, and you should be good to go.
The following user(s) said Thank You bporter315

Please Log in or Create an account to join the conversation.

2 months 1 week ago
bporter315
New Member
New Member
Posts: 4
More
Topic Author
Beginner's Assistance Required - Astroberry Not Booting #62759

jabian wrote: In hotspot mode you have wifi. The wifi of your hotspot. What you do not have is internet access (i.e. connection to your home network and router).
You can get internet if you bridge your internal raspi wifi with an ethernet line from your home router.
Also you can add a external wifi dongle and have wlan0 and wlan1. I am not sure but I think you can have one of them connected to your wifi network and the other generating the wifi hotspot.

Not an expert, others could give you more specific details.


Thanks! I am not a wi-fi expert either. I just misinterpreted the write-up and instructions. And you are correct, I was able to connect an ethernet cable and then get internet on my PC through local hotspot on the Astroberry. I will probably just disable the wi-fi connection all together and keep it operating solely as a hotspot. I should only need internet when doing updates. If I ever determine a need for it, I will look into getting a dongle.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
bporter315
New Member
New Member
Posts: 4
More
Topic Author
Beginner's Assistance Required - Astroberry Not Booting #62762

bdavis wrote: Once you've connected the Pi to your WLAN, then connect your PC to the same WLAN, and communicate with VNC. Just connect to "stellarmate.local" with VNC, and you should be good to go.


I am able to connect through VNC, but there are two issues with this. The "stellarmate.local" did not work in VNC and neither did "astroberry.local". The only way I could connect is with the IP address assigned by my router. Again, this requires me to know my IP address which is not currently static. The second problem with VNC is the icons that are in the tray on the left hand side of the screen when connecting through hotspot mode are not there. While you don't necessarily need them, they are certainly useful and handy. Again, VNC works, but I believe it is missing some of the user friendly characteristics that are present in hotspot.

Please Log in or Create an account to join the conversation.

Moderators: Kaczorek
Time to create page: 1.102 seconds