×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

I want to install siril in astroberry but encountered a problem.

  • Posts: 7
  • Thank you received: 0
I want to install siril in astroberry, but none of the downloaded siril seems to work. I am a beginner, can anyone help? Thank you!
1 year 6 months ago #65470

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 39
Currently the only way to install a recent version of SiriL on the RPi is building from source. It’s not completely evident, neither extremely difficult

This are the steps I’ve followed (I think, that nothing is missing)
sudo apt install -y libgtk-3-dev libconfig-dev libfftw3-dev libexiv2-dev libopencv-dev libraw-dev libffms2-dev libheif-dev libcurl4-gnutls-dev gnuplot cmake libgsl-dev ninja-build libcurl4-openssl-dev
 
sudo pip3 install meson==0.54.2
 
git clone https://gitlab.com/free-astro/siril.git 
 
cd siril
git submodule sync --recursive
git submodule update --init --recursive 
 
meson --buildtype release _build 
ninja -C _build
sudo ninja -C _build install

Perhaps the meson version now must be other. When you run the meson step it will tell you if you need a more recent version.
The following user(s) said Thank You: ranjin
1 year 6 months ago #65474

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 1
Hi there:

Trying to get SIRIL working on the latest Stellarmate (StellarMate OS v1.7.0 32bit) but it doesn't seem to want to install libgtk or libcurl:

stellarmate@stellarmate:~/siril $ sudo apt install -y libgtk-3-dev libconfig-dev libfftw3-dev libexiv2-dev libopencv-dev libraw-dev libffms2-dev libheif-dev libcurl4-gnutls-dev gnuplot cmake libgsl-dev ninja-build libcurl4-openssl-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
cmake is already the newest version (3.16.3-3~bpo10+1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libcurl4-gnutls-dev : Conflicts: libcurl4-openssl-dev but 7.64.0-4+deb10u2 is to be installed
libcurl4-openssl-dev : Conflicts: libcurl4-gnutls-dev but 7.64.0-4+deb10u2 is to be installed
libgtk-3-dev : Depends: libatk-bridge2.0-dev but it is not going to be installed
Depends: libatk1.0-dev (>= 2.15.1) but it is not going to be installed
Depends: libcairo2-dev (>= 1.14.0) but it is not going to be installed
Depends: libgdk-pixbuf2.0-dev (>= 2.30.0) but it is not going to be installed
Depends: libglib2.0-dev (>= 2.49.4) but it is not going to be installed
Depends: libpango1.0-dev (>= 1.41) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The meson version I used was

sudo pip3 install meson==0.56.0

And it works fine but missing pre-requisites obviously. It's surprising Siril isn't pre-installed on Stellarmate considering how useful it is on scripted post-schedule tasks to calibrate images. Anyone get it working lately?
2 months 5 days ago #82680

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.781 seconds