×

INDI Library v1.9.4 Released (17 Jan 2022)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Error upgrade astroberry raspberry

  • Posts: 64
  • Thank you received: 5
I did the Astroberry update but after the indi drivers were not recognized neither ZWO 120mm nor Nikon D5300. I tried with 2 installation
Why?
INDI/KStars on Raspberry Pi 4, 4gb
Ubuntu mate
Tecnosky 70ED F 4.8
Iexos 100 Mount
Nikon D5300 Camera
ZWO ASI120mm @260mm Guide Scope
PHD2
Arduino focuser
1 year 2 weeks ago #65533

Please Log in or Create an account to join the conversation.

  • Posts: 64
  • Thank you received: 5
This error is random
INDI/KStars on Raspberry Pi 4, 4gb
Ubuntu mate
Tecnosky 70ED F 4.8
Iexos 100 Mount
Nikon D5300 Camera
ZWO ASI120mm @260mm Guide Scope
PHD2
Arduino focuser
1 year 2 weeks ago #65584

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 1
I have the same issue. After updating my Astroberry install yesterday, neither my Nikon D5500 nor my ZWO ASI120MM-Mini are detected by KStars/Ekos anymore.
What's particularly concerning is the output of lsusb:

astroberry@astroberry:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

At the same time, the cameras do show up in the dmesg log:

[ 2.051187] usb 1-1.2: new high-speed USB device number 3 using xhci_hcd
[ 2.182113] usb 1-1.2: New USB device found, idVendor=03c3, idProduct=120c, bcdDevice= 0.00
[ 2.182130] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 2.182146] usb 1-1.2: Product: ASI120MM Mini
[ 2.182162] usb 1-1.2: Manufacturer: ZWO
[ 2.281199] usb 1-1.4: new full-speed USB device number 4 using xhci_hcd

Not sure what's going on here, but maybe these logs help.
1 year 2 weeks ago #65608

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 4
I have been running Astroberry for quite a few months, but never had as many problems as tonight. Last session was December 18th. Finally I get a clear night, bring out everything, as usual. Connect everything, VNC into the Pi, launch EKOS and my usual profile. Neither camera is recognized (D5300 or ASI 224MC). The only thing I did between December 18th and tonight was plugging in the Raspberry into my ethernet this afternoon and run "sudo apt update" and "sudo apt upgrade".

I tried everything I could think of. Been outside since well before astronomical darkness (by 6 PM I had everything mounted and running). At 9.45 PM I called it quits and brought everything back inside.

I tried connecting only one camera, it works. Then another one, it works. Then the mount, then the hotspot gets dropped and I am back at square one. Turn it off, plug everything in, turn it back on - hotspot doesn't work, so I can't VNC into it. Disconnect everything, reboot, now the hotspot works. Plug the cameras, launch the profile, no camera plugged in message.

Any idea? I would like to solve this asap, since I am getting perfect skies on Sunday and I don't want to miss another opportunity. Here lately we get only clouds, rain and fog. So missing a clear night is like missing a months opportunity...
Last edit: 1 year 2 weeks ago by Matteo Gaetan.
1 year 2 weeks ago #65609

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 1
I had the same issue and the following command fixed it for me:

astroberry@astroberry:~ $ sudo rpi-update e1050e94821a70b2e4c72b318d6c6c968552e9a2
The following user(s) said Thank You: Matteo Gaetan
1 year 2 weeks ago #65615

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 4
I spent the whole part of the morning trying everything possible: from setting the hotspot of Astroberry to work in 5 GHz, to connecting the laptop straight to the Pi with an ethernet cable, to connecting Pi and laptop to the home Wi-Fi. Nothing worked. Connections kept dropping, USB ports wouldn't work, everything broken just like last night.

Finally, I gave the above command a try and reverted to the previous Pi firmware. Everything works as a charm, now. My EKOS imaging profile works in all these modes, now: hotspot, direct ethernet, and home Wi-Fi. Even with hotspot at 5 GHz.

Now I have three possible ways to connect while I am outside. I hope at least one of the three works in my next session(s).

Now the question is: why the developers of Raspberry go and break a perfectly functioning firmware to release one that doesn't work?! If it ain't broke, don't fix it - they say...!
1 year 1 week ago #65639

Please Log in or Create an account to join the conversation.

  • Posts: 64
  • Thank you received: 5
You're absolutely right, now I'm afraid to make updates.
INDI/KStars on Raspberry Pi 4, 4gb
Ubuntu mate
Tecnosky 70ED F 4.8
Iexos 100 Mount
Nikon D5300 Camera
ZWO ASI120mm @260mm Guide Scope
PHD2
Arduino focuser
1 year 1 week ago #65646

Please Log in or Create an account to join the conversation.

  • Posts: 48
  • Thank you received: 3

OK, as a Pi newbie, can you explain the "e1050..." part please?
1 year 1 week ago #65820

Please Log in or Create an account to join the conversation.

  • Posts: 157
  • Thank you received: 28
This is unrelated with Raspberry or KStars.

When you develop software, you store all the project history on a database called “a repository”. This number is a pointer inside the repository that identifies a concrete point in time when the problem you are suffering was not present.

With this command you are getting exactly this version of the source code and no newer.
The following user(s) said Thank You: David Swinnard
1 year 1 week ago #65827

Please Log in or Create an account to join the conversation.

  • Posts: 299
  • Thank you received: 45
I may have been experiencing this issue, I checked out INDI from github and compiled it to test a new driver version. While this is all probably unrelated, I had done a "apt update && apt upgrade" before the checkout.

When I went to test I found none of my ZWO devices were loading.

I thought that maybe the new INDI drivers were incompatible with the indi-3rdparty repo, so I checked that out and compiled / installed it too.

Now my ZWO devices are working again.

The root cause is probably some update to the Raspberry Kernel that means the ZWO drivers need to be rebuilt. Once that is done it will probably work, or wait until Radek updates his repo version of indi & indi-3rdparty.

I think compiling indi from git itself was probably a red herring.
__
I blog my progress: www.coochey.net
1 year 1 week ago #65830

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.723 seconds