×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Issue with autofocus for camera lens canon 450D

  • Posts: 8
  • Thank you received: 0
Hi everybody, i want to try some wide-field astrophotos with my canon 450D and the original lens (FL 18-55mm). But there is a limitation with the autofocus.

If i want to focus in and out using Ekos (Focus module), i have to set the autofocus on AF mode on the lens, this works well. But then i can't trigger capture because the camera autofocus gets confused with the dark. On the other hand, if i set the autofocus mode to Manual, i can capture but the focus routine of EKOS can't run as the lens can't be focused remotly with the focus module.

I have tried to find out a way or a setting to let the AF mode on the lens, without the camera autofocus, without success.

So my question is : do you know a way to do that, a setting in the camera or something else ?

Clear skies
Skywatcher 150/750 on HEQ5 pro using EqMod
Canon 450D IR cut filter removed - CC Baader MPCC III
Guiding with 60mm refractor and QHY5 II mono
Kstars/Ekos on RPi4
2 months 1 week ago #73671

Please Log in or Create an account to join the conversation.

  • Posts: 285
  • Thank you received: 69
I used a 400mm f/5.6 lens with my Canon DSLR once back in the day, and I didn't have the problem you're having. I let Ekos autofocus with the lens, and it worked. The camera did not try to autofocus before each shot.

The only thing I can think of, is my cameras are always setup with back button autofocus (the shutter button doesn't autofocus). On the 450D, change custom fn. 10 (shutter/AE lock button) to 1 (AE lock/AF). That will cause autofocus to be moved from the shutter button to the * (asterisk) button. Maybe that will help.
The following user(s) said Thank You: Val Chevalier
2 months 1 week ago #73695

Please Log in or Create an account to join the conversation.

  • Posts: 285
  • Thank you received: 69
Oh, one other thing, make sure the mode dial on the top of the camera is set to M, and not the green box mode or one of the scene modes.
2 months 1 week ago #73696

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
Thanks Kevin, you solved my problem. The issue comes from the custom setting fn. 10 (shutter/AE lock button) to 1 (AE lock/AF). I had never really cared about this setting, i remember picking it up from somewhere on a forum.

About the M mode, i always set it to Manual.

Thanks again

Clear skies
Skywatcher 150/750 on HEQ5 pro using EqMod
Canon 450D IR cut filter removed - CC Baader MPCC III
Guiding with 60mm refractor and QHY5 II mono
Kstars/Ekos on RPi4
2 months 1 week ago #73705

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
Does the Ekos focus module work well for Canon DSLR camera's ?
Even at high focal lengths ?
Would be pretty cool. Now I am always doing things by hand with the bahtinov mask.
2 months 6 days ago #73809

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
Hi Paul,

So for me the Focus module runs well except the autofocus process, but i have not really tested it in the field. I have only tested it at home in a big town, without any mount. To sum up, up to now,i can focus in and out with the command but the autofocus routine does not work properly for fl around 55 50 and 45mm. But that's not really relevant as i have not tried it yet in the field, on a mount and under a good dark night. And i am not really familiar with the routine and its settings.
Skywatcher 150/750 on HEQ5 pro using EqMod
Canon 450D IR cut filter removed - CC Baader MPCC III
Guiding with 60mm refractor and QHY5 II mono
Kstars/Ekos on RPi4
2 months 5 days ago #73828

Please Log in or Create an account to join the conversation.

Time to create page: 0.436 seconds