×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

ASI6200 cannot load 16 bits images into Raspberry Pi4

  • Posts: 161
  • Thank you received: 13
Running into the issue again with the ASI6200, which files are too large to be handled by the Raspberry Pi4 (8GB, Linux Mate 20.04.3 LTS). In 8-bit mode all fine, but in 16-bit mode, it cannot handle it (not even binned captures). On my Fitlet computer (also 8GB, but with Intel Atom X7-E3950 and Ubuntu Mint 20.04) I had this issue before and that could be solved by increasing the memory allocation in the Indi webserver. That was handled in the file \\usr\local\lib\python2.7\dist-packages\indiweb\indi_server.py.
But on my Raspberry Pi4, I cannot find that directory or file, so have no idea where to make the adjustments. 
Would anybody be able to point me to the right location to change the memory allocation? Or has this been changed in the meantime and should be addressed somehow else?
Willem Jan Drijfhout
astroworldcreations.com
1 year 1 month ago #76324

Please Log in or Create an account to join the conversation.

It was increased in INDI Web Manager but I guess a new PIP package was not released, let me know follow up with that.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 1 month ago #76357

Please Log in or Create an account to join the conversation.

  • Posts: 124
  • Thank you received: 28
Hi Jasem,
yes the PIP package was nit released. We talked in another thread about this. Willem-Jan: you could change this entry manually after installed the web manager, but this is not ideal for longer time.
Michel
1 year 1 month ago #76374

Please Log in or Create an account to join the conversation.

  • Posts: 161
  • Thank you received: 13
Thank you for the responses. Tried using the web manager and increased the memory allocation in Indi_server.py, but unfortunately did not work. Still the same. 8-bit images fine, 16 bit images don't show up from the ASI6200. Even increased the memory allocation to 200, but nothing. Anything else I could try?
Willem Jan Drijfhout
astroworldcreations.com
1 year 1 month ago #76471

Please Log in or Create an account to join the conversation.

  • Posts: 161
  • Thank you received: 13
Must be a setting somewhere. Just tried Stellarmate on the same RPi4, and it worked.
Willem Jan Drijfhout
astroworldcreations.com
1 year 1 month ago #76472

Please Log in or Create an account to join the conversation.

  • Posts: 124
  • Thank you received: 28
Willem-Jan,

find the site packages in RPI4 with
python3 -m site

check if indiweb is in

change to indiweb dir

open indi_server.py
find line
cmd = 'indiserver -p %d -m 100 -v -f %s > /tmp/indiserver.log 2>&1 &' % (port, self.__fifo)

and change it to
cmd = 'indiserver -p %d -m 1000 -v -f %s > /tmp/indiserver.log 2>&1 &' % (port, self.__fifo)

manually and restart indiweb. Hop this helps.
Michel
Last edit: 1 year 1 month ago by Michael. Reason: override startup parameter
1 year 1 month ago #76473

Please Log in or Create an account to join the conversation.

  • Posts: 161
  • Thank you received: 13
Thanks Michael.
It does look like the indiweb directory is not the site packages. How can I add that?
I increased the memory allocation now to 1000 as per your suggestion. This is where I earlier tried 160 and 200. Unfortunately still the same problem.
Willem Jan Drijfhout
astroworldcreations.com
1 year 1 month ago #76477

Please Log in or Create an account to join the conversation.

  • Posts: 124
  • Thank you received: 28
Somehow there must be a location from where the indiweb is loaded. Not to easy to tell where on linux. Even though it might be more than one location. The change to 1000 was the value I did - and which is btw. the value in the actual repo on GitHub - and since using this I get 1x1 bin images from my QHY600 (see this thread as well).
Michel
1 year 1 month ago #76478

Please Log in or Create an account to join the conversation.

Time to create page: 0.265 seconds