×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

indi_gphoto_ccd missing

  • Posts: 5
  • Thank you received: 0
I recently installed a 32-bit version of Mint Cinnamon on an old Dell laptop.  I installed Kstars using the Software Manager provided in that distro.  However, the DLSR drivers, including indi_gphoto_ccd, are missing.  Indiserver and other drivers are there but not indi_gphoto_ccd.  I have tried to install via terminal using the instructions for ubuntu, however, I am getting a keyserver error when trying to add the respository.. 
1 month 1 week ago #78323

Please Log in or Create an account to join the conversation.

You need to try again, unless the INDI repo is added you cannot use 3rd party drivers like INDI GPhoto.. the key error might be some transient issue.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 month 1 week ago #78339

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0

Replied by Allen on topic indi_gphoto_ccd missing

Here is the response to me trying:

sudo apt-add-repository ppa:mutlaqja/ppa

Terminal response:

Executing: /tmp/apt-key-gpghome.XUfJ1eg0S7/gpg.1.sh --keyserver hkps://keyserver.ubuntu.com:443 --recv-keys 7DA5C2D272B4C6F8E7CEA9C6487CEC2B3F33A288
gpg: key 487CEC2B3F33A288: "Launchpad INDI" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

 
1 month 1 week ago #78340

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0

Replied by Allen on topic indi_gphoto_ccd missing

I went back to the beginning.  I reinstalled 32bit Linux Mint 19.3.  I updated and upgrade it.  Then added ppa:mutlaqja/ppa and reloaded launchpad keys using the software manager.  When I issued the sudo apt-get install indi-full here is what terminal did:

myusername@DelLaptop:~$ sudo apt-get install -y indi-full gsc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 indi-full : Depends: libindi1 (>= 1.7) but it is not installable
             Depends: indi-eqmod but it is not going to be installed
             Depends: indi-sx but it is not going to be installed
             Depends: indi-sbig but it is not going to be installed
             Depends: indi-apogee but it is not going to be installed
             Depends: indi-gphoto but it is not going to be installed
             Depends: indi-qsi but it is not going to be installed
             Depends: indi-fishcamp but it is not going to be installed
             Depends: indi-maxdomeii but it is not going to be installed
             Depends: indi-asi but it is not going to be installed
             Depends: indi-aagcloudwatcher but it is not going to be installed
             Depends: indi-ffmv but it is not going to be installed
             Depends: indi-dsi but it is not going to be installed
             Depends: indi-qhy but it is not going to be installed
             Depends: indi-gpsd but it is not going to be installed
             Depends: indi-mi but it is not going to be installed
             Depends: indi-duino but it is not going to be installed
             Depends: indi-fli but it is not going to be installed
             Depends: indi-nexstarevo but it is not going to be installed
             Depends: indi-nexdome but it is not going to be installed
             Depends: indi-gpsnmea but it is not going to be installed
             Depends: indi-armadillo-platypus but it is not going to be installed
             Depends: indi-mgen but it is not going to be installed
             Depends: indi-shelyak but it is not going to be installed
             Depends: indi-nightscape but it is not going to be installed
             Depends: indi-altaircam but it is not going to be installed
             Depends: indi-toupcam but it is not going to be installed
             Depends: indi-atik but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

 
1 month 1 week ago #78363

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0

Replied by Allen on topic indi_gphoto_ccd missing

When I try to add the ppa:mutlaqja/ppa using the command I still get this as I did berfore:

myusername@DelLaptop:~$ sudo apt-add-repository ppa:mutlaqja/ppa
[sudo] password for myusername:
You are about to add the following PPA:
Latest INDI Library and drivers!

This PPA is for stable Ekos & INDI drivers releases.
More info: launchpad.net/~mutlaqja/+archive/ubuntu/ppa
Press Enter to continue or Ctrl+C to cancel

Executing: /tmp/apt-key-gpghome.bqHfgpqIds/gpg.1.sh --keyserver hkps://keyserver.ubuntu.com:443 --recv-keys 7DA5C2D272B4C6F8E7CEA9C6487CEC2B3F33A288
gpg: key 487CEC2B3F33A288: "Launchpad INDI" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
1 month 1 week ago #78365

Please Log in or Create an account to join the conversation.

Sorry, 32bit x86 support was dropped long ago, only 64bit is supported.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 month 1 week ago #78374

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0

Replied by Allen on topic indi_gphoto_ccd missing

I thought it might be a 32bit issue. Was worth the ask.

Thanks for all your good work...
1 month 1 week ago #78375

Please Log in or Create an account to join the conversation.

Time to create page: 0.606 seconds