Welcome, Guest
Username: Password: Remember me
14 Nov 2018
Glad to announce of release of INDI Library v1.7.5 on 2018-11-14. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: Orion Starshoot Autoguider

Orion Starshoot Autoguider 2 years 1 month ago #11473

  • myxlflik
  • myxlflik's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 128
  • Karma: 2
  • Thank you received: 6
It looks like I may have forgotten to submit a reply earlier. I have gotten PHD2 to consistently recognize my camera as long as I don't use the INDI drivers. If I run PHD2 and select the QHY5 driver and on camera for the mount, I am able to consistently connect to and capture with my SSAG. If I use the INDI Camera selection it does not work for me. I don't mind running PHD2 separately from Ekos, but would ultimately like it to work with the INDI driver so I can use the Ekos internal guiding if I choose to do so. I am not sure if it make a difference or not here, but I am running my setup locally on a Linux Mint 17 install. I have multiple laptops setup for it. I am currently not using a Pi3 nor am I doing a headless operation. I wanted to keep things as simple as possible for now.

Please Log in or Create an account to join the conversation.

Orion Starshoot Autoguider 2 years 1 month ago #11475

FYI you need Mint 18 for latest INDI & Ekos

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Orion Starshoot Autoguider 2 years 1 month ago #11477

  • myxlflik
  • myxlflik's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 128
  • Karma: 2
  • Thank you received: 6
Sorry. That was a typo. I am on Linux Mint 18.

Please Log in or Create an account to join the conversation.

Orion Starshoot Autoguider 2 years 1 month ago #11481

Jasem:
After my previous post, and you pointing out my error, I've attached a pdf with screen shots of the setup and the steps I've taken to make it run. It's working as near as I can tell. I had planned to get the scope outside tonight and try all of this out but it's just cloudy enough that I'm not. However, I'm dry running inside and everything appears to be working and if I tell the Guiding Module to "Guide" with PHD2 enabled, it starts looping the imager and trying to find a star, etc. to calibrate. So I think it's working.

Please review the file I attached and let me know if it is all correct. If so, I can expand this a bit if you like, with more steps and details so it can be posted for others to benefit from.
THANKS AGAIN!
Attachments:
The following user(s) said Thank You: knro

Please Log in or Create an account to join the conversation.

Orion Starshoot Autoguider 2 years 1 month ago #11489

u2pilotjt wrote: Jasem:
After my previous post, and you pointing out my error, I've attached a pdf with screen shots of the setup and the steps I've taken to make it run. It's working as near as I can tell. I had planned to get the scope outside tonight and try all of this out but it's just cloudy enough that I'm not. However, I'm dry running inside and everything appears to be working and if I tell the Guiding Module to "Guide" with PHD2 enabled, it starts looping the imager and trying to find a star, etc. to calibrate. So I think it's working.

Please review the file I attached and let me know if it is all correct. If so, I can expand this a bit if you like, with more steps and details so it can be posted for others to benefit from.
THANKS AGAIN!


James, this looks good to me! Good luck in your run. I'll try to include this in the Guide FAQs when I create it!

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Orion Starshoot Autoguider 2 years 1 month ago #11498

knro wrote:

u2pilotjt wrote: Jasem:
After my previous post, and you pointing out my error, I've attached a pdf with screen shots of the setup and the steps I've taken to make it run. It's working as near as I can tell. I had planned to get the scope outside tonight and try all of this out but it's just cloudy enough that I'm not. However, I'm dry running inside and everything appears to be working and if I tell the Guiding Module to "Guide" with PHD2 enabled, it starts looping the imager and trying to find a star, etc. to calibrate. So I think it's working.

Please review the file I attached and let me know if it is all correct. If so, I can expand this a bit if you like, with more steps and details so it can be posted for others to benefit from.
THANKS AGAIN!


James, this looks good to me! Good luck in your run. I'll try to include this in the Guide FAQs when I create it!

Great! Glad I finally contributed in a meaningful way. When you do get the FAQ going, I would emphasize the importance of doing things in the right order because I think that was one of my big problems when trying to make it work. I would be glad to clean that file up a bit so it looks more like a set of instructions as well as install notes if you like; save you some work.

Please Log in or Create an account to join the conversation.

Orion Starshoot Autoguider 2 years 1 month ago #11601

I updated QHY driver so that binning works for SSAG. Please try it out in KStars and let me know if it works.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Orion Starshoot Autoguider 2 years 1 month ago #11615

knro wrote: I updated QHY driver so that binning works for SSAG. Please try it out in KStars and let me know if it works.


Jasem, just to eliminate the probably user error on my part, I want to make sure I have updated the software on my end properly. I did
sudo apt-get update
sudo apt-get upgrade

Is that all that's needed for a driver update such as this? I also went and installed the indi-qhy driver per the devices instructions just to make sure. I did a restart after the update/upgrade

With that said, I opened Kstars and connected my SSAG as a QHY CCD and I still cannot selecting binning other than 1x1 in the guider module. I tried setting binning to 2x2 inside of phd2 and it returned it to 1x1 immediately. In the log file is says, "QHY CCD QHY5-0-M- : "SetBin mode failed. Invalid bin requested 2x2"

Please Log in or Create an account to join the conversation.

Orion Starshoot Autoguider 2 years 1 month ago #11627

The new driver is now built. Usually when I say try something, the PPA build process takes about 24 hours to refresh. So do apt-get update and upgrade and it should be ready.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Last Edit: by knro.

Orion Starshoot Autoguider 2 years 1 month ago #11699

Jasem -
I installed the updates. I'm seeing some interesting behavior. First, I can now select the various binning settings; so that definitely has changed.

When I start Kstars, then open the Ekos - Kstars module and start INDI, then use the Connect button to connect all of the devices - if I don't have ALL of the devices turned on so they can connect, then the Guider Module has all the buttons grayed out and I can't do anything. However, if I go into INDI control panel and turn the QHY CCD on individually, then it works. IF I power everything up and use the connect button, then it works fine.

Second, once I get the guider module to actually see the guide CCD, when I set binning to anything other that 1x1, the capture image is completely white, even if the guider CCD is covered. At 1x1 it appears to be fine. This is all indoors, since the weather here is bad, but I think something funny is going on if I'm getting a completely white image at capture. I can select 2x3 3x3 and 4x4 ut the results are the same. I had the guider module do a dark as well to see if anything changed and it's still all white.

Please Log in or Create an account to join the conversation.

Orion Starshoot Autoguider 2 years 1 month ago #11769

So it appears that QHY SDK performs binning that would up in saturating an 8bit image. I now forced QHY to use "software binning" which is defined by the INDI CCD driver and the results seems to be OK now (at least indoors). So hopefully by tomorrow you'd get an update and you can test that again.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Orion Starshoot Autoguider 2 years 3 weeks ago #12379

Finally got around to testing this - updated everything via apt-get this evening - and I see the all white capture problem I think.

It is strange though and unpredictable. It was all white to start with - over saturated - at any of the possible binning values, but when I started taking darks I was able to get it to take seemingly normal saturations.

But this could also be something about the camera where the first captures are completely oversaturated until some other thing happens to correct the oversaturated issue - what that could be. I was seeing this before the update, but never when running PHD2 directly on the device.

The binning is all selectable except for the 3x3 option. 1x1, 2x2 or 4x4 work.

Please Log in or Create an account to join the conversation.

Last Edit: by jonbelanger.
Time to create page: 0.188 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica