×
INDI Library v1.8.8 Released (09 Jan 2021)

Here are the changes from v1.8.7 to v1.8.8

Atik 383L+ buffer size causing SX Lodestar X2 to timeout

3 years 2 months ago 3 years 2 months ago by jpaana.
jpaana
Elite Member
Elite Member
Posts: 296
Karma: 7
More
Topic Author
Atik 383L+ buffer size causing SX Lodestar X2 to timeout #20551
I solved my problem so this is just a heads up if someone else happens to bump in to the same issue. I recently moved from Raspberry Pi 3 to X86 based Udoo X86 Ultra minipc for my imaging and for some reason my setup which had worked fine previously just didn't anymore. I use Atik 383L+ for imaging and Lodestar X2 for guiding and the Lodestar always stopped responding a while after starting a sequence and didn't recover until powered down and up again. Today I noticed that it always happened during image download from the Atik and I remembered there was a difference in buffer size for the Atik between ARM and X64 builds and lo and behold, dropping the buffer size from 24 MB to 8 MB like it is on the ARM made everything work again. I don't know if the root cause is that they are both behind the same StarTech USB 3 hub or not, but at least this way everything works again.

Remote observatory running Ubuntu 20.04 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub

Please Log in or Create an account to join the conversation.

3 years 2 months ago
knro
Administrator
Administrator
Posts: 8731
Karma: 51
Atik 383L+ buffer size causing SX Lodestar X2 to timeout #20559
This is the buffer size for what exactly? USB bulk transfers?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

3 years 2 months ago
jpaana
Elite Member
Elite Member
Posts: 296
Karma: 7
More
Topic Author
Atik 383L+ buffer size causing SX Lodestar X2 to timeout #20561
I guess so, there is a driver option for it and it's 8 by default for ARM and 24 for X86.

Remote observatory running Ubuntu 20.04 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub

Please Log in or Create an account to join the conversation.

5 months 1 week ago
the.cakemaker
Elite Member
Elite Member
Posts: 321
More
Atik 383L+ buffer size causing SX Lodestar X2 to timeout #58010
I saw your thread here an have a question.

I use a Lodestar X2 too for guiding, and a Moravian G2 8300 colour for imaging.
I have the problem that the lodestar keeps timing out all of the time.
My only solution to this atm is to set the lodestar on binning 2x2, this way it works fine.

Could you explain a bit clearer for me, what exactly and where you changed the buffersize?

Maybe this would work for me too.

greetings
Niki

Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina

Please Log in or Create an account to join the conversation.

5 months 1 week ago
jpaana
Elite Member
Elite Member
Posts: 296
Karma: 7
More
Topic Author
Atik 383L+ buffer size causing SX Lodestar X2 to timeout #58017
There was a buffer size option in the old closed source CloudMakers Atik driver so I don't know what it did precisely but probably set the buffer used for image bulk transfer from the camera. My theory is that the smaller transfers allowed other devices to use the bus more often and avoid timing out. I don't know if there is something similar in the Moravian driver or something like the USB utilization configuration in ASI driver.

Remote observatory running Ubuntu 20.04 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
The following user(s) said Thank You the.cakemaker

Please Log in or Create an account to join the conversation.

Time to create page: 0.740 seconds