×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Cannot play back SER videos?

  • Posts: 33
  • Thank you received: 0
Hi. I've just captured a load of SER video files with Ekos using my QHY5L-II mono camera. Everything seemed to go okay and the live video stream showed up correctly.

I'm now trying to play back the captured files and none of the programs I tried are displaying them correctly. The attached screenshot shows what they typically look like. What could be the problem?

I tried SER Player, Registax, Autostakkert and WinJupos all showing the same problem.
Last edit: 3 years 1 month ago by Kari Brown.
3 years 1 month ago #29182
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 778
  • Thank you received: 101
Are those 8bit or 16bit? I'm (also) not able to record valid SER files in 16bit in EKOS with my ASI cameras.

Edit: Forgot the 'in 16bit' - 8bit works.
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
Last edit: 3 years 1 month ago by Peter Sütterlin.
3 years 1 month ago #29189

Please Log in or Create an account to join the conversation.

Can you post a link to the SER file itself?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 years 1 month ago #29198

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 0
My videos are 8-bit. I've managed to narrow the problem down to the fact that I used cropping (Left: 320, Top: 240, Width: 640, Height: 480) while capturing the videos. Full frame videos seem to play back just fine. I've uploaded an example of these here:

www.dropbox.com/sh/uqnoj2gyhths6k7/AAByT...YwsyTcjuHoFibqa?dl=0
3 years 1 month ago #29243

Please Log in or Create an account to join the conversation.

  • Posts: 778
  • Thank you received: 101
I cannot comment on the error in the SER file, but just had a try with my own setup (EKOS/KStars 2.9.8, INDI 1.7.4, ASI1600MM Pro).
I can record full frame and partial frame 8bit SER movies with it. Like yours, the full frame video plays fine in ser-player (1.7.2.15).
I can load and play the partial frame video, but several of the frames are broken, showing an intensity step. I currently cannot tell if that is a shift in readout area or some exposure issue (or both) as the scope is only looking at a whitish wall... Will try to find out.
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
3 years 1 month ago #29252

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 0
Feels like the cropped area doesn't get written to the file correctly as all the various players I've tried are showing the problem same way.

Jasem: Did you have any luck with the files I linked?
3 years 1 month ago #29334

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 5
I checked out your cropped and non-cropped files and they are exactly the same size (36,001KB).

The header of the cropped SER file claims that the frame size is 640 x 480, but the frame data is clearly not actually cropped and is actually the full frame data (1280 x 960). This will be why no software is able to play it.

Cheers,
Chris
The following user(s) said Thank You: Jasem Mutlaq, Alfred, Kari Brown
3 years 1 month ago #29370

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 0
That's helpful! Thank you! Wonder if there is a way to edit the header? I've got gigabytes of data of (cropped) mars. If I could just tell the software it's not actually cropped I might be able to revive the files...
3 years 1 month ago #29390

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 5
Yes, editing the header would be simple and would fix the files. You just need a hex editor. I can tell you the bytes you need to edit if you wish.
What OS are you using?
The following user(s) said Thank You: Alfred
Last edit: 3 years 1 month ago by Chris Garry.
3 years 1 month ago #29391

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 5
To set the frame size to 1280 x 960 you need to ensure the bytes in the file are set to the following:

Address: Value
0x001A: 0x00
0x001B: 0x05
0x001C: 0x00
0x001D: 0x00
0x001E: 0xC0
0x001F: 0x03
0x0020: 0x00
0x0021: 0x00

I just tried with your broken SER file and it fixed the file.
The following user(s) said Thank You: Alfred
Last edit: 3 years 1 month ago by Chris Garry.
3 years 1 month ago #29396

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 0
Awesome, that works. I'll just write a simple script to apply this fix to all of my broken files.

Cheers,
Kari
3 years 1 month ago #29399

Please Log in or Create an account to join the conversation.

  • Posts: 509
  • Thank you received: 102

Replied by Jim on topic Cannot play back SER videos?

Excellent, this could be the problem that has been plaguing me for some time. I haven't had time to look into it more, but will have to try some .ser again to see.
12" pier with HDX110 using EQMod
ASI 1600 mono/color mains with ASI290MM in off-axis
ASI filter wheel
Moonlite focusers for the sharpening
AT115EDT w/.8x for the light
Fedora Linux, 100% INDI
3 years 1 month ago #29416

Please Log in or Create an account to join the conversation.

Time to create page: 0.763 seconds