×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Cannot play back SER videos?

  • Posts: 43
  • Thank you received: 25
Yes, for that reason I only use KStars/Ekos for Deep Sky Photography.
It works fantastic for that purpose.

But when I do planetary, I always use FireCapture.
It would be nice if the video recording feature of Ekos could integrate with FireCapture somehow.
Or if the issues with video recording could be fixed.

FireCapture is very resource demanding on a Raspberry Pi.
1 year 1 month ago #58960

Please Log in or Create an account to join the conversation.

  • Posts: 604
  • Thank you received: 58
Yes. I installed and tried FireCapture on RPI4 once - it is very resource demanding.
Don't want to go to Windows for that. Would be really nice if StellarMate provided some useful tool for video capture.
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
AT72EDII, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
1 year 1 month ago #58962

Please Log in or Create an account to join the conversation.

  • Posts: 189
  • Thank you received: 108
You can try using oacapture for planetary. I use it on my NUC. I haven't tried it yet on a RPI4 yet.
Gayle H Riggsbee Observatory - Charlotte Amateur Astronomers Club
CEM120 - TMB 100/800 - AT72EDII w/Homemade Moonlite Compatible Arduino Focuser - AT8RC w/Moonlite CSL 2.5" w/Moonlite Stepper v3
ZWO ASI2600MC-Pro - ZWO ASI2600MM-Pro - ZWO ASI174MM-Mini - ZWO OAG - ZWO EFW
AT2FF - CCDT67 - RIRED-M63
1 year 1 month ago #58977

Please Log in or Create an account to join the conversation.

I added this to my TODO, hopefully I'll get time to tackle it shortly.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 1 month ago #58994

Please Log in or Create an account to join the conversation.

  • Posts: 604
  • Thank you received: 58
I tried to install oacapture on RPI4 a few months ago but was not successful..
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
AT72EDII, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
1 year 1 month ago #59030

Please Log in or Create an account to join the conversation.

  • Posts: 604
  • Thank you received: 58
Jasem,
I do realize that you are busy with other things.
But can this be fixed please?
-- 16bit SER files are not readable (which is probably OK - 8bit are readable).
-- cropped to ROI SER files are corrupted and not readable. (this feature is advertised as functional).

It would be great if Ekos had at least some basic planetary capabilities.

At present it only can record full frame 8-bit SER files.

Thanks!

Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
AT72EDII, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
Last edit: 11 months 2 weeks ago by maxthebuilder.
11 months 2 weeks ago #62339

Please Log in or Create an account to join the conversation.

What camera is this? I can do both 16bit and also subframes.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
11 months 2 weeks ago #62344

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 10

Replied by nou on topic Cannot play back SER videos?

I have same problem. Recording with ASI1600 ROI in 16 bit mode result in just bunch of noise. Also the timestamps are all over the place like year 10000 and such. I am using ser-player to play back recorded files. But with some ROI sizes it seems like it can record properly. Like 500x500 it is recording fine but tanything smaller result in noise. Also I am not entirely sure but there may be difference where I set image size if in Image tab or Streaming tab of control panel. Also when I set 300x300 pixels it change it to 296x300
Last edit: 11 months 2 weeks ago by nou.
11 months 2 weeks ago #62346

Please Log in or Create an account to join the conversation.

  • Posts: 604
  • Thank you received: 58
Last time I tried it was ASI071MC Pro.
-- 16 bit. It records but frames look weird. As if they were grossly overexposed.
-- 8 bit. OK.
-- 8 bit. ROI. Noise. But I haven't tried square ROI. ROI was selected in Live View window.

Will experiment more tonight.
Thanks!
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
AT72EDII, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
11 months 2 weeks ago #62354

Please Log in or Create an account to join the conversation.

  • Posts: 604
  • Thank you received: 58
OK. Did some experimenting.
SM 1.5.4 (recent but not one of the latest betas with the new internal solver). RPI4 4Gb. ASI294MC Pro.

SER files were acquired on RPI. Single frames were extracted on Windows 10 PC with SER Player.
Frames resized to 25%.
Exposure time and gain were the same for all recordings.

Summary:
16 bit doesn't work properly. SER recordings look bad but individual captures and Live Video looked fine!
8 bit works except for cropping in Live Video.

16 bit full frame:


16 bit cropped in Live Video window:


16 bit cropped in Capture settings:


8 bit full frame:


8 bit cropped in Live Video window:


8 bit cropped in Capture settings:
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
AT72EDII, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
11 months 2 weeks ago #62382

Please Log in or Create an account to join the conversation.

So I can confirm that 16bit look "bad", but I'm not sure what's causing this. Byte swapping required?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
11 months 2 weeks ago #62385

Please Log in or Create an account to join the conversation.

  • Posts: 604
  • Thank you received: 58
I have no idea why but two things are not right:
-- 16 bit and
-- ROI selection in Live Video for both 8 and 16bit.

8 bit is fine except for ROI in Live Video.

Thanks!
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
AT72EDII, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
11 months 2 weeks ago #62386

Please Log in or Create an account to join the conversation.

Time to create page: 1.542 seconds