×
INDI Library v1.8.7 Released (21 Nov 2020)

Nov. 2020 Release brings significant improvements to streaming and recording videos. Support for new drivers including Estatto focuser and Pegasus falcon rotator.

SONY SLT-A55 not connecting to INDI

2 years 2 months ago
philpugh51
Fresh Boarder
Fresh Boarder
Posts: 14
More
Topic Author
SONY SLT-A55 not connecting to INDI #29366
New user of KSTARS / INDI here.

I have a Sony SLT-A55 that I would like to use for imaging. Reading the information - which can be a bit confusing sometimes - it should work.
When I start EKOS I get a pop up :-

"[WARNING] Warning: Didn't find an exposure widget! Are you sure the camera is set to Bulb mode? "

It is in BULB mode.

I am running UBUNTU 18.04 with latest INDI - all software installed from scratch 2 days ago and latest updates applied. Below is an extract from the INDI log file.

Any pointers please?

[2018-09-07T09:04:12.832 BST DEBG ][ org.kde.kstars.indi] - INDIListener: Adding a new client manager to INDI listener..
[2018-09-07T09:04:12.832 BST DEBG ][ org.kde.kstars.indi] - INDI: Connecting to local INDI server on port 7624 ...
[2018-09-07T09:04:12.833 BST DEBG ][ org.kde.kstars.indi] - INDI server connected.
[2018-09-07T09:04:12.833 BST DEBG ][ org.kde.kstars.indi] - Connection to INDI server is successful
[2018-09-07T09:04:12.833 BST INFO ][ org.kde.kstars.ekos] - "INDI services started on port 7624."
[2018-09-07T09:04:12.841 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: startup: /usr/bin/indiserver -v -p 7624 -f /tmp/indififo6b1d4999 "
[2018-09-07T09:04:12.841 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: listening to port 7624 on fd 3"
[2018-09-07T09:04:12.841 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "FIFO: start indi_sony_ccd"
[2018-09-07T09:04:12.841 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "FIFO: Starting driver indi_sony_ccd"
[2018-09-07T09:04:12.842 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: Driver indi_sony_ccd: pid=3292 rfd=4 wfd=7 efd=8"
[2018-09-07T09:04:12.842 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: Client 5: new arrival from 127.0.0.1:38260 - welcome!"
[2018-09-07T09:04:12.842 BST DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2018-09-07T09:04:12.910 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: Driver indi_sony_ccd: Number of cameras detected: 1."
[2018-09-07T09:04:12.910 BST DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2018-09-07T09:04:12.911 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: Driver indi_sony_ccd: snooping on Telescope Simulator.EQUATORIAL_EOD_COORD"
[2018-09-07T09:04:12.911 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: Driver indi_sony_ccd: snooping on Telescope Simulator.TELESCOPE_INFO"
[2018-09-07T09:04:12.911 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: Driver indi_sony_ccd: snooping on Telescope Simulator.GEOGRAPHIC_COORD"
[2018-09-07T09:04:12.911 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: Driver indi_sony_ccd: snooping on Focuser Simulator.ABS_ROTATOR_ANGLE"
[2018-09-07T09:04:12.911 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: Driver indi_sony_ccd: snooping on CCD Simulator.FILTER_SLOT"
[2018-09-07T09:04:12.911 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: Driver indi_sony_ccd: snooping on CCD Simulator.FILTER_NAME"
[2018-09-07T09:04:12.911 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:12: Driver indi_sony_ccd: snooping on SQM.SKY_QUALITY"
[2018-09-07T09:04:12.911 BST DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2018-09-07T09:04:12.911 BST DEBG ][ org.kde.kstars.indi] - Received new device Sony DSLR SLT-A55 (PTP mode) 0
[2018-09-07T09:04:12.916 BST DEBG ][ org.kde.kstars.indi] - INDIListener: New device Sony DSLR SLT-A55 (PTP mode) 0
[2018-09-07T09:04:12.917 BST INFO ][ org.kde.kstars.ekos] - Ekos received a new device: Sony DSLR SLT-A55 (PTP mode) 0
[2018-09-07T09:04:12.918 BST DEBG ][ org.kde.kstars.indi] - < Sony DSLR SLT-A55 (PTP mode) 0 >: < CONNECTION >
[2018-09-07T09:04:12.950 BST DEBG ][ org.kde.kstars.indi] - < Sony DSLR SLT-A55 (PTP mode) 0 >: < DRIVER_INFO >
[2018-09-07T09:04:12.994 BST DEBG ][ org.kde.kstars.indi] - < Sony DSLR SLT-A55 (PTP mode) 0 >: < POLLING_PERIOD >
[2018-09-07T09:04:13.004 BST DEBG ][ org.kde.kstars.indi] - < Sony DSLR SLT-A55 (PTP mode) 0 >: < DEBUG >
[2018-09-07T09:04:13.008 BST DEBG ][ org.kde.kstars.indi] - < Sony DSLR SLT-A55 (PTP mode) 0 >: < SIMULATION >
[2018-09-07T09:04:13.013 BST DEBG ][ org.kde.kstars.indi] - < Sony DSLR SLT-A55 (PTP mode) 0 >: < CONFIG_PROCESS >
[2018-09-07T09:04:13.014 BST DEBG ][ org.kde.kstars.indi] - < Sony DSLR SLT-A55 (PTP mode) 0 >: < ACTIVE_DEVICES >
[2018-09-07T09:04:13.019 BST DEBG ][ org.kde.kstars.indi] - < Sony DSLR SLT-A55 (PTP mode) 0 >: < DEVICE_PORT >
[2018-09-07T09:04:13.025 BST INFO ][ org.kde.kstars.indi] - Sony DSLR SLT-A55 (PTP mode) 0 : "[WARNING] Warning: Didn't find an exposure widget! Are you sure the camera is set to Bulb mode? "
[2018-09-07T09:04:13.301 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "Child process 3292 died"
[2018-09-07T09:04:13.301 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:13: Driver indi_sony_ccd: stderr EOF"
[2018-09-07T09:04:13.302 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:13: Driver indi_sony_ccd: restart #1"
[2018-09-07T09:04:13.302 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:13: Driver indi_sony_ccd: pid=3304 rfd=4 wfd=8 efd=9"
[2018-09-07T09:04:13.302 BST DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2018-09-07T09:04:13.302 BST CRIT ][ org.kde.kstars.indi] - INDI driver "indi_sony_ccd" crashed!
[2018-09-07T09:04:13.385 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:13: Driver indi_sony_ccd: Number of cameras detected: 1."
[2018-09-07T09:04:13.385 BST DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2018-09-07T09:04:13.385 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:13: Driver indi_sony_ccd: snooping on Telescope Simulator.EQUATORIAL_EOD_COORD"
[2018-09-07T09:04:13.385 BST DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2018-09-07T09:04:13.385 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:13: Driver indi_sony_ccd: snooping on Telescope Simulator.TELESCOPE_INFO"
[2018-09-07T09:04:13.385 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:13: Driver indi_sony_ccd: snooping on Telescope Simulator.GEOGRAPHIC_COORD"
[2018-09-07T09:04:13.385 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:13: Driver indi_sony_ccd: snooping on Focuser Simulator.ABS_ROTATOR_ANGLE"
[2018-09-07T09:04:13.385 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:13: Driver indi_sony_ccd: snooping on CCD Simulator.FILTER_SLOT"
[2018-09-07T09:04:13.385 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:13: Driver indi_sony_ccd: snooping on CCD Simulator.FILTER_NAME"
[2018-09-07T09:04:13.386 BST DEBG ][ org.kde.kstars.indi] - INDI Server: "2018-09-07T08:04:13: Driver indi_sony_ccd: snooping on SQM.SKY_QUALITY"
[2018-09-07T09:04:13.386 BST DEBG ][ org.kde.kstars.indi] - INDI Server: ""


Phil

Please Log in or Create an account to join the conversation.

2 years 2 months ago
Gerard
Senior Boarder
Senior Boarder
Posts: 42
More
SONY SLT-A55 not connecting to INDI #29368
Hello,

I have had the same problem with a SONY SLT-A54, I put 'remote computer' in USB mode ...
Try this ans tell us

Bye

Please Log in or Create an account to join the conversation.

2 years 2 months ago
philpugh51
Fresh Boarder
Fresh Boarder
Posts: 14
More
Topic Author
SONY SLT-A55 not connecting to INDI #29375
Sorry - not sure what you mean....

Where are you setting this?

Thanks

Please Log in or Create an account to join the conversation.

2 years 2 months ago
Gerard
Senior Boarder
Senior Boarder
Posts: 42
More
SONY SLT-A55 not connecting to INDI #29376
In the Menu you have a wrench, Look for USB connection, my SLR have 3 options: Mass Storage, PTP and Remote computer, when I set
PTP I get the same message than yours.
Now , I set Remote computer but now i get this message in EKOS:
[WARNING] Shutter speed widget does not have any valid data (count=0). Using fallback speeds...

by now, i have not resolved it yet ...

Please Log in or Create an account to join the conversation.

2 years 2 months ago
philpugh51
Fresh Boarder
Fresh Boarder
Posts: 14
More
Topic Author
SONY SLT-A55 not connecting to INDI #29377
Ah. I see what you mean. It on the camera!

I don’t have that option on the a55.

Thanks

Please Log in or Create an account to join the conversation.

2 years 2 months ago
Gerard
Senior Boarder
Senior Boarder
Posts: 42
More
SONY SLT-A55 not connecting to INDI #29378
shame, I would have liked to help you ...

Please Log in or Create an account to join the conversation.

2 years 2 months ago
knro
Administrator
Administrator
Posts: 8547
Karma: 51
SONY SLT-A55 not connecting to INDI #29394
Please attach the full logs. You might need to debug the driver later on, but logs first.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 years 2 months ago
philpugh51
Fresh Boarder
Fresh Boarder
Posts: 14
More
Topic Author
SONY SLT-A55 not connecting to INDI #29401
I have attached the full log for that session. Please note i was only trying to see in the A55 would work so it is the only device in the profile. I know i can control my HEQ5 mount. Log just created!

many thanks

Phil
Attachments:

Please Log in or Create an account to join the conversation.

2 years 2 months ago
philpugh51
Fresh Boarder
Fresh Boarder
Posts: 14
More
Topic Author
SONY SLT-A55 not connecting to INDI #29402
This is the USB info from lsusb

Bus 002 Device 004: ID 054c:04a3 Sony Corp.

Anything else you need?

Please Log in or Create an account to join the conversation.

2 years 2 months ago
knro
Administrator
Administrator
Posts: 8547
Karma: 51
SONY SLT-A55 not connecting to INDI #29404
The driver crashes, are you using INDI Nightly or Stable PPA? Please try Nightly PPA and see if it crashes there. If this is already nightly then we'll have to debug.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 years 2 months ago
philpugh51
Fresh Boarder
Fresh Boarder
Posts: 14
More
Topic Author
SONY SLT-A55 not connecting to INDI #29405
Will try nightly

Please Log in or Create an account to join the conversation.

2 years 2 months ago
philpugh51
Fresh Boarder
Fresh Boarder
Posts: 14
More
Topic Author
SONY SLT-A55 not connecting to INDI #29406
Looks like debugging required!

Attached latest log
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 1.242 seconds