×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

SONY SLT-A55 not connecting to INDI

1 year 4 months ago
philpugh51
Fresh Boarder
Fresh Boarder
Posts: 14
More
Topic Author
SONY SLT-A55 not connecting to INDI #29500
What do I need to do to initiate a debug of the Indi_sony_ccd driver? I don't see a debug option in the logs area.

Attached is log that had the following parameters set: Verbose/INDI/CCD/Capture.

Cheers

Phil
Attachments:

Please Log in or Create an account to join the conversation.

1 year 4 months ago
knro
Administrator
Administrator
Posts: 7562
Karma: 51
SONY SLT-A55 not connecting to INDI #29513
Debugging would require some extra steps. You need to start the driver from the terminal. Check here for details: www.indilib.org/forum/general/571-read-b...support-request.html

If you get stuck, send me your TeamViewer details in a private message and I can check it out later.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 4 months ago
philpugh51
Fresh Boarder
Fresh Boarder
Posts: 14
More
Topic Author
SONY SLT-A55 not connecting to INDI #29516
OK - not sure I am doing this correctly!
Followed the post you referenced but couldn'y fing a indi_sony_ccd_dbg to install. I did install the indi_gphoto_dbg
From terminal ran: gdb --ex run --eval-command="set follow-fork-mode child" --args indiserver -v indi_sony_ccd
Then started KSTARS and set the debug option in the driver as per instructions - connected to camera and it crashed....
did a bt in gdb and copied the output. Attached are two files: the debug log file and a copy of the gdb output.

It's getting late so I will pick up tomorrow - thanks for any pointers
Attachments:

Please Log in or Create an account to join the conversation.

1 year 4 months ago
knro
Administrator
Administrator
Posts: 7562
Karma: 51
SONY SLT-A55 not connecting to INDI #29517
Is this on Raspberry PI? if yes, you probably need to also install libc6-dbg package. The gdb doesn't show much. At any rate, I checked the code and found where it could possible crashed and fixed that. However, if the exposure widget you won't be to capture anything. If you figure out a way to do a capture with gphoto2 in the command line, let me know what command you used exactly.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 4 months ago
philpugh51
Fresh Boarder
Fresh Boarder
Posts: 14
More
Topic Author
SONY SLT-A55 not connecting to INDI #29521
Looking at gphoto2 it would appear that the camera does not support "capture-image" mode via PTP - shame really. I guess SONY have their reasons.

Thanks for the assistance - will look at other capture methods!

Phil

Please Log in or Create an account to join the conversation.

Time to create page: 0.400 seconds