×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

QHYSDK 4.0.1

11 months 2 weeks ago
rutledgechris
Fresh Boarder
Fresh Boarder
Posts: 5
More
QHYSDK 4.0.1 #31306
Sadly, the loop/stop driver crash still present at least in Fedora 29.
[   96.123571] usb 1-1: new high-speed USB device number 6 using xhci_hcd
[   96.249902] usb 1-1: New USB device found, idVendor=1856, idProduct=0011, bcdDevice= 0.00
[   96.249912] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[   96.304221] usb 1-1: USB disconnect, device number 6
[   98.044484] usb 1-1: new high-speed USB device number 7 using xhci_hcd
[   98.171024] usb 1-1: config 1 interface 0 altsetting 0 bulk endpoint 0x1 has invalid maxpacket 64
[   98.171317] usb 1-1: New USB device found, idVendor=16c0, idProduct=296d, bcdDevice= 0.00
[   98.171323] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   98.171328] usb 1-1: Product: QHY5-CMOS
[   98.171333] usb 1-1: Manufacturer: QHY_CAMS
[  152.110271] show_signal_msg: 18 callbacks suppressed
[  152.110276] indi_qhy_ccd[2856]: segfault at 2d0 ip 00007f5c5a781950 sp 00007fffc9cdf620 error 4 in libpthread-2.28.so[7f5c5a77e000+f000]
[  152.110294] Code: 48 89 7c 24 f8 64 48 8b 04 25 10 00 00 00 f0 48 0f b1 54 24 f8 c3 0f 1f 40 00 f3 0f 1e fa 41 56 41 55 41 54 55 53 48 83 ec 40 <44> 8b 87 d0 02 00 00 64 48 8b 04 25 28 00 00 00 48 89 44 24 38 31

Please Log in or Create an account to join the conversation.

11 months 2 weeks ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1039
Karma: 6
More
QHYSDK 4.0.1 #31353
I confirm that my QHY9 CCD camera and filter wheel work with this SDK. Thanks very much, Jasem!

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

11 months 1 week ago
jerry
Expert Boarder
Expert Boarder
Posts: 114
Karma: 1
More
QHYSDK 4.0.1 #31398
Dumb question - after running a software update against your ppa:mutlaqja/indinightly on stellarmate how does one know if I've got this update yet? ;)

10" Meade SCT on Celestron CGEM DX HC: GEM 5.29.7137 MC: 6.50 6.50,
QHY-5L-II-M 1280x960 3.75um guiding,
Nikon Z7 8256 x 5504, 35.9 x 23.9mm 4.34 um pixel size.
StellarMate OS on RPI4 using kstars-bleeding and Kstars on Odroid-N2.

Please Log in or Create an account to join the conversation.

11 months 1 week ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 1966
Karma: 19
More
QHYSDK 4.0.1 #31402
Try this on the Pi in the terminal:

apt-cache policy libqhy
The following user(s) said Thank You jerry

Please Log in or Create an account to join the conversation.

11 months 1 week ago
fmozza
Expert Boarder
Expert Boarder
Posts: 100
More
QHYSDK 4.0.1 #31406

knro wrote: There is a new QHYSDK out. I personally put many hours in fixing various problems with the SDK so hopefully it will resolve some common issues now. The change should be later in INDI Nightly. Provide feedback in this thread.


I didn't see this thread until after I posted my topic on potential cooling issue with QHY9. Before you did into it too deeply, it might be a problem with my camera as it was acting up - I had some corrorsion on the connectors. Its working again, other than cooling. I'm hoping someone else with a QHY9 can test and verify cooling.

jmh

Please Log in or Create an account to join the conversation.

11 months 1 week ago 11 months 1 week ago by fmozza.
fmozza
Expert Boarder
Expert Boarder
Posts: 100
More
QHYSDK 4.0.1 #31411

fmozza wrote:

knro wrote: There is a new QHYSDK out. I personally put many hours in fixing various problems with the SDK so hopefully it will resolve some common issues now. The change should be later in INDI Nightly. Provide feedback in this thread.


I didn't see this thread until after I posted my topic on potential cooling issue with QHY9. Before you did into it too deeply, it might be a problem with my camera as it was acting up - I had some corrorsion on the connectors. Its working again, other than cooling. I'm hoping someone else with a QHY9 can test and verify cooling.

jmh


I switched things over to Window 7 / Nebulosity to test. I don't think it is the camera as it looks like it works well in that environment. Once the camera reached the target temperature (-25C), over time there was a slight variance of +/- 0.5 degrees C and power to the cooler running at 5% to 8%. I never really paid much attention to this before, but I think this is more or less normal. The ambient temp in the obs is -10C right now which is why the power is as low as it is.

And I am running the latest nightly build on the RPi where the camera is connected.

jmh

Please Log in or Create an account to join the conversation.

11 months 1 week ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1039
Karma: 6
More
QHYSDK 4.0.1 #31413
I answered to the other topic that you opened. Would you like to continue there since it is more dedicated to your specific observation or continue here?


Wouter

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

11 months 1 week ago
papaf76
Senior Boarder
Senior Boarder
Posts: 42
More
QHYSDK 4.0.1 #31417
Can anybody test this with a normal QHY8? A friend tried a few months back but couldn't stop exposures without locking up the camera. I'm curious if QHY8 (non pro or L) is supported now.

Please Log in or Create an account to join the conversation.

11 months 1 week ago
fmozza
Expert Boarder
Expert Boarder
Posts: 100
More
QHYSDK 4.0.1 #31425

wvreeven wrote: I answered to the other topic that you opened. Would you like to continue there since it is more dedicated to your specific observation or continue here?


Wouter


I think here is best - all the QHY driver issues in one place.

Please Log in or Create an account to join the conversation.

11 months 1 week ago 11 months 1 week ago by fmozza.
fmozza
Expert Boarder
Expert Boarder
Posts: 100
More
QHYSDK 4.0.1 #31426

papaf76 wrote: Can anybody test this with a normal QHY8? A friend tried a few months back but couldn't stop exposures without locking up the camera. I'm curious if QHY8 (non pro or L) is supported now.


I also have an older QHY8. The driver does not support these older camera's but but there was an alternate firmware that (sort of) works and a link was posted somewhere on this forum. QHYCCD has a new website and the firmware is no longer available from there. I've attached it if you want to try. My camera is a colour camera, and the driver treats it as a mono, and the maximum exposure time is 86.4 seconds. I've been looking for ways around it, but haven't found a solution.

Another solution is to run the camera under Windows with the ASCOM drivers and use the Windows INDI server to connect to the camera. There's a lot of pieces in that puzzle, but it can be made to work. Native driver support would be best, but don't hold your breath. I think QHYCCD is struggling to get a quality Linux driver out the door. (They should hire Jasem to do this for them ... ;-)

jmh

Please Log in or Create an account to join the conversation.

11 months 1 week ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1039
Karma: 6
More
QHYSDK 4.0.1 #31434

fmozza wrote: I think here is best - all the QHY driver issues in one place.


I tried just now and on my camera the cooler doesn't work at all and I am sure it did before. However, I never had to actively enable it. It would always start cooling down to 0 degrees Celsius without a problem. Now when either in the INDI Control Panel or in the CCD tab I click on the "On" button for cooling it automatically switches to off again. Logs attached.

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
Attachments:

Please Log in or Create an account to join the conversation.

11 months 1 week ago
fmozza
Expert Boarder
Expert Boarder
Posts: 100
More
QHYSDK 4.0.1 #31438

wvreeven wrote:

fmozza wrote: I think here is best - all the QHY driver issues in one place.


I tried just now and on my camera the cooler doesn't work at all and I am sure it did before. However, I never had to actively enable it. It would always start cooling down to 0 degrees Celsius without a problem. Now when either in the INDI Control Panel or in the CCD tab I click on the "On" button for cooling it automatically switches to off again. Logs attached.


I think this seems to indicate there is a bug. This worked find with indi-1.7.2, and I think the libqhy version was 2.0.3. Something changed after that release that broke cooling.

jmh

Please Log in or Create an account to join the conversation.

Time to create page: 0.824 seconds