´╗┐
×

INDI Library v1.7.9 Released (23 Jun 2019)

INDI Library v1.7.9 is mostly a maintenance release to fix a few bugs in several drivers.

QHYSDK 4.0.1

  • Posts: 395
  • Karma: 2
  • Thank you received: 54

Replied by Herrhausen on topic QHYSDK 4.0.1

Here is the dmesg output:

[ 1158.670687] usb 1-6: new high-speed USB device number 5 using ehci-pci
[ 1158.827130] usb 1-6: New USB device found, idVendor=1781, idProduct=0c7c
[ 1158.827137] usb 1-6: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 1158.855543] usb 1-6: USB disconnect, device number 5
[ 1160.634990] usb 1-6: new high-speed USB device number 6 using ehci-pci
[ 1160.791399] usb 1-6: config 1 interface 0 altsetting 0 bulk endpoint 0x1 has invalid maxpacket 64
[ 1160.791767] usb 1-6: New USB device found, idVendor=16c0, idProduct=296d
[ 1160.791772] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1160.791776] usb 1-6: Product: QHY5-CMOS
[ 1160.791780] usb 1-6: Manufacturer: QHY_CAMS
7 months 1 week ago #32379

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1

Replied by rutledgechris on topic QHYSDK 4.0.1

Herrhausen wrote: Hi Chris, many thanks for looking into it!

This is the config.xml. I have to re-produce the dmesg output. Is there anything you're looking for in particular?


Just want to compare it against mine and try with both.

-Chris
7 months 1 week ago #32381

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 3

Replied by papaf76 on topic QHYSDK 4.0.1

Before I borrow my friend's QHY8, I'd like to know if any changes have been made to this camera driver at all. We tried a few months back, but we had several difficulties, with the firmware first, which wouldn't work with the camera at all and had to download a different one, and we were then unable to stop a capture without locking the camera up.
If anyone thinks it would be a good thing to try, I can get the camera and make a few tests.
Thanks for any info!
6 months 3 weeks ago #33024

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 17

Replied by fmozza on topic QHYSDK 4.0.1

papaf76 wrote: Before I borrow my friend's QHY8, I'd like to know if any changes have been made to this camera driver at all. We tried a few months back, but we had several difficulties, with the firmware first, which wouldn't work with the camera at all and had to download a different one, and we were then unable to stop a capture without locking the camera up.
If anyone thinks it would be a good thing to try, I can get the camera and make a few tests.
Thanks for any info!


I noticed that version 4.0.11 of the QHY driver was released. I can't find any documentation indicating what was changed, but my old QHY8 now works for captures greater than 86.4 seconds. Note I used different firmware than what comes with the driver - I attached a version to a message earlier in this thread.

You'll have to copy it over the default firmware that is installed with the driver. Attach the camera to your computer. The device should be listed as 1618:6001 when you run lsusb.

Start indiserver, kstars with the appropriate configuration and you should be able to use the camera.

Regards,

jmh
6 months 3 weeks ago #33027

Please Log in or Create an account to join the conversation.

  • Posts: 873
  • Karma: 6
  • Thank you received: 229

Replied by wvreeven on topic QHYSDK 4.0.1

Where did you download it from?
ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chr├ętien on a SkyWatcher EQ6-R
6 months 3 weeks ago #33028

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 3

Replied by papaf76 on topic QHYSDK 4.0.1

The attachment is missing from that message. Can you repost that firmware please?
6 months 3 weeks ago #33029

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 17

Replied by fmozza on topic QHYSDK 4.0.1

papaf76 wrote: The attachment is missing from that message. Can you repost that firmware please?


Firmware attached. You need to copy it to QHY8.HEX in the firmware directory - this forum only allows files with specific extensions. I originally downloaded this from the old QHY forums.

Regards,

jmh

File Attachment:

File Name: v2QHY8_2018-12-27.txt
File Size:15 KB
6 months 3 weeks ago #33032
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 2

Replied by HoHr on topic QHYSDK 4.0.1

on Odroid XU4 runing ubuntu mate and updated now still QHY9s shows similar cooling behavior as described earlier.
SDK 4.0.1, not sure how to force installation of the very latest 4.0.11 mentioned above (maybe not available for ARM yet?).
6 months 2 weeks ago #33248

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 3

Replied by papaf76 on topic QHYSDK 4.0.1

You need to use the nightly builds, there are instructions on how to enable them in the Ubuntu format page.
The following user(s) said Thank You: HoHr
6 months 2 weeks ago #33251

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 2

Replied by HoHr on topic QHYSDK 4.0.1

Thanks but didn't help.
Maybe there is a tiny improvement - after connecting camera the temperature is updated in regular intervals while power is stable on 34% or so, but temperature oscillates around room temp (=no cooling). when I set new target temperature (or just entering "0") temperature is not read anymore and cooling power goes up through the roof resulting in rapid temp drop. driver is now SDK 4.0.11.
6 months 2 weeks ago #33254

Please Log in or Create an account to join the conversation.

  • Posts: 25
  • Thank you received: 1

Replied by vladutzalex on topic QHYSDK 4.0.1

I can confirm cooling still doesn't work.

I have tested this for a few hours, switching between Ekos & Ubuntu and a Windows environment for control.
When cooling is first set , power jumps to 100%.
I try to disable and enable again, but it doesn't seem to do anything. The temperature readout seems to "hang" and won't update either the power or the temperature. Whenever I switch off again it updates, then hangs again
6 months 2 weeks ago #33273

Please Log in or Create an account to join the conversation.

  • Posts: 395
  • Karma: 2
  • Thank you received: 54

Replied by Herrhausen on topic QHYSDK 4.0.1

rutledgechris wrote:
Just want to compare it against mine and try with both.

-Chris


Hi Chris,

did your tests yield any results?
5 months 2 weeks ago #34225

Please Log in or Create an account to join the conversation.

Time to create page: 1.020 seconds