×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

New INDI Atik driver - Feedback requested

  • Posts: 712
  • Thank you received: 174
Hi Simon,

our (CloudMakers) INDI driver definitely worked with Atik One (I have one) and to some extent worked with Atik GP (I have one as well). If it is detected but can't be connected, maybe USB rules script failed for some reason. Check permissions for device created for the camera in /dev/bus/usb/something... You can use lsusb command to find which one is it.

Atik GP is actually PointGrey Chameleon camera and only basic IIDC modes are supported by INDI driver, what limits e.g. available resolutions or framerates. If you want full support, you need to use INDIGO IIDC driver, but it will not work for you out of the box because of design flaw in Ekos. Camera reports itself correctly as PointGrey Chameleon and not as CCD IIDC as supposed by Ekos. But it should work, if you will run Atik and IIDC drivers in separate INDIGO server instead of built in INDI server. It will be also faster, because you will save one interprocess boundary.

Peter
The following user(s) said Thank You: sdh
2 years 3 months ago #33493

Please Log in or Create an account to join the conversation.

Hello Simon,

"Atik" is the newer INDI driver built on Atik SDK. Regarding the Atik filter wheel, I just tested it and it works just fine, including saving filter names. . Which driver are you selecting for that? Make sure it's "Atik EFW".
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 3 months ago #33494

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0
Hello Jasem,

thanks for the quick reply. First I wasn't using any driver for the filter wheel, since it is included in the Atik One. However, when I select "Atik EFW" as filter wheel I get a message from Indi Server saying "No Atik filter wheels detected. Power on?". Any idea what I am doing wrong? Also any clue why the Atik GP guider camera doesn't even show up in the INDI Control Panel?
2 years 3 months ago #33496

Please Log in or Create an account to join the conversation.

Ah built it FW. Okay, I can't test that but I think I fixed the issue from the description of your bug report. The change will be in tomorrow's nightly build (check Download for how to enable nightly PPA).

Regarding Atik GP, I just emailed Atik to see what they have to say about that. But As Peter said above, you might need a different driver for it. At any rate, let's wait for Atik official response on this.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 3 months ago #33499

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0
Thanks for the effort. I will check the nightly build tomorrow and see how it works. I also tried using the indigo server. All connected devices (CCD, built in FW and Guider) show up in the Web Interface. But how do I get Ekos to use the indigo instead of the INDI drivers?

I‘m looking forward to hear what Atik‘s official reply is.
2 years 3 months ago #33500

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174

But how do I get Ekos to use the indigo instead of the INDI drivers?


Run INDIGO server with indigo_ccd_atik and indigo_ccd_iidc drivers, run Ekos, create new profile, select remote type and enter localhost as the address.

Peter
2 years 3 months ago #33525

Please Log in or Create an account to join the conversation.

  • Posts: 933
  • Thank you received: 125

polakovic wrote:

But how do I get Ekos to use the indigo instead of the INDI drivers?


Run INDIGO server with indigo_ccd_atik and indigo_ccd_iidc drivers, run Ekos, create new profile, select remote type and enter localhost as the address.

Peter


Or you could try just manually writing the name of the indigo driver into the corresponding ekos profile box, and it will find them as they are located in same folder as INdI drivers, that may work..
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
2 years 3 months ago #33527

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0
Thanks to Peter and AstroNerd for the help. I managed to start Ekos using the INDIGO drivers for the Atik One CCD and Atik GP. Both cameras work and the filter wheel is behaving correctly. However, I am still running into problems:

1) The guiding section of Ekos doesn't show up. Is the GP not recognised as a guiding camera (using indigo_ccd_iidc driver)? Do I need another driver?
2) The Align section (I used the INDIGO Telescope Simulator for now) won't work. I would like to use the EqMod telescope driver with a synscan mount but there doesn't seem to be (a stable) one in INDIGO. Can you run INDI EqMod and INDIGO CCD drivers side by side? If so, how?


Jasem, I tested the INDI Atik driver in the nightly build. The 2nd filter wheel position is not skipped anymore. However, now KStars crashes when I try to change the filter wheel position from position 5. The filter names still cannot be changed. I get [ERROR] Error updating names of filters. after hitting Set in the INDI Control Panel.
2 years 3 months ago #33529

Please Log in or Create an account to join the conversation.

Ok I believe I found the issue for the crash. Please check nightly again tomorrow. For updating names error. Please remove the camera config file in ~/.indi directory and try again.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 3 months ago #33537

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174

1) The guiding section of Ekos doesn't show up. Is the GP not recognised as a guiding camera (using indigo_ccd_iidc driver)? Do I need another driver?


INIDGO, unlike INDI, creates different devices for different purposes. You will probably find "Atik GP" device for camera itself and "Atik GP (guider)" for its guiding port, you can use them independently. You need to select first one as camera and second one as guider in Ekos. The same apply for "Atik One" and "Atik One (wheel)", there are two independent logical device too for a single physical unit.

2) The Align section (I used the INDIGO Telescope Simulator for now) won't work. I would like to use the EqMod telescope driver with a synscan mount but there doesn't seem to be (a stable) one in INDIGO. Can you run INDI EqMod and INDIGO CCD drivers side by side? If so, how?


SynScan driver (and also alignment model) made a huge progress during last couple of weeks, but binary package is not created yet. You can either checkout INDIGO from GitHub and compile from source (github.com/indigo-astronomy/indigo) or you can run INDI EqMod driver (or any other INDI driver), just prefix it with -i switch on a command line. This instruct indigo_server to load executable instead of dynamic library and to use legacy INDI protocol. I can't recommend this approach for e.g. CCD drivers as far as legacy INDI protocol is really a disaster from performance point of view, but it doesn't matter too much for mount driver.

Peter
The following user(s) said Thank You: sdh
Last edit: 2 years 3 months ago by polakovic.
2 years 3 months ago #33540

Please Log in or Create an account to join the conversation.

Ok I just received confirmation from Atik that they will support the Atik GP in their SDK shortly, so stay tuned for the official support!
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 3 months ago #33572

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0
Thanks Jasem for the feedback. I will keep my eyes open for INDI Atik GP support.

I checked out the nightly build which stopped the crashing of KStars. However, taking images with the Atik One results in an „IDLE“ situation. Preview is working fine though.

I guess I stick with the INDIGO Atik drivers and the INDI EQMod driver. That seems to solve all my problems for now. Thanks Peter for the help.

Simon
2 years 3 months ago #33577

Please Log in or Create an account to join the conversation.

Time to create page: 0.679 seconds