×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

QHY5 not found by Ekos

11 months 3 weeks ago
crw4096
Expert Boarder
Expert Boarder
Posts: 90
More
Topic Author
QHY5 not found by Ekos #40007
Hello,

I'm having trouble getting Ekos to find the qhy5 guide camera in my setup. I'm running an indi server on Raspberry Pi; here's what the indi server says about QHY5 on startup:
2019-06-09T03:05:09: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|InitQHYCCDResource|    InitQHYCCDResource   END
2019-06-09T03:05:09: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|ScanQHYCCD|START
2019-06-09T03:05:09: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|ScanQHYCCD|ScanQHYCCD numdev=0
2019-06-09T03:05:09: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|ScanQHYCCD|Scan  finished. Return nid=0

Once I try to connect, though, Ekos doesn't see the camera. It sees everything else (mount, filter wheel, imaging cam, focuser) but not the guide cam. I turned on logging in Ekos and tried to attach just the QHY5; the log is attached.

I wasn't sure the camera itself was the issue, but I tried it under Windows and it worked fine. The setup seemed to work several weeks ago after I upgraded to INDI 1.7.8. I say "seemed to" because I could only try it out in my living room. Today, I updated kstars, and I'm wondering if that could be the issue.

Versions:
INDI 1.7.8 on RPi
Kstars Build: 2019-05-30T09:48:47Z

Let me know if there's anything else I can provide.

Thanks,

Charles Wright

Ubuntu 18.04 and Raspbian Jessie; INDI 1.7.4
Mounts: CEM-60 chiefly; iEQ45
Cameras: Atik 383L+, QHY5-II-M
Focuser: Moonlite
Attachments:

Please Log in or Create an account to join the conversation.

11 months 3 weeks ago
knro
Administrator
Administrator
Posts: 7992
Karma: 51
QHY5 not found by Ekos #40010
You need to contact QHY for this. They said recently that QHY5 is no longer supported and does not work in their SDK for Linux.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

11 months 3 weeks ago
crw4096
Expert Boarder
Expert Boarder
Posts: 90
More
Topic Author
QHY5 not found by Ekos #40024
Well that's not very nice of them.

What if I revert to an earlier version of INDI? I see in the git log that QHYSDK v5.0.3 went in just before the INDI v1.7.7 release. Does that mean I need to go back to 1.7.6?

Thanks for any help,

Charles

Ubuntu 18.04 and Raspbian Jessie; INDI 1.7.4
Mounts: CEM-60 chiefly; iEQ45
Cameras: Atik 383L+, QHY5-II-M
Focuser: Moonlite

Please Log in or Create an account to join the conversation.

11 months 3 weeks ago
jerry
Gold Boarder
Gold Boarder
Posts: 171
Karma: 1
More
QHY5 not found by Ekos #40029
Just to be clear in my mind, is the dropped support is specifically for the QHY5? I'm hoping (based on the 2019-04-08 linux note), it doesn't include the QHY5L-II-M ?

120 MM Skywatcher Esprit on Celestron CGEM DX HC: GEM 5.29.7137 MC: 6.50 6.50,
ZWO ASI 224MC or QHY-5L-II-M for guiding,
Nikon Z7 8256 x 5504, 35.9 x 23.9mm 4.34 um pixel size.
1) StellarMate on RPI4
2) Kstars on Odroid-N2 on Ubuntu-mate 20.04 and
3) KStars on Astroberry on RPI3.

Please Log in or Create an account to join the conversation.

11 months 3 weeks ago 11 months 3 weeks ago by crw4096.
crw4096
Expert Boarder
Expert Boarder
Posts: 90
More
Topic Author
QHY5 not found by Ekos #40041
Well, it might mean that - the camera I'm using is precisely a QHY 5L-II-M, and if this really is the case, it's the second piece of QHY hardware rendered inoperable under Linux for me. Gotta sell these things to a happy Windows astronomer...

Ubuntu 18.04 and Raspbian Jessie; INDI 1.7.4
Mounts: CEM-60 chiefly; iEQ45
Cameras: Atik 383L+, QHY5-II-M
Focuser: Moonlite

Please Log in or Create an account to join the conversation.

11 months 3 weeks ago
knro
Administrator
Administrator
Posts: 7992
Karma: 51
QHY5 not found by Ekos #40051
No, the QHY5L-II-M works just fine, I think they were referring to the 1st generation QHY5.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

11 months 3 weeks ago
ChrisRowland
Platinum Boarder
Platinum Boarder
Posts: 452
Karma: 9
More
QHY5 not found by Ekos #40054
Won't the drivers provided by QHY before they withdrew support continue to work?

Please Log in or Create an account to join the conversation.

11 months 3 weeks ago
knro
Administrator
Administrator
Posts: 7992
Karma: 51
QHY5 not found by Ekos #40055
Right, but we use updated QHY SDK whenever it is released. We have to do this to keep with the bug fixes.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

11 months 3 weeks ago
crw4096
Expert Boarder
Expert Boarder
Posts: 90
More
Topic Author
QHY5 not found by Ekos #40062

knro wrote: No, the QHY5L-II-M works just fine, I think they were referring to the 1st generation QHY5.


If the QHY5L-II-M works "just fine", then I would like to help people further diagnose the issue I am having, because that is the camera I have, and it is very much *not* working. I can provide more info later - perhaps it's due to an issue with the build or something? No idea...

Charles

Ubuntu 18.04 and Raspbian Jessie; INDI 1.7.4
Mounts: CEM-60 chiefly; iEQ45
Cameras: Atik 383L+, QHY5-II-M
Focuser: Moonlite

Please Log in or Create an account to join the conversation.

11 months 3 weeks ago
jerry
Gold Boarder
Gold Boarder
Posts: 171
Karma: 1
More
QHY5 not found by Ekos #40063
This may not help, as I haven't yet scrolled back to see your original issues, but my QH5L-II-M pretty much works with either internal or Phd2 in the most recent bleeding edge builds (and has been for a while). I have had "exposure failed restarting", many times in the past, but at the moment, for the most part, it is working. When it doesn't I reboot Kstars. My problem at the moment is full resolution Nikon Z7 captures (without fits viewing) and Phd2 guiding appear to kill the nikon driver (driver crashed). I can see the system goes to 100% memory utilization. In the last session 2 days ago, after doing the image alignment with Kstars, I ended up with Phd2 guiding using Kstars indi drivers and attaching the camera to a CamRanger to provide exposures > 30". Not an ideal situation as the images are not fits. I hope an Odroid-N2 might help this, but more likely to replace one set of issues with another.

120 MM Skywatcher Esprit on Celestron CGEM DX HC: GEM 5.29.7137 MC: 6.50 6.50,
ZWO ASI 224MC or QHY-5L-II-M for guiding,
Nikon Z7 8256 x 5504, 35.9 x 23.9mm 4.34 um pixel size.
1) StellarMate on RPI4
2) Kstars on Odroid-N2 on Ubuntu-mate 20.04 and
3) KStars on Astroberry on RPI3.

Please Log in or Create an account to join the conversation.

11 months 3 weeks ago
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 634
Karma: 3
More
QHY5 not found by Ekos #40064
I just tested my very old QHY5 clone with nightlies and found it works OK. It lists as "Bus 003 Device 010: ID 16c0:296d Van Ooijen Technische Informatica" in lsusb. I did not find any difference to "original" QHY5s in the past so I believe it had just been re-labeled and is otherwise identical to the QHY5. If course I could be wrong nevertheless.

Please Log in or Create an account to join the conversation.

11 months 3 weeks ago
crw4096
Expert Boarder
Expert Boarder
Posts: 90
More
Topic Author
QHY5 not found by Ekos #40070
Mine is listed as "Bus 001 Device 015: ID 1618:0921" - there is no string following the numbers.

Ubuntu 18.04 and Raspbian Jessie; INDI 1.7.4
Mounts: CEM-60 chiefly; iEQ45
Cameras: Atik 383L+, QHY5-II-M
Focuser: Moonlite

Please Log in or Create an account to join the conversation.

Time to create page: 0.463 seconds