×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

EOS 6D unstable after latest update?

1 year 1 week ago
rishigarrod
Expert Boarder
Expert Boarder
Posts: 88
Karma: 3
More
Topic Author
EOS 6D unstable after latest update? #43359
Hi All

I seem to be having issues with my Canon 6D since I updated to the latest library.
I have tried unsuccessfully to use my Canon 6D over the last 2 evenings.
I get everything setup fine including Auto-Focussing which goes through the Canon.
Taking a few sample pictures usually works too but as soon as I start a sequence the camera hangs. On the camera I see the frame counter flashing and the Indi control panel produces an error message every 20 seconds.

I will try again today in the daytime to see if I can reproduce the error and provide some accurate information but I was curious if anyone has experienced the same?

Cheers

Rishi

WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
HEQ5 with belt mod and ADM dual saddle
294 mc pro
224 guide cam
Powerbox PPB
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

Please Log in or Create an account to join the conversation.

1 year 1 week ago
knro
Administrator
Administrator
Posts: 8390
Karma: 51
EOS 6D unstable after latest update? #43360
Can you try the gphoto driver instead of Canon? Is it any better?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 1 week ago
rishigarrod
Expert Boarder
Expert Boarder
Posts: 88
Karma: 3
More
Topic Author
EOS 6D unstable after latest update? #43362
I tried first with the EOS driver this morning and although I tried to follow exactly the same pattern as last night now it works fine (same thing happed yesterday when I tried it in the daytime).
I swapped to the GPhoto driver and that seems to work OK too. I guess I will have to wait for the next clear night to really see if it makes a difference.

WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
HEQ5 with belt mod and ADM dual saddle
294 mc pro
224 guide cam
Powerbox PPB
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

Please Log in or Create an account to join the conversation.

1 year 1 week ago
knro
Administrator
Administrator
Posts: 8390
Karma: 51
EOS 6D unstable after latest update? #43364
Are you getting "cannot wait for event" errors?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 1 week ago
rishigarrod
Expert Boarder
Expert Boarder
Posts: 88
Karma: 3
More
Topic Author
EOS 6D unstable after latest update? #43366
Exactly. Those are the errors i get. When you look in the camera you see the number of frames left counter flashing.

WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
HEQ5 with belt mod and ADM dual saddle
294 mc pro
224 guide cam
Powerbox PPB
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

Please Log in or Create an account to join the conversation.

1 year 1 week ago
knro
Administrator
Administrator
Posts: 8390
Karma: 51
EOS 6D unstable after latest update? #43368
Thanks for the confirmation. I've been getting those as well. This is definitely a libgphoto2 issue, I will try to git bisect later today and found where they broke it.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 1 week ago
alacant
Platinum Boarder
Platinum Boarder
Posts: 646
Karma: 1
More
EOS 6D unstable after latest update? #43370
Hi
Is this all canon dslrs? I have: 2019-09-08T20:04:46Z
Thanks.

ubuntu 18.04
700d, eq6, t7m

Please Log in or Create an account to join the conversation.

1 year 1 week ago
terryfitz
Fresh Boarder
Fresh Boarder
Posts: 6
More
EOS 6D unstable after latest update? #43382
I too have been having a similar problem with my Canon 100D, and though it may be coincidence, it has started since the latest slew of updates. My set is that on my "portable" mount, I have a TinkerBoard S that runs Linux and uses INDI drivers, with an EQ6-Pro mount, a SW 150PDS with an astr0modded Canon 100D and a QHY5LIIM guide camera on an Orion Guide Scope. All was well until recently where the sequence of events would be as follows.

I could set up the rig and slew the scope to a bright star to focus the scope. I'd be able to do that fine using a Bahtinow mask, so then I'd slew to the target I'm after with the software doing plate solving etc., to get me there. All OK up to now. Then I would start the auto guider and it would all stop working in that the auto guider would appear to be OK, but the Canon would display the symptoms described by Rishi. I was using the Canon INDI driver, so I triep the gphoto driver as per your suggestion, but that was exactly the same.

Being a scientist with an inquisitive mind, I decided to hook everything up to a laptop to see if it was related to the TinkerBoard, but that's where things became more odd (or maybe more clear, I'm not sure). First I tried running under Ubuntu with KStars / EKOS, and the 100D worked fine on it's own, but when I went to the guider page, any attempt to get the gude camera to start looping resulted in time-out errors on the QHY5LII, so I different issue apparently, but one that still leave the system unuseable. However, my laptop is dual boot so I went to trusty old Windows and fired up SGPro and PHD2 using ASCOM drivers and all worked absolutely fine - the reason for this latter course of action was to confirm that I don't have any faulty hardware, which it successfully proved.

So my question is whether it is the Canon driver that is the problem, or is it the QHY driver (I notice that this was updated to a newer SDK if I recall correctly) that is the cause of the trouble. I am lucky in that I can run the whole thing under Windows, but I do want to get back to using my TinkerBoard as that is what makes the mount "portable", not the weight!

Terry

Equipment:
EQ6R-Pro with SW 190MN, ATIK 383L+ and ATIK EFW2, guiding with QHY5LII-M on an Orion GuideScope (run from a PC in the observatory running SGPro)
EQ6R with SW 150PDS, Canon 100D (astro mod), guiding with with QHY5LII-M on an Orion GuideScope (run from a TinkerBoard S)

Terry
The following user(s) said Thank You knro

Please Log in or Create an account to join the conversation.

1 year 1 week ago
alacant
Platinum Boarder
Platinum Boarder
Posts: 646
Karma: 1
More
EOS 6D unstable after latest update? #43401
Hi
I took 6 frames in a capture module sequence. Canon 450d. 3.3.6: 2019-09-08T20:04:46Z

steve@E5430:~$ apt list indi-gphoto
Listing... Done
indi-gphoto/bionic,now 2.8~201909051730~ubuntu18.04.1 amd64 [installed]

steve@E5430:~$ apt list gphoto2
Listing... Done
gphoto2/bionic 2.5.15-2 amd64

Here is the log. It seems ok but am unsure if I have reproduced what the OP describes. I have no guide camera attached; maybe that is when the bug occurs...
Cheers anyway,
Steve

ubuntu 18.04
700d, eq6, t7m
Attachments:

Please Log in or Create an account to join the conversation.

1 year 1 week ago
terryfitz
Fresh Boarder
Fresh Boarder
Posts: 6
More
EOS 6D unstable after latest update? #43520
Hi,

I have just completely reimaged my TinkerBoard S and the problem persists. I can take a sequence of images with my Canon 100D and that all works fine, but as soon as I start my guide camera (even just looping, not actually guiding), the Canon runs into difficulties and, at the end of the first exposure in this mode, I get a message saying "Cannot wait for event" (or something like that) and the image won't download. The camera is then unusable until I completely power it down (which includes removing the battery). I have therefore eliminated the software on the TinkerBoard as a problem I believe. My next attempt will be with my rPi 4B using the beta image of StellarMate, but that seems to be a bit flaky at the moment with KStars hanging during start-up so I'm not hopeful.

Terry

Equipment:
EQ6R-Pro with SW 190MN, ATIK 383L+ and ATIK EFW2, guiding with QHY5LII-M on an Orion GuideScope (run from a PC in the observatory running SGPro)
EQ6R with SW 150PDS, Canon 100D (astro mod), guiding with with QHY5LII-M on an Orion GuideScope (run from a TinkerBoard S)

Terry

Please Log in or Create an account to join the conversation.

1 year 1 week ago
knro
Administrator
Administrator
Posts: 8390
Karma: 51
EOS 6D unstable after latest update? #43524
I uploaded an updated SM OS Beta for RPI4 now to fix the KStars issue.

If you use the INDI GPhoto driver and not Canon, does it make any difference?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 1 week ago
terryfitz
Fresh Boarder
Fresh Boarder
Posts: 6
More
EOS 6D unstable after latest update? #43552
The SM OS on the site is still v1.4.4 which is the one that I am using - I clearly don't know where to look for any updated beta versions. As for using GPhoto, I tried that a while ago and it made no difference. Personally, I'm convinced it's a problem with the QHY driver since, though I can't get KStars to run reliably on the rPi4, I did get the INDI server running and got PHD2 open with the QHY5LIIM camera, but it refused to download and preview any images. If I had al alternative guide camera to the QHY, I would try that to see if it made any difference, but I don't sadly. Is there any way to go back to an earlier INDI-QHY driver (and maybe an earlier CANON one) since this has all just apparently started with the September release - it may just be coincidence, but again, this would be a way of eliminating things that aren't the cause of the problem.

Equipment:
EQ6R-Pro with SW 190MN, ATIK 383L+ and ATIK EFW2, guiding with QHY5LII-M on an Orion GuideScope (run from a PC in the observatory running SGPro)
EQ6R with SW 150PDS, Canon 100D (astro mod), guiding with with QHY5LII-M on an Orion GuideScope (run from a TinkerBoard S)

Terry

Please Log in or Create an account to join the conversation.

Time to create page: 1.278 seconds