×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

Raspberry Pi 4 solved my ASI120MM split-frame nightmare

1 week 6 days ago
rserpell
Fresh Boarder
Fresh Boarder
Posts: 1
More
Topic Author
Raspberry Pi 4 solved my ASI120MM split-frame nightmare #47899
Hi everyone,
I though it would be good to share a recent positive experience regarding the random split frame problem that plagues the old USB2 version of the ASI120MM camera. In case it helps someone else.

I was a about to angrily throw away this camera and buy the newer "mini" version, but decided to give it a chance first with the new raspberry 4 (I was set for the raspberry upgrade from 3 model B anyway). I'm happy to tell that the camera works flawlessly now. I had to update the camera firmware to "compatible" though, as after the raspberry upgrade it would not show a single image with the original one.

I have the camera connected to one of the USB2 ports on the raspberry 4. On the other USB2 port I have a FTDI for EQMOD and on one of the USB3 ports I have an ASI1600MM Pro. The pi is loaded with astroberry 2.0 server. I have updated all dists yesterday (INDI included). So far, dry runs only (too many clouds). I will report back when I have a chance to test the whole system under the stars.

For a bit of context/history: On notebooks running Windows, my camera had displayed the split frame problem since I bought it (in 2016, I think). Nevertheless, it had worked without issues with my raspberry pi 3 model B using iastrohub (raspbian jessie, linguider and a now outdated version of libasicamera). I used it for guiding via the camera's ST4 output and an FTDI was used to trigger a mirrorless camera. All of that was with the original camera firmware. Last year I decided to ditch iastrohub and try astroberry to benefit from updated INDI, kstars and Ekos. I was shocked to discover that using the same hardware as before the camera was now displaying the split frame problem (!!??). Searched every forum, tried most suggestions (different drivers, plugging it alone, binning 2x2), nothing. Useless for guiding.

I am aware that ZWO has officially recognized that this particular camera had hardware issues and thus would not be able to solve them via a firmware or driver update. Still, I find it a bit disturbing that the same hardware combination would work with a particular set of software and not with another. Sometimes one is lucky enough to find a working match. But then every future software update is a scary though.

Best,
Ricardo

Please Log in or Create an account to join the conversation.

1 week 6 days ago
stash
Platinum Boarder
Platinum Boarder
Posts: 344
Karma: 4
More
Raspberry Pi 4 solved my ASI120MM split-frame nightmare #47922
The old 120 really had a power , USB hub and cable length problem - it required power greater than some usb ports could provide and was a b@&%h on USB hubs/extenders - even cable length was a problem. This occurred on both Windows and Linux in my experience.

Even updating the firmware in the camera only slightly helped (slowed down the USB speed I think) but gave the split image problem instead.. Really ZWO should have done a recall as they were, IMHO ,not fit for purpose.

Also I believe there was a quality control problem as some of my friends didn't have any problems at all but most didn't use USB Hubs (powered or not) or long cables.

Dont forget the libraries used on Windows and I believe on Linux are ZWO own so again much of the blame is with ZWO

I still wont buy ZWO camera's even though many use them without problems I believe some QHY's models were just as bad - as they used much of the same hardware as the 120 USB2

Updates should be done in a controlled way - BY YOU. Make a copy of your SD card and update that - if there are problems just go back to the old fully working version - All good IT people do this even on large servers. Then there is no scary updates! Remember "if it aint broke dont fix it" :-)

RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????

Please Log in or Create an account to join the conversation.

Time to create page: 0.309 seconds