×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Pentax driver broken, kStars 3.4.0

6 months 3 weeks ago 6 months 3 weeks ago by DrawsACircle.
DrawsACircle
Senior Boarder
Senior Boarder
Posts: 71
More
Topic Author
Pentax driver broken, kStars 3.4.0 #49993
I’ve been using kStars controlling my Pentax K-70 in MSC mode. For some reason this is not working anymore, kStars/Indi cannot connect.
If I switch to PTP mode, it does connect, but the functionality is way too limited/buggy.
What has been changed? I know karlrees has been working on something, but hopefully this has not been released in the official version? It needs way more testing.
Jasem/Marcus you need people testing various camera models, the I volunteer testing the Pentax K-70 functionalities.
If Stellarmate is to survive, proper testing before releasing is a must.

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
knro
Administrator
Administrator
Posts: 8370
Karma: 51
Pentax driver broken, kStars 3.4.0 #49995
Any logs? Maybe it is due to some libgphoto2 issue as well? Can you capture with gphoto2 command? In SM Dashboard --> Diagnostics, there is a DSLR test.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
DrawsACircle
Senior Boarder
Senior Boarder
Posts: 71
More
Topic Author
Pentax driver broken, kStars 3.4.0 #49996
I’ll do some testing Jasem, I really want this to work, so does other Pentax users - Stellarmate/kStars is a fantastic tool, but the bugs makes it frustrating when you have clear skies.

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago 6 months 3 weeks ago by DrawsACircle.
DrawsACircle
Senior Boarder
Senior Boarder
Posts: 71
More
Topic Author
Pentax driver broken, kStars 3.4.0 #50006
Just did some testing, if I connect the camera directly to my Ubuntu PC running kStars 3.4.0 it works just fine in MSC mode (as usual)

Trying the same controlling my RPi4/SM via kStars from my Win10 PC or directly via VNC:
[2020-02-23T20:27:43.187 Rom, normaltid DEBG ][ org.kde.kstars.indi] - Received new device Pentax DSLR K70
[2020-02-23T20:27:43.187 Rom, normaltid DEBG ][ org.kde.kstars.indi] - INDIListener: New device Pentax DSLR K70
[2020-02-23T20:27:43.203 Rom, normaltid INFO ][ org.kde.kstars.ekos] - Ekos received a new device: Pentax DSLR K70
[2020-02-23T20:27:43.203 Rom, normaltid INFO ][ org.kde.kstars.ekos] - "Remote devices established."
[2020-02-23T20:27:43.203 Rom, normaltid DEBG ][ org.kde.kstars.indi] - < Pentax DSLR K70 >: < CONNECTION >
[2020-02-23T20:27:43.218 Rom, normaltid DEBG ][ org.kde.kstars.indi] - < Pentax DSLR K70 >: < DRIVER_INFO >
[2020-02-23T20:27:43.218 Rom, normaltid DEBG ][ org.kde.kstars.indi] - < Pentax DSLR K70 >: < POLLING_PERIOD >
[2020-02-23T20:27:43.218 Rom, normaltid DEBG ][ org.kde.kstars.indi] - < Pentax DSLR K70 >: < DEBUG >
[2020-02-23T20:27:43.218 Rom, normaltid DEBG ][ org.kde.kstars.indi] - < Pentax DSLR K70 >: < SIMULATION >
[2020-02-23T20:27:43.218 Rom, normaltid DEBG ][ org.kde.kstars.indi] - < Pentax DSLR K70 >: < CONFIG_PROCESS >
[2020-02-23T20:27:43.234 Rom, normaltid DEBG ][ org.kde.kstars.indi] - < Pentax DSLR K70 >: < ACTIVE_DEVICES >
[2020-02-23T20:27:43.234 Rom, normaltid DEBG ][ org.kde.kstars.indi] - < Pentax DSLR K70 >: < DEVICE_PORT >
.
.
[2020-02-23T20:27:43.937 Rom, normaltid INFO ][ org.kde.kstars.indi] - Pentax DSLR K70 : "[ERROR] Camera_get_config failed (-7): I/O problem "
[2020-02-23T20:27:43.937 Rom, normaltid INFO ][ org.kde.kstars.indi] - Pentax DSLR K70 : "[ERROR] Can not open camera: Power OK? If camera is auto-mounted as external disk storage, please unmount it and disable auto-mount. "
[2020-02-23T20:27:43.937 Rom, normaltid DEBG ][ org.kde.kstars.ekos] - Pentax DSLR K70 is disconnected.
[2020-02-23T20:27:43.937 Rom, normaltid INFO ][ org.kde.kstars.ekos] - "Pentax DSLR K70 is disconnected."
[2020-02-23T20:27:43.937 Rom, normaltid INFO ][ org.kde.kstars.indi] - Pentax DSLR K70 : "[INFO] Debug is enabled. "
[2020-02-23T20:27:43.937 Rom, normaltid DEBG ][ org.kde.kstars.indi] - < Pentax DSLR K70 >: < DEBUG_LEVEL >
[2020-02-23T20:27:43.952 Rom, normaltid DEBG ][ org.kde.kstars.indi] - < Pentax DSLR K70 >: < LOGGING_LEVEL >
[2020-02-23T20:27:43.952 Rom, normaltid DEBG ][ org.kde.kstars.indi] - < Pentax DSLR K70 >: < LOG_OUTPUT >

I also tried to unmount the camera and then started kStars on the RPi, same message.

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago 6 months 3 weeks ago by DrawsACircle.
DrawsACircle
Senior Boarder
Senior Boarder
Posts: 71
More
Topic Author
Pentax driver broken, kStars 3.4.0 #50007
I installed gphoto2 on the RPi, the camera is detected, executing the auto-detect command tells me that the K-70 is detected. Executing the --list-config command gives an I/O error message "Access denied". I have used the gphoto2 command line without any problems before.
The attached file is the result of running the --list-config command.
Running the DSLR test from the Control Panel fails, it says "connection lost", "DSLR test failed".

File Attachment:

File Name: my-logfile.txt
File Size:15 KB
Attachments:

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
knro
Administrator
Administrator
Posts: 8370
Karma: 51
Pentax driver broken, kStars 3.4.0 #50020
So it is a GPhoto2 issue. If you're using StellarMate, try software updater since I updated libgphoto2 just yesterday. Not sure if this will a difference, but at least try on the latest release before we file a bug report with libgphoto2.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
DrawsACircle
Senior Boarder
Senior Boarder
Posts: 71
More
Topic Author
Pentax driver broken, kStars 3.4.0 #50106
I just updated to 1.5.1, no changes.
I've filed a bug report on GitHub->gphoto/libgphoto2: github.com/gphoto/libgphoto2/issues/478

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago
knro
Administrator
Administrator
Posts: 8370
Karma: 51
Pentax driver broken, kStars 3.4.0 #50136
Thank you for filing the report... I will keep watch on that thread and will rebuild once/if they fix it.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

6 months 5 days ago
martinfink
Fresh Boarder
Fresh Boarder
Posts: 2
More
Pentax driver broken, kStars 3.4.0 #50726
Same problem here with my setup (Stellarmate 1.5.1 and Pentax K5)

Do you have any update on that issue or can you suggest a workaround to get stellarmate 1.5.1 working with a Pentax?

Please Log in or Create an account to join the conversation.

6 months 5 days ago
knro
Administrator
Administrator
Posts: 8370
Karma: 51
Pentax driver broken, kStars 3.4.0 #50744
I'm looking into it and hopefully Karl's new driver would be ready in the repo soon.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

6 months 5 days ago
DrawsACircle
Senior Boarder
Senior Boarder
Posts: 71
More
Topic Author
Pentax driver broken, kStars 3.4.0 #50759
My gphoto bug report has not been looked into after I provided some log files (at least I cannot see any activities), it could be due to Marcus being on vacation or the situation we are in right now (COVID-19).

Please Log in or Create an account to join the conversation.

6 months 2 days ago
DrawsACircle
Senior Boarder
Senior Boarder
Posts: 71
More
Topic Author
Pentax driver broken, kStars 3.4.0 #50848
Jasem has some changes which made it possible to connect to a Pentax camera, at least if you use the GPhoto CCD driver.
Just update SM via the Control Panel (using VNC to connect to a RPi), the nrun the package updater (I did that first), restart and voilá :-)

Please Log in or Create an account to join the conversation.

Time to create page: 0.275 seconds