×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Driver for Raspberry Pi "High Quality Camera?"

  • Posts: 47
  • Thank you received: 12
Nice work, Ill see if I can rearrange the code to run gain settings after timing perhaps solves it..

Im also working on improving the speed for downloading the image, i've gone from about 40s to a few seconds now.

I need to understand how to set debug level and received debug message from my PyIndi python testing client. The documentation is very goon on how to send debug messages from a driver, but I don't understand how to get the debug messages through to the client. Ping @knro
The following user(s) said Thank You: Jasem Mutlaq
1 year 8 months ago #65115

Please Log in or Create an account to join the conversation.

You can set debug level in Options --> Debug --> Enable/Disable. THis just enables and disable the debug. Then there are two options for levels. One that is DEBUG LEVELS, what gets set to the CLIENT so you select what needs to be checked. There is also LOGGING levels and this is when you want to write a FILE.

Beware that if you run Ekos, it will override these and you cannot control them from the driver (technically you can but Ekos will override them). This is because Ekos in the Logs window specify which drivers are logged and which are not. If you are not using Ekos, then you can change the settings as you like.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 8 months ago #65124

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
Thanks Jasem, I think I got it t work. I knew how to do it from within kstars but not from my python client i used for faster test-loops. Think I got it now. Now I just need to understand why the client is not receiving the image. I do get the image in kstars but no blobs are sent to the python client for some reason.

When I turn on debugging now, i see this in my python client as soon as i send the CONNECTION switch to on, is that a timing problem perhaps...

Dispatch command error(-1): INDI: Could not find property CCD_INFO in RPI Camera
<setNumberVector device="RPI Camera" name="CCD_INFO" state="Idle" timeout="60" timestamp="2020-12-29T11:43:04">
<oneNumber name="CCD_MAX_X">
4056
</oneNumber>
<oneNumber name="CCD_MAX_Y">
3040
</oneNumber>
<oneNumber name="CCD_PIXEL_SIZE">
0
</oneNumber>
<oneNumber name="CCD_PIXEL_SIZE_X">
0
</oneNumber>
<oneNumber name="CCD_PIXEL_SIZE_Y">
0
</oneNumber>
<oneNumber name="CCD_BITSPERPIXEL">
0
</oneNumber>
</setNumberVector>
Last edit: 1 year 8 months ago by Lars Berntzon.
1 year 8 months ago #65128

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
I have the camera working now with exposure times more than 1 s, but the gain needs to be defined always and the default is "unset". I just can't find out how to set a default gain in my driver. There is all those IUFillNumberVector, IDSetNumber, IUUpdateNumber, defineNumber(), registerProperty(), setProperty() that completely confuses me. Anyone knows how to do what I want?
Regards, Lars
1 year 8 months ago #65171

Please Log in or Create an account to join the conversation.

Line #207
IUFillNumber(&mGainN[0], "GAIN", "Gain", "%.f", 1, 16.0, 1, 1);

Last argument is the default value, which you set to 1 here.

To change it directly, mGainN[0].value = XXX whatever value. Once you change gain, then you need to send the value back to the client, so

IDSetNumber(&mGainNP, nullptr);
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 8 months ago #65190

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
Great, thanks a lot. I found that when I used kstars it did not use that default value of 1 (which the value '--' means i suspect). Instead it was using a gain of 2. Then I realized that the ~/.indi/RPI Camera_config.ini on the actual raspberry (not my laptop) it is set to 2. I guess it kind of makes sense to have the config file saved on the actual device and not the laptop connecting to the device (but not super clear).
1 year 8 months ago #65196

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
Ill take back that. I cant get more than 1 sec exposure without first taking a 20 sec exposure for the camera to kind of synchronize. As I understand the camera is then measuring and adjusting settings. There must be a way to set all values fixed, still looking for that.
The following user(s) said Thank You: Keith Venables
1 year 8 months ago #65211

Please Log in or Create an account to join the conversation.

Ok, let me know if I can help in anyway.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 8 months ago #65212

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
Hi,
Just joined the forum. I'm an experienced visual astronomer and now retired I'm exploring using CCD's to help.

I like raspberry Pi's and have used them quite a bit, but wouldnt consider myself a capable user/programmer.
first project was an all sky camera. A QHY CCD connected to the a remote RPi4 running IndigoSky. Worked out nicely in the end although the QHY 5L is a temperamental beast.

Now I'm trying to make an electronic finder for my Dobsonian.

The RPi HQ Camera looked interesting and I believe others have managed to get sufficient sensitivity to capture stars and plate solve the image.

First step I thought would be to use Astroberry/Kstars/Indi to test the setup and prove the concept. The I would attempt to write a more dedicated programme to do the capture/plate solving/scope drive.

Steep learning curve but I'm getting there.

problem I've hit is exposure & gain control. it seems not to change. I've read this thread and tried various things but to no avail.

When I start Ekos from Kstars, I get an Indi control panel pop up. On the tabs I can set exposure time and gain. I then go to the 'capture' tab in Ekos. Again I am presented with options to change exposure and gain. But they dont reflect what I may have set on the Indi control panel.
I've tried various combos of changing gain and exposure in various orders, but the resulting image always appears the same. The activity monitor script at the bottom of the window suggest the right length exposures are being taken, but the displayed images never change.

Any help greatly appreciated. (please remember I'm not a programmer!)
1 year 8 months ago #65582

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
Hi,
Just joined the forum after looking for solutions to problems I am having with my RPI HQ Camera and Kstars/Ekos/Indi.

Grateful for all the good work in this thread. It has helped quite a lot, but i am still not sure I am in control of exposure time - it seems most of the time I am trying things in the dark, (sorry no pun intended).

I'll keep following the thread, but if there is any thing I can do by way of testing etc? ps: i'm not a programmer!!
1 year 8 months ago #65588

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
Hi,
I've been stuck on this issue for a couple of weeks now. Just once I managed to get long exposures, but do not seem to reliably get it to work.
I have an RPi HQ camera on a RPi4 4GB, running astroberry 2.0.3. I did a fresh install a couple of days ago, to no avail.
Camera works OK with long exposures from the command line.

So far best way seems to be
Start up Kstars/Ekos & select profile
Set gain to anything other than the default '--" (dont seem to be able to change this default)
Try & do a long exposure - it will ignore the value and do a 1 second exposure first time
Thereafter it seems to respond to long exposure request

I'm hopeful for a solution, and in the meantime if I can help with any testing (I'm retired!) to try and pin down any issues I'd be more than happy.

Best regards
Keith
Last edit: 1 year 8 months ago by Keith Venables.
1 year 8 months ago #66342

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
I know about the problem and it is very annoying, sometimes I can get long exposures very reproducible. Probably we only need to figure out how to set the correct sensor-mode for the HiQ camera, but I have not found such documentation. Ive sent request to Sony about their sensor, but no reply. Berhaps I should ask Broadcom instead ..
1 year 8 months ago #66394

Please Log in or Create an account to join the conversation.

Time to create page: 1.116 seconds