×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Driver for Raspberry Pi "High Quality Camera?"

  • Posts: 12
  • Thank you received: 1
Hi,
I've been stuck on this issue for a couple of weeks now. Just once I managed to get long exposures, but do not seem to reliably get it to work.
I have an RPi HQ camera on a RPi4 4GB, running astroberry 2.0.3. I did a fresh install a couple of days ago, to no avail.
Camera works OK with long exposures from the command line.

So far best way seems to be
Start up Kstars/Ekos & select profile
Set gain to anything other than the default '--" (dont seem to be able to change this default)
Try & do a long exposure - it will ignore the value and do a 1 second exposure first time
Thereafter it seems to respond to long exposure request

I'm hopeful for a solution, and in the meantime if I can help with any testing (I'm retired!) to try and pin down any issues I'd be more than happy.

Best regards
Keith
Last edit: 1 year 5 months ago by Keith Venables.
1 year 5 months ago #66342

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
I know about the problem and it is very annoying, sometimes I can get long exposures very reproducible. Probably we only need to figure out how to set the correct sensor-mode for the HiQ camera, but I have not found such documentation. Ive sent request to Sony about their sensor, but no reply. Berhaps I should ask Broadcom instead ..
1 year 5 months ago #66394

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
I've found the following command line always works ok, first time, any time. Somethingabout First Mode seems rekey perhaps?
raspistill -t 1 -md 3 -bm -ex off -ag 1 --shutter 200000 -ISO 800 -st -o /home/astroberry/Desktop/long.jpg
1 year 5 months ago #66423

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
Yes, mode is the key probably. QRainman has provided me with lot of information so Ill update the code from this.
1 year 5 months ago #66425

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
OOps typo & autocorrect - meant to be "Burst Mode"!
1 year 5 months ago #66426

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
Oh, ok. That was interesting for sure. Ill see if I can find anything there.
Thanks, Lars
1 year 5 months ago #66429

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
Ok, done some testing today. Neither burst mode or hard setting a mode seems to help. Also I see that when I use raspistill to get a 5 s exposure it can take up to 45 seconds. That is really strange I think.
1 year 5 months ago #66444

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 10
Yeah. That one had me stumped for a while. Seems that raspistill will go through several frames (around 7 of them) before it presents the final frame to the user. Each frame is the length of the exposure time that has been set. That is the very reason for implementing raspiraw in my driver after attempting to use raspistill.
1 year 5 months ago #66454

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
Did you try the raspistill line I posted earlier?

For me, as written, the image is saved after about 1 second longer than the set exposure length. ie for a 5 second it takes 6.
If I remove the -bm, it gets a little longer.
if I remove -ex off, it does indeed get very much longer.
1 year 5 months ago #66460

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
You mean this: raspistill -t 1 -md 3 -bm -ex off -ag 1 --shutter 200000 -ISO 800 -st -o /home/astroberry/Desktop/long.jpg
Its a 0.2 s exosure, I have not had problems with that before.
1 year 4 months ago #66525

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
sorry, I pasted a random line. I can adjust the --shutter right up to 10's of seconds.

That short exposure came from an experiment I did, changing the exposure length up in steps and looking at the histogram to make sure the actual image was getting stronger.
Last edit: 1 year 4 months ago by Keith Venables.
1 year 4 months ago #66526

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
Just to make sure, when you say the image exposure does not change. You have turned of the stretch-button in the FITS-viewer then, otherwise the stretch function will normalize the exposure, with more or less noise as a side-effect.
1 year 4 months ago #67040

Please Log in or Create an account to join the conversation.

Time to create page: 0.646 seconds