×

INDI Library v1.9.4 Released (17 Jan 2022)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Driver for Raspberry Pi "High Quality Camera?"

  • Posts: 47
  • Thank you received: 12
You mean this: raspistill -t 1 -md 3 -bm -ex off -ag 1 --shutter 200000 -ISO 800 -st -o /home/astroberry/Desktop/long.jpg
Its a 0.2 s exosure, I have not had problems with that before.
11 months 3 weeks ago #66525

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
sorry, I pasted a random line. I can adjust the --shutter right up to 10's of seconds.

That short exposure came from an experiment I did, changing the exposure length up in steps and looking at the histogram to make sure the actual image was getting stronger.
Last edit: 11 months 3 weeks ago by Keith Venables.
11 months 3 weeks ago #66526

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
Just to make sure, when you say the image exposure does not change. You have turned of the stretch-button in the FITS-viewer then, otherwise the stretch function will normalize the exposure, with more or less noise as a side-effect.
11 months 2 weeks ago #67040

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
Yes - that can be a distraction!

I'm finding that if I start EKOS and go straight to the camera exposure tab, change gain first to anything 1 or higher, then change exposure to something long. It will give me a true long exposure straight away, and carry on doing so for the session.

Ive found you must not touch the exposure before the gain, as the moment exposure has been entered, a test image is captured automatically, which prevents future long exposures.

The command line I gave before still continues to be 'foolproof'.
11 months 2 weeks ago #67041

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
ps:

A load of messages I tried to post a month ago, suddenly appeared overnight.
11 months 2 weeks ago #67042

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
I wrote that weeks ago.

Tino
11 months 2 weeks ago #67043

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12

Ok, ill try more with that input, sorry but Im a bit of work spare time now adays so its moving a bit slow.
The following user(s) said Thank You: Keith Venables
11 months 1 week ago #67128

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
Many thanks,
If there is anything I can do to help - tests, characterisation etc? Just ask.
Being retired I have no time excuses!
11 months 1 week ago #67135

Please Log in or Create an account to join the conversation.

  • Posts: 63
  • Thank you received: 7
Could I inquire as to the latest on this, please?

I have the Pi HQ Camera and want to try it in an All Sky Camera. Previously I have been using ZWO cameras for this with RPi 3B, in particular the ASI178MC but this is a relatively old camera and needs quite a lot of cooling (using 60s exposures) to reduce thermal noise and hot pixels. This system has worked well with KStars/Ekos/INDI but cooling has produced a complicated setup - cooling the case of a non-cooled astro camera is inefficient. I have friends who would like to make an ASC too but ZWO astro cameras are expensive and would be interested if I can get it working with a cheaper camera.

My thinking is that the Pi HQ Camera is a much later addition to the Sony sensor range and could well be a lot more advanced and more sensitive in spite of smaller pixels.

To summarise, I'm looking to use the Pi HQ Camera with INDI and RPi, maybe the RPi Zero, using exposures of around 30s to 60s.

Thanks in advance.
11 months 4 days ago #67552

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
Hi Gina,
Its quite useable with the current indi driver if ones takes care to set the parameters in the right order. I'm able to get exposures up to 200 sec, both through indi, and direct RPi command line.

However, I've been running it alongside a ZWOASI 120MM-S in a plate-solving project to compare performances. The small pixels do seem to be an issue. To get anywhere near the same sensitivity as the ZWO camera I have to bin it 4x4.
The following user(s) said Thank You: Gina Davis
11 months 3 days ago #67554

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
From what I can gather, it appears the RaspiHQ camera is perfectly usable within Ekos, as long as the correct setup order is done (Gain before exposure if I've read the thread correctly?).  I've yet to test this in anger, but I appear to be getting some output during the day which is promising.

What I can't get to work though, is live video or video recording. The live video button below the sequence order window has a cross-through it?! Is this supported yet, or have I missed something on setup?

(Video seems to work fine via comman line and raspivid
6 months 4 weeks ago #72626

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 12
Sorry, but live video is not yet supported at all in the driver.
6 months 4 weeks ago #72630

Please Log in or Create an account to join the conversation.

Time to create page: 0.596 seconds