×
INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

*** CLOSED *** PHD2 Connection problem

6 months 1 day ago 6 months 2 days ago by the.cakemaker.
the.cakemaker
Elite Member
Elite Member
Posts: 321
More
Topic Author
*** CLOSED *** PHD2 Connection problem #59150
I know it´s not really the place for this but i have to aks what the problem could be that the cam almost won´t connect to PHD2

See video...

Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina

Please Log in or Create an account to join the conversation.

6 months 1 day ago
Gonzothegreat
Supernova Explorer
Supernova Explorer
Posts: 1965
Karma: 6
More
*** CLOSED *** PHD2 Connection problem #59151
dead youtube video

Kstars Mac osx
Odroid C1 running indiserver (kept up-to-date with apt-get update/upgrade)
Megrez72 / HEQ5 pro / QHY5L-II-M (OAG) / Atik 314L+ / Gerd Neumann drawer

Please Log in or Create an account to join the conversation.

6 months 1 day ago
the.cakemaker
Elite Member
Elite Member
Posts: 321
More
Topic Author
*** CLOSED *** PHD2 Connection problem #59152
Seems you were too fast. Its on now :-)

Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina

Please Log in or Create an account to join the conversation.

6 months 1 day ago
dmsummers
Elite Member
Elite Member
Posts: 316
Karma: 4
More
*** CLOSED *** PHD2 Connection problem #59170
I've on occasion experienced issues connecting from PHD2 using the method you're using, but I came to find it's easier and more reliable to just bring PHD2 up and make sure the profile is right (but don't connect from inside PHD2). Connect from Ekos (using guide tab controls). Depending on any out-of-sync state condition between Ekos & PHD2, you might need to forcibly disconnect and then reconnect, but generally, I no longer experience connection problems when coming from Ekos. Just a thought for something different to try. I could make myself believe a prior connection that has not "let go" could cause follow-on connect attempt issues. Cheers, Doug

RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.

Please Log in or Create an account to join the conversation.

6 months 1 day ago
the.cakemaker
Elite Member
Elite Member
Posts: 321
More
Topic Author
*** CLOSED *** PHD2 Connection problem #59173
I understand what you say.

The problem is that i am at the point "creating" the profile in PHD, and eveen here the problem allready occurs.

I have phd as guider in EKOS. I start PHD. I start KStars and the system connects automaitc immideately.
Ending up in the state you see on the vid...

I have to explain the situation in detail.

Got an ASUS Vivobook running some KDE-Neon-Plasma whatever...
Problems with the Lodestar X2 running on BIN 2x2 only. Bin 1x1 gives me timeouts. (ordered special cables to maybe get rid of that)
For testing purposes i erased the complete system and installed windows to have a clou how ASCOM behaves. (Under ASCOM everything runs fine)
So i installed the newest version of KUBUNTU how Jasem told me. Because on his Kubuntu System the same Cam has no issues at all.
So now i have a dualboot System running Win10 on one, and Kubuntu 20.-something on the other.
And THERE this problem started to happen.
I do not even have it on an old Stellarmate running 1.5.4 nor on my macbook air.
So it must have something to do with the Kubuntu, doesn´t it?
Can one somhow find out whats wrong?
Or "debug" something? Or just update kubuntu?

Niki

Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina

Please Log in or Create an account to join the conversation.

6 months 17 hours ago
dmsummers
Elite Member
Elite Member
Posts: 316
Karma: 4
More
*** CLOSED *** PHD2 Connection problem #59182
Well....not sure I can help with the dual boot config part of this issue. One thought might be to set your default profile in the OS environment you DONT want to test to use only simulators (mount, cam, guider). Connect and disconnect that profile to be sure it's the active default, and then exit. Next, set the profile in the OS you DO want to test to the actual HW. My guess is that somehow, you're managing to establish a connection to HW when not intended, so that when you are ready and try to intentionally connect, the equipment is already connected or the connection didn't clean up correctly (and then you can't get the socket/port when you want/need it for the config you're testing). It's not the first time I've seen the state machine from PHD2 to Ekos show incorrect state, so it can definitely be confused (and confusing to debug). Anyway, maybe something else to try. Good luck...

RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
The following user(s) said Thank You the.cakemaker

Please Log in or Create an account to join the conversation.

6 months 15 hours ago 6 months 2 days ago by the.cakemaker.
the.cakemaker
Elite Member
Elite Member
Posts: 321
More
Topic Author
*** CLOSED *** PHD2 Connection problem #59189
Thanks DMSUMMERS for this input. I definitally will have a try on this when the very bad and rainy wheather has gone. Thats why i am testing inside.
I will get new cables to get this issue out of the count but atm ASCOM under windows works well so i will see if i have to change.
Right now i am too annoyed of permanent problems and think i will choose the more problem free system...

Back to taking pictures again, not spending my time with software issues...

CS
Niki

EDIT:

Did a complete reinstallation of Kubuntu. Installed KSTARS. Installed PHD.
Maybe i do something wrong installing PHD2 because the installation-information is somehow "misleading" or not clear to me...

Seems that it has to be the wright "folder" for the fitting kubuntu-version.

I did it as follows:
sudo add-apt-repository ppa:pch/phd2
sudo apt-get update
sudo apt install phd2

But what is meant further down with this two links?
deb http://ppa.launchpad.net/pch/phd2/ubuntu focal main 
deb-src http://ppa.launchpad.net/pch/phd2/ubuntu focal main

Maybe i have got a wrong version?

CS
Niki

Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina
Attachments:

Please Log in or Create an account to join the conversation.

6 months 2 days ago
the.cakemaker
Elite Member
Elite Member
Posts: 321
More
Topic Author
*** CLOSED *** PHD2 Connection problem #59225
Found this when starting phd2 in konsole...

Is this normal or relevant

niki

Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina
Attachments:

Please Log in or Create an account to join the conversation.

6 months 2 days ago
ouioui01
Senior Member
Senior Member
Posts: 64
More
*** CLOSED *** PHD2 Connection problem #59227
Hi niki,
Did you check this combox when try to connect the mount ? some times, it's missing...


Cheers

----
ES ED 127mm FCD100, AZEQ6 GT, FocusLynx ESX25, Nikon D800 , ASI120mm-s, Polemaster
-- RPi4 4Gb Stellarmate , Windows 10 Pro, Kstars/VNC
-- RPi4 8Gb Ubuntu mate 20.04.1 LTS - Kstars/NoMachine
Attachments:

Please Log in or Create an account to join the conversation.

6 months 2 days ago
the.cakemaker
Elite Member
Elite Member
Posts: 321
More
Topic Author
*** CLOSED *** PHD2 Connection problem #59228
Hi!

I don´t know.
I installed 3 different versions of Ubuntu today.
None of them were able to connect to PHD2 .
I even get more problems in kstars to get the lodestar looping...
Not even in bin 2x2 anymore.
I totally give up now.
The only explanation to me is a hardware-damage of the laptop.

I close this topic here, it makes no sense anymore. Thanks all for your help...

Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Moravian G2 8300 Color | Canon EOS 5DMarkIIIa | Lodestar X2 guiding cam | KSTARS 3.4.3. on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.4.3. on Remote-IMac with Catalina | KSTARS 3.4.3 on Remote-Macbook Air with Catalina

Please Log in or Create an account to join the conversation.

Time to create page: 0.365 seconds