×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Meade DSI III colour camera- Unsupported Bayer Pattern

  • Posts: 26
  • Thank you received: 1
I recently purchased a Meade DSI III colour camera. Using Kstars/Ekos, no problem getting the camera recognized, however when I take an image a pop up note indicates that the Bayer Pattern is not recognized. As it is not a new camera I thought someone may have encountered the same problem and hopefully managed to find a solution./home/geoff/Pictures
When I press the OK tab on the pop up it does go to the FITS viewer. I think the result is in mono. (Need to get a bit more backfocus to get a c;lear image).
Any assistance appreciated
Geoff
1 year 5 months ago #66032
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1029
  • Thank you received: 301
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
1 year 5 months ago #66036

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
Thanks for that Eric. Unfortunately that didn't seem to be the answer for my problem. It is about Meade DSI versions I and II. I have version III which is quite a different chip.
I have searched all I can on the camera but cannot find exactly what bayer pattern it uses. Or if it is indeed a RGB pattern. As I am using Linux mint I can't download the Envisage program that Meade use for the camera.
At this point I am at a loss as to how to proceed.
1 year 5 months ago #66130

Please Log in or Create an account to join the conversation.

  • Posts: 1029
  • Thank you received: 301
From literature, it seems to be a CMYK pattern. Although you cannot use the FITS Viewer, you can still capture frames, and view them with an external tool I suppose. This is slightly annoying, but is it blocking for you?

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
1 year 5 months ago #66193

Please Log in or Create an account to join the conversation.

  • Posts: 1029
  • Thank you received: 301
No, definitely, I'm wrong. It's not CMYK, it is RGB. It means the driver supporting that camera should not attempt to run a debayer, maybe that's a blatant bug.

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
1 year 5 months ago #66195

Please Log in or Create an account to join the conversation.

  • Posts: 1029
  • Thank you received: 301
I am looking at this : www.hamiltonastronomy.com/ASTRO_ARTICLES/DSI_Pro_III.pdf

Does the INDI driver reports the right device version?

I think the issue is in the driver, dsi_ccd.cpp at line 136. The INDI glue considers there is a Bayer pattern as soon as the camera offers color frames. It is not the case for DSI III. Is it possible for you to rebuild the driver by changing this flag?

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
1 year 5 months ago #66196

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
Thanks again Eric, The little pop up that said "Unsupported Bayer pattern" was requiring me to press the OK button after each exposure, so I couldn't schedule a series of shots. However last night I found that by turning off the "auto debayer"in the FITS control panel it prevents the pop up and I can schedule a series of shots. So now to see if Siril will hopefully recognize the pattern, I tried it in GIMP however that still only gave me a mono image.
1 year 5 months ago #66199

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
Changing the driver is not within my capabilities I'm afraid. I will ask around the Tasmanian astro society if there is any one that may assist me.
The Indi Cotrol panel gives me:
Name: DSI
Exec: indi_dsi_ccd
Version: 0.3
Interface: 2
It doesn't mention colour
1 year 5 months ago #66200

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
Siril also just treats the image as mono also
1 year 5 months ago #66201

Please Log in or Create an account to join the conversation.

  • Posts: 1029
  • Thank you received: 301
It is possible that your dsi is not fully recognised by the driver. There should be a few lines of log when the driver starts, stating which device was detected. Do you get the "DSI Pro III" mention or the "unknown CCD" with the type of sensor?

On which computer are you running the dsi driver?

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
1 year 5 months ago #66225

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
My computer is a HP 6560B laptop running Linux Mint 20 Ulyana base: Ubuntu 20.04. On the log it only mentions Meade DSI no model.
I think that this is the part of the log yhatyou mentioned should indicate the DSI III.


[2021-01-20T21:08:22.055 AEDT INFO ][ org.kde.kstars.indi] - Meade Deep Sky Imager : "[INFO] Found a DSI with an unknown CCD: ICX285AQ "
[2021-01-20T21:08:22.057 AEDT INFO ][ org.kde.kstars.ekos] - "Meade Deep Sky Imager" Version: "0.3" Interface: 6 is connected.
[2021-01-20T21:08:22.057 AEDT DEBG ][ org.kde.kstars.ekos] - 1 devices connected out of 1
[2021-01-20T21:08:22.057 AEDT INFO ][ org.kde.kstars.ekos] - All INDI devices are now connected.
[2021-01-20T21:08:22.261 AEDT DEBG ][ org.kde.kstars.indi] - < Meade Deep Sky Imager >: < CCD_EXPOSURE >
1 year 5 months ago #66226

Please Log in or Create an account to join the conversation.

  • Posts: 1029
  • Thank you received: 301
The log excerpt matches my assumption. Your DSI is recognised, but not exactly as it should. I'll try to rebuild indi_dsi_ccd for your system to debug the situation. Could you open an issue on the INDI github?

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
1 year 5 months ago #66227

Please Log in or Create an account to join the conversation.

Time to create page: 1.068 seconds