×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

INDI can't start ZWO 294 - unable to establish . . .

  • Posts: 129
  • Thank you received: 33
With today's nightly (March 16)  both my ZWO cameras are working again...but my ZWO EAF still is not recognized.  
-Brian

NanoPC-T4 - Armbian focal
iOptron CEM25P mount
Photoline 80mm triplet refractor
ZWO ASI294MC Pro Imaging camera
ZWO ASI290MM mini Guide camera
ZWO ASI EAF focuser

7 months 1 week ago #68775

Please Log in or Create an account to join the conversation.

  • Posts: 1116
  • Thank you received: 182
I don't think nightly is the problem. More likely a driver readiness issue. As I described, I had similar problems a couple of nights ago with my ZWO-EFW and my ZWO imaging camera.
Can you mount the EAF from the device manager after starting EKOS and after your cameras have been found? If not, try unplugging the EAF, plug it in again, then retry mounting it from the Device Manager (found under Tools) with EKOS running.
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
The following user(s) said Thank You: Brian
7 months 1 week ago #68776

Please Log in or Create an account to join the conversation.

  • Posts: 1941
  • Thank you received: 416
It could also be a timing issue. Perhaps some, but not all, of the nighlty package builds have finished and a mix of old and new packages gets downloaded leading to inconsistencies.
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
The following user(s) said Thank You: Brian
7 months 1 week ago #68778

Please Log in or Create an account to join the conversation.

  • Posts: 1116
  • Thank you received: 182
I was also thinking of a timing issue, but a different one. I had 4 independent copies of Kstars on my Pi, one install from nightly 2 days ago and 3 independently compiled versions with different dates that had all worked fine previously. The only common factor was that I had updated the drivers which would be used by all the Kstars versions. Each of them had the same problem finding my ZWO peripherals. Only the ASI120MM-S was found every time, along with the CEM25 and the Moonlite focuser module.

What I was wondering is whether the updated drivers might have taken too long to find the peripherals and timed out? The interesting part is that only ZWO peripherals were affected and the one that uses the lowest amount of resources, i.e. the camera with the smallest sensor, had no problem with connecting.

Does this make sense?

Jo
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
7 months 1 week ago #68784

Please Log in or Create an account to join the conversation.

  • Posts: 129
  • Thank you received: 33
Thanks for that Jo but the ZWO EAF won't come up from the device manager in Kstars.  I know it is not a focuser problem, it works fine with the Kstars stable version.
-Brian

NanoPC-T4 - Armbian focal
iOptron CEM25P mount
Photoline 80mm triplet refractor
ZWO ASI294MC Pro Imaging camera
ZWO ASI290MM mini Guide camera
ZWO ASI EAF focuser

The following user(s) said Thank You: Jose Corazon
Last edit: 7 months 1 week ago by Brian.
7 months 1 week ago #68804

Please Log in or Create an account to join the conversation.

  • Posts: 223
  • Thank you received: 26
Again, I am running the stable release using an Intel machine, ubuntu 20.04.
Have problems with both imaging and guide camera, no problem with ZWO filter wheel.

Perhaps relevant to the thoughts about it being driver readiness/timing releated.
I have always run a local setup with Ekos and drivers on the same machine with
Ekos auto starting the drivers. However since updating to the recent release
the only way I found to coax the Astrophysics Experimental driver through its
initialization was to use indiserver to start the drivers. Then use Ekos remote
to the same machine without auto start. That allows the connect and cold start
buttons to be functional for the mount.

So it finally dawned on me to revert back to the original method of startup and have
Ekos start and connect to the drivers. Now both cameras connect and operate okay.
I have only gone back and forth two or three times but the results seem consistent.
No longer have cameras failing to connect, or connecting but taking 2 minutes to fill
in the indi panel controls. Also can image without it looping and restarting the image
attempt several times.

In case it is of use to anyone, local vs distributed startup playing a role?

For the moment for me it is camera or mount, pick one. I think next will try
stringing a USB2 cable to the mount instead of ethernet see if that changes the
timing.

Edit:
Correction I get the same beneficial effect by not using auto connect in Ekos, that is I do not have to use indiserver to
prestart the drivers. Uncheck the auto connect box in the Ekos profile. That still allows access to the cold start button
after connect for the mount. It seems (for me) I need to allow Ekos to auto start the ASI drivers for the cameras to work.
Then can manually connect to the other drivers.  Will see if this holds up when able to do an imaging session.

 
Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro
Last edit: 7 months 1 week ago by wotalota. Reason: correction
7 months 1 week ago #68813

Please Log in or Create an account to join the conversation.

  • Posts: 1116
  • Thank you received: 182
Unfortunately, last night my Pi executed unattended updates before I could stop them and now my ASI-EFW is also no longer recognized. 

Arghhh!!!  I need to roll back the drivers to an earlier version.  It can't be Kstars, since I have multiple independently compiled versions dating back to December on my Pi4, so it must have something to do with the specific driver for the ASI-EFW.  I now cannot even get it to be recognized manually anymore.  Cameras are now being recognized just fine.  But the ASI-EAF is not anymore.

Has anyone found an easy solution for this?
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
7 months 1 week ago #68841

Please Log in or Create an account to join the conversation.

  • Posts: 1116
  • Thank you received: 182
Looks like the problem has been solved with the latest driver updates.
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
7 months 6 days ago #68904

Please Log in or Create an account to join the conversation.

  • Posts: 129
  • Thank you received: 33
ASI EAF still not being recognized here.  Jo, can you tell me what nightly build you are using?  I have 3.53 Beta Build 2021-03-17T15:03:52Z   
I've not seen any driver updates lately.
-Brian

NanoPC-T4 - Armbian focal
iOptron CEM25P mount
Photoline 80mm triplet refractor
ZWO ASI294MC Pro Imaging camera
ZWO ASI290MM mini Guide camera
ZWO ASI EAF focuser

7 months 5 days ago #68919

Please Log in or Create an account to join the conversation.

  • Posts: 1116
  • Thank you received: 182
I am using this nightly build:

 

But I don't think that is the problem.  As I wrote, I have 4 different builds on my Pi4 dating back to December.  All of them worked before.  So the problem had to be either with a driver or with a file that is being changed during installation and that is being used by all independent builds. 
I remembered that I had a similar problem about 18 months or so ago when my PoleMaster was no longer recognized.  At that time that had something to do with a QHY update that changed a .rules file and as a result the PoleMaster was no longer recognized when I started EKOS.  I wondered whether something similar could be going on again now.
Before you proceed, take everything with a large grain of salt.  I have made multiple changes and did not test them systematically for each change, so I can't be 100% certain what finally fixed the problem.

Search your machine for a folder called  rules.d .  There should be two places where you should find it.  One as a /usr/././..  and one as a /etc/././..  subdirectory.  The location is different depending on what machine you installed Kstars on (Pi4 or AMDx64, at least in my case, so it is probably simpler to just search for the folders).  In there, you should find several files ending in  .rules . Find the ones that have asi in the name.  99-asi.rules  or  just called  asi.rules.  There are also rules files for filterwheels  (efw.rules) and focusers ( 99-focusers.rules ).  I suspected that during one of the recent nightly updates one of the asi.rules files must have changed, preventing my efw from being recognized. 

I then asked Hy to check his functioning installation and send me the contents of his asi.rules file.  Comparing the two versions I saw that one line in the "new" rules file was missing.  I added that back and then placed the modified file back into the rules.d  folders.

My EFW was still not recognized after doing that, so I recompiled all the drivers.  After that, I was back in business and it has been functioning now again flawlessly last night.

Again, I need to stress that I have not performed this test systematically, so I cannot say for sure which part (or location of the asi.rules file) is the critical one.  But you could try it and see if that fixes your problem.

This is the content of the now functioning 99-asi.rules file:

ACTION=="add", ATTR{idVendor}=="03c3", RUN+="/bin/sh -c '/bin/echo 256 >/sys/module/usbcore/parameters/usbfs_memory_mb'"
# All ASI Cameras and filter wheels
SUBSYSTEMS=="usb", ATTR{idVendor}=="03c3", MODE="0666"



The first line was missing on my Pi4 when it was not working.

Let me know if that helps (or even makes sense).

Jo

PS:  Also, I used an older version of the efw.rules file and placed it into both of the rules.d folders.  I don't know whether that made a difference.  There may be a rules file that defines your ZWO-EAF device ID and that may also have been changed.  You may have to experiment with that if just replacing the asi.rules file and recompiling the drivers is not sufficient.

 
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
The following user(s) said Thank You: Brian
Last edit: 7 months 5 days ago by Jose Corazon.
7 months 5 days ago #68923
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1116
  • Thank you received: 182
Brian,

You may also want to try Jerry's solution first.

indilib.org/forum/general/9112-solved-bl...d-cameras.html#68838

Purge indi and kstars, then reinstall fresh from the nightly repository.

That may be a simpler way to fix problems that has also worked for me in the past. Since in all cases reported ASI peripherals were involved, I still suspect it has something to do with the asi.rules file, but since Jerry was able to fix his issue by simply reinstalling, it could also be caused by something else that was corrected during the driver recompiling. I just don't know.

Jo
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
7 months 5 days ago #68926

Please Log in or Create an account to join the conversation.

  • Posts: 1941
  • Thank you received: 416
If the nightly builds are involved then perhaps this post may shed some light on the issue?

www.indilib.org/forum/ccds-dslrs/9151-as...ails-git-builds.html
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
Last edit: 7 months 5 days ago by Wouter van Reeven.
7 months 5 days ago #68927

Please Log in or Create an account to join the conversation.

Time to create page: 0.239 seconds