×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

QHY CCD problem with frame dimensions

I just published libqhy v21.10.26 and it should be in the nightlies. You can try that, not sure if they fixed this particular issue since then.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: nMAC
1 month 1 week ago #76938

Please Log in or Create an account to join the conversation.

  • Posts: 460
  • Thank you received: 83
I saved the geometry dimensions manually and it worked. Until I stop the exposure. The camera hangs and it disapears from the usb bus.
You have to disconnect it from the usb port and connect again. Try with the libqhy that Jasem put on the ppa. That was the last version I tried
and it did not solve the problems. Maybe you are luckier than me.
(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Orion 120ST / Explore Scientific 80APO / TSAPO102Q Sextuplet / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
Last edit: 1 month 1 week ago by nMAC.
1 month 1 week ago #76939

Please Log in or Create an account to join the conversation.

  • Posts: 255
  • Thank you received: 15
Thanks to both of you, I will try the nightly.

Have anyone presented the problem to QHY? I guess its a driver problem?
1 month 1 week ago #76948

Please Log in or Create an account to join the conversation.

  • Posts: 460
  • Thank you received: 83
I think the problem is really on the linux SDK as the older version (wich I don't remember) on my RPi3 worked without any problems.
I am also using it with Windows (ASCOM and Native) and I don't have any problems with it so I know the problem is not the camera itself.
Maybe this issue came up on the very old qhy forum some time ago, but I dont think it was solved or even answered.
(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Orion 120ST / Explore Scientific 80APO / TSAPO102Q Sextuplet / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
Last edit: 1 month 1 week ago by nMAC.
1 month 1 week ago #76949

Please Log in or Create an account to join the conversation.

  • Posts: 255
  • Thank you received: 15
Yeah, my camera worked perfectly. Then i updated Indi+kstars and it gave this error.

I will write to qhy if the nightly does not fix the problem.
Last edit: 1 month 6 days ago by S.
1 month 6 days ago #76953

Please Log in or Create an account to join the conversation.

  • Posts: 460
  • Thank you received: 83
I have just tried my QHY6 with the latest updates and this is the new status:

1 - Resolution is still missing from the driver so I have to save it manually on INDI Panel.
2 - Capture module captures just fine, any exposure.
3 - Focus module works with still pictures and looping. If I stop looping in focus module the camera hangs after 3 ou 4 cycles of start-stop looping. .
3 - Guiding module works partially, still pictures work. Looping starts working but has soon as I stop it, the camera hangs and it's no longer available.

But.... the latest libqhy (both  libqhy_21.10.26 unstable~202110262312~ubuntu21.04.1_amd64.deb  and  libqhy_21.10.26 unstable~202110262315~ubuntu21.10.1_amd64.deb  ) still includes 21.9.10 and not the 21.10.12 (latest)?
Anyway I have downloaded and installed the latest SDK and the results are the same as above, so no solution yet. 
(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Orion 120ST / Explore Scientific 80APO / TSAPO102Q Sextuplet / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
Last edit: 1 month 6 days ago by nMAC.
1 month 6 days ago #76959
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 255
  • Thank you received: 15
I tried the nightly and it still give me this error :-(

How did you manually set the values?
1 month 5 days ago #77012

Please Log in or Create an account to join the conversation.

  • Posts: 460
  • Thank you received: 83
On the indi panel, image settings tab. Fill the values and save.
 
(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Orion 120ST / Explore Scientific 80APO / TSAPO102Q Sextuplet / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
1 month 5 days ago #77013
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 460
  • Thank you received: 83
752x582 for usable field resolution or 800x596 for full resolution.
After saving this values it won't give an error anymore. 
But you have to do it everytime the libqhy sdk gets updated.
 
(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Orion 120ST / Explore Scientific 80APO / TSAPO102Q Sextuplet / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
Last edit: 1 month 5 days ago by nMAC.
1 month 5 days ago #77015

Please Log in or Create an account to join the conversation.

  • Posts: 255
  • Thank you received: 15
Ah ok, I already have those set but I still get the errors...
1 month 5 days ago #77016

Please Log in or Create an account to join the conversation.

  • Posts: 460
  • Thank you received: 83
Did you save the camera options?
I don't have errors now, where are you seeing yours?


Ok I have just saw them. They only appear when the camera is in loop mode, in still mode you don't get them:

2021-10-28T19:01:42: [ERROR] Invalid frame requested (0,0) (0 x 0)
2021-10-28T19:01:34: [INFO] Exposure aborted.
2021-10-28T19:00:58: [ERROR] Invalid frame requested (0,0) (0 x 0)
2021-10-28T19:00:57: [ERROR] Invalid frame requested (0,0) (0 x 0)
2021-10-28T19:00:56: [ERROR] Invalid frame requested (0,0) (0 x 0)
2021-10-28T19:00:55: [ERROR] Invalid frame requested (0,0) (0 x 0)
2021-10-28T19:00:54: [ERROR] Invalid frame requested (0,0) (0 x 0)
2021-10-28T19:00:20: [ERROR] Invalid frame requested (0,0) (0 x 0)
2021-10-28T19:00:19: [ERROR] Invalid frame requested (0,0) (0 x 0)
2021-10-28T18:59:44: [INFO] World Coordinate System is enabled.
2021-10-28T18:59:44: [INFO] Device configuration applied.
2021-10-28T18:59:44: [INFO] USB Buffer updated to 512
2021-10-28T18:59:44: [INFO] Gain updated to 0
2021-10-28T18:59:44: [INFO] Upload settings set to client only.
2021-10-28T18:59:44: [INFO] Loading device configuration...
2021-10-28T18:59:44: [INFO] Offset Settings: Value: 140 Min: 0 Max: 255 Step 1
2021-10-28T18:59:44: [INFO] Gain Settings: Value: 0 Min: 0 Max: 63 Step 1
2021-10-28T18:59:44: [INFO] USB Speed Settings: Value: 1 Min: 0 Max: 1 Step 1
2021-10-28T18:59:44: [INFO] Humidity Support: False
2021-10-28T18:59:44: [INFO] Camera exposure limits: Min: 0.001000s Max: 3600s Step 0s
2021-10-28T18:59:44: [INFO] Sensor resolution for mode STANDARD MODE: 800x596 px
2021-10-28T18:59:44: [INFO] Mode 0: STANDARD MODE
2021-10-28T18:59:44: [INFO] Using QHY SDK version 21.10.26
2021-10-28T18:59:44: [INFO] Connected to QHY6-M-0106XXXXXXXXXXXX.
(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Orion 120ST / Explore Scientific 80APO / TSAPO102Q Sextuplet / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
Last edit: 1 month 5 days ago by nMAC.
1 month 5 days ago #77017
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 255
  • Thank you received: 15
Yes, those I also get! Additionally I get "The calculated field of view is out of bounds" error and it seems that indi is not calculating the focal length from the plate solved image.

I think I will try to write QHY, it seems to be their issue....
1 month 5 days ago #77019

Please Log in or Create an account to join the conversation.

Time to create page: 0.790 seconds