×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

Python says incomplete though Homebrew installed

  • Posts: 3
  • Thank you received: 0
Admittedly I am absolutely green at this. Although I have worked and retired in IT I am somewhat new to the MAC world however I am very new to Astronomy and can't even begin to start Astrophotography until I understand and successfully test and configure my equipment.

I have:
Celestron AVX with Newtonian 200mm f/5 SkySync
Macbook Pro M1 Ventura 13.1 (Purchased specifically for Photography and AstroPhotography/Management)
(I haven't acquired a WiFi interface to the AVX yet because I'm working out the kinks of what I need to know and understand, need for equipment and how to set it up)

So... [forgive my ignorance here] according to what I've spent hours read and studied and reviewed videos of so far I've grabbed kstars, PHD2 and INDIWebManager.

Running INDIWebManager prompts me to install Python and Homebrew. I followed the prompts to install Python and indi-web which brings me to the terminal to install Homebrew where I get:

/usr/bin/ruby -e "$(curl -fsSL raw.githubusercontent.com/Homebrew/install/master/install)"
The default interactive shell is now zsh.
To update your account to use zsh, please run `chsh -s /bin/zsh`.
For more details, please visit support.apple.com/kb/HT208050.
<computer name> <useername> /usr/bin/ruby -e "$(curl -fsSL raw.githubusercontent.com/Homebrew/install/master/install)
"Error: The Ruby Homebrew installer is now disabled and has been rewritten in Bash. Please migrate to the following command: /bin/bash -c "$(curl -fsSL raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"


I run said command and it ran through what appeared to successfully install (I did not capture the first install terminal text because I assumed (yes I know :) ) it completed successfully according tyo its text.

Sooo,,, I closed terminal, closed Web Manager and relaunched WebManager only to be prompted again to install Python which brought me full circle to install Homebrew.

Just to be sure I went through the steps again. This time this is what I get:

==>
This script will install:
/opt/homebrew/bin/brew
/opt/homebrew/share/doc/homebrew
/opt/homebrew/share/man/man1/brew.1
/opt/homebrew/share/zsh/site-functions/_brew
/opt/homebrew/etc/bash_completion.d/brew
/opt/homebrew

Press RETURN/ENTER to continue or any other key to abort:
==> /usr/bin/sudo /usr/sbin/chown -R sabatinikl:admin /opt/homebrew
==> Downloading and installing Homebrew...
HEAD is now at 31ed6906f Merge pull request #14391 from MikeMcQuaid/comment_bump_repology_spec
==> Installation successful!


Apparently Homebrew thinks it is installed and truncates the first install procedure (long) and tells me Installation Successful!
Unfortunately INDI Web Manager does not agree (see screenshot).

I've gone in circles. I'm missing something or doing something wrong.

any help out there for this brutalized, beaten and dragged through the cornfield beginner? :)

1 year 4 months ago #89803
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
Hi Ken, did you ever get this resolved? I am at exactly the same place as you at the moment!

Thanks and regards,

Rob
7 months 3 weeks ago #96165

Please Log in or Create an account to join the conversation.

Time to create page: 0.337 seconds