×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

Driver OnStep (LX200 like) for INDI

  • Posts: 323
  • Thank you received: 32
Jasem merged the PR from James.

So I updated from Jasem's repo, then compiled it and testing now over WiFi.
There are no timeouts.

One very important and confusing change: there is no way to change the connection at all since all the fields are missing now.

Here is a screenshot to better show what the issue actually is.
 
2 years 5 months ago #78364

Please Log in or Create an account to join the conversation.

  • Posts: 453
  • Thank you received: 71
Khalid,

unfortunately this missing fields are not OnStep related. Did you try again after restarting Kstars.
I observe the same using Eqmod.
And it is not reproducible, sometimes yes sometimes no ...
2 years 5 months ago #78366

Please Log in or Create an account to join the conversation.

  • Posts: 323
  • Thank you received: 32
Yes, now that I tried a couple of times, the connection info is shown and can be changed.

I guess we need to report this to Jasem, so it is fixed before the next packages are built. Right?
2 years 5 months ago #78369

Please Log in or Create an account to join the conversation.

  • Posts: 453
  • Thank you received: 71
I suppose yes.
I noticed this some time before .
The strange thing is I cannot find a rule to reproduce it.
2 years 5 months ago #78371

Please Log in or Create an account to join the conversation.

  • Posts: 453
  • Thank you received: 71
Two Onstep Telescope with Kstars.
  
Last edit: 2 years 5 months ago by Alain Zwingelstein.
2 years 5 months ago #78376
Attachments:

Please Log in or Create an account to join the conversation.


I believe I found and fixed this issue, please test KStars from GIT or nightly.
The following user(s) said Thank You: Alain Zwingelstein
2 years 5 months ago #78380

Please Log in or Create an account to join the conversation.

  • Posts: 323
  • Thank you received: 32
The "telescope connection disappearing" issue is in KStars, not INDI?
2 years 5 months ago #78382

Please Log in or Create an account to join the conversation.

  • Posts: 453
  • Thank you received: 71
@Jasem,

Just compiled Kstars from Git and yes, looks klike you fixed it, connection selection is always accessible.

Thanks a lot
2 years 5 months ago #78385

Please Log in or Create an account to join the conversation.

  • Posts: 453
  • Thank you received: 71
@Khalid,

since Kstars is the client and it is up to the client to display properties it is likely the client that makes things like that.
This is why I use sometimes CDC to check if behavior is the same as in Kstars.
I just compiled Kstars Version 3.5.7 Beta Build: 2021-12-05T21:27:06Z and the bug is closed
2 years 5 months ago #78386

Please Log in or Create an account to join the conversation.

  • Posts: 323
  • Thank you received: 32
Excellent.
Thanks Alain for explaining how the bug is manifested/expressed.
Thanks Jasem for fixing it.

I hope that stable packages are built in the coming couple of weeks or so.
2 years 5 months ago #78388

Please Log in or Create an account to join the conversation.

  • Posts: 453
  • Thank you received: 71
It seems someone try to use Bluetooth as the main connection between OnStep and Computer.
Obviously it does not work correctly.
Does somebody use Bluetooth with success?
Have a look on this issue
github.com/indilib/indi/issues/1579
The following user(s) said Thank You: james_lan
2 years 4 months ago #79026

Please Log in or Create an account to join the conversation.

  • Posts: 65
  • Thank you received: 4
Yes i have on my MicroScope project. RaspberryPi Indi server connecting to OnStep via bluetooth.

I followed the steps under the "bluetooth" heading of this instrucable.
www.instructables.com/The-Micro-Scope-a-...ture-GOTO-Telescope/

I will look at that thread to see if it will help them.
2 years 4 months ago #79031

Please Log in or Create an account to join the conversation.

Time to create page: 0.534 seconds