×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

Driver OnStep (LX200 like) for INDI

  • Posts: 215
  • Thank you received: 17
It is a known issue, and has to do with the timeout.
For an unrelated, but similar API, I had to issue a connect before sending every command.

James Lancaster is working on it, and his latest status update is here

onstep.groups.io/g/main/message/12653
The following user(s) said Thank You: james_lan, greg_the_maker
1 year 8 months ago #42894

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 17
The master branch of OnStep (version 3.0h) now has support for communicating with it over WiFi.

If your controller has a WiFi module, you need to re-flash that module with the WiFi-Bluetooth addon from the above version.

The difference is that you use port 9998, but keep using 9999 for the Android App as usual.
For INDI, you can change that under the Connect tab.

This was tested with Stellarium Mobile Plus and found to be working.

More detail here .
1 year 7 months ago #44395

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 17
James / Alain,

Version 3.x of OnStep (which is 'master' in Github), has a new way for configuration which is much easier than before. Instead of one Config file for each board, there is a unified Config.h file.

It also has support for a persistent command channel on port 9998, which can make OnStep work over WiFi. Previously, port 9999 does not work because it times out after 2 seconds and closes the connection. The new port needs to be tested.

Another change is in how the focuser works, with new commands. Details in this message .
1 year 7 months ago #44728

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 23
Since I haven't updated in a bit. I fixed a bug yesterday not allowing to set the slew rate, should be in the next release.

Port 9998 has worked for quite a while.

As far as the focuser, I haven't implmented it yet. I did get into the habit of using 1 micron = 1 step in Config.h. I'd like to not break it for anyone potentially using it, but I need to refresh myself on the focuser. I'll probably let it toggle.

Couple of things on my todo list (numbered for convenience, not priority):

1. Changing the MaxRate replacement (degrees per sec)
Question on this: Would people prefer a settable 50-200%, as Degrees per sec, or the 50,75, 100, 150, 200%?
2. Intervolometer support
(Might be a priority, simply because I have some D5100s, and if I could trigger them as well as the main one in Ekos, that'd be handy until the Ekos/Kstars Imaging train gets done.)
3. Focuser Changes
4. Dew heater
5. Weather support. (Read BME280/etc)
6. Tangent arm support (Plate solve then adjust?)
7. Check backlash values (Changed to allowed to 3600)
8. DC Focuser support (Not sure if that works already or not?) Might need someone who has one to help with this.
9. TMC_SPI reporting support. (I got one for testing, and finally went to put it in on this cloudy night. I unfortunately missed the: You have to have both axis be SPI if one is, so this will be working at some point, but when is a big question. Oops.)
10. Equivalent of MoveAxis support to allow for following satellites. (Kstars issue more likely than OnStep directly, as the custom rates are added in, but Kstars doesn't have a way to send the rates/information, AFAIK)

Anything anyone else wants?
The following user(s) said Thank You: rbarberac
1 year 1 month ago #51548

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 0
Would love the weather support :)

Thanks in any case!

Joachim
1 year 1 month ago #51778

Please Log in or Create an account to join the conversation.

  • Posts: 122
  • Thank you received: 19
I've entered this thread to report a problem with the Slew rate... and I see that is fixed right now (but not available yet for macOS users) :). Any way, very happy to see that the driver is not dead :)

I've another question. I'm still building my OnStep system (soldering, waiting for some components to arrive, etc). Mean while I've built a prototype with a Mega board and one small 28BYJ-48 motor to see movement. Gotos speeds are reasonable, change slew rata didn't work, and I don't know if this is related, changing the speed at witch the polar assistant rotates the mount neither work. If you go to the polar assistant and star it, the 30deg slew is performed at very low speed, aside of the one that you have chosen in the combo.

Regards
1 year 4 weeks ago #52186

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 23
Added to the latest master. It's read only though, and I need to look into the dew heaters, and for the BMP280 I have, add support for changing the values (and useful for a heater for anyone who doesn't have a weather sensor, or maybe I can pull that from others.)

Please let me know if anything is broken. (I don't think so, but well it can happen.)

rbarberac: That should be fixed with OnStep unless I misread conversations?
The following user(s) said Thank You: joxda
1 year 1 week ago #53652

Please Log in or Create an account to join the conversation.

  • Posts: 122
  • Thank you received: 19
Yes it's fixed on OnStep 4.X versions
1 year 6 days ago #53662

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 0
Awesome, I will check it out.

And what you say about also making it possible to set the Onstep weather data from INDI or some other connected device makes perfect sense to me!
1 year 6 days ago #53666

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 0
Hello,

Some suggestions:
- Adding 3 or 4 presets for the focuser.
- Perhaps; full support for the 2nd focuser (selectable in for example kstars (Focuser1, Focuser2))
- For the dew heater: backup of the previous state in the Indi configuration. For example Heater1 On when Indi starts.
For the question, I prefer a settable 50-200%

And thank you again for this work.
1 year 6 days ago #53670

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 23
The problem is that INDI::Weather (Well, WeatherInterface more specifically) handles things as if it's a read-only value (which is usually not an unreasonable assumption). So I'll probably implement a 'setT/P/H' control above and on the same tab as a workaround, and see about sniffing weather values from other drivers as an option. To allow for dew heater operation without having the sensor on OnStep. Also probably grab OnStep's dew temp calculation, and for the heck of it, the MCU Temperature (if available on the processor).
1 year 6 days ago #53695

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 1
Hey Ian

Thanks for all the effort you put into the driver!

I face an issue after upgrading to the lastest master. I was on tag v1.8.4 which worked fine for me.
Yesterday I pulled in the lastest master and Kstars crashed with an allocation error as as soon as I 'unpack' the mount. However, the command is send before the crash. The next time I connect, I can see the mount is tracking. When I issue a park command, bam, crash :(

I rolled back to 'd7ac975d0fac3171af62c28a298b15d2e2d4caa7'. Anything later isn't working for me.

tested with 'kstars-bleeding' on Mint Linux and 3.4.1 on macOS.
Any ideas?

best
Niko
1 year 1 day ago #54049

Please Log in or Create an account to join the conversation.

Time to create page: 1.596 seconds