×

INDI Library v1.8.0 is Released (27 Jul 2019)

INDI Library v1.8.0 is mostly a maintenance release to fix a few bugs in several drivers.

Latest INDI build and ASI cameras: Hickups

  • Posts: 162
  • Karma: 1
  • Thank you received: 28

Latest INDI build and ASI cameras: Hickups was created by DerPit

I compiled latest git of INDI (1.8.0-30_gefbca51e) and kstars (3.3.4-686_g0e9825067) yesterday, but when using it with my ASI1600 I had problems with the connection(?).
I could connect, take some image in the capture tab, but when I switched to INDI control panel and wanted to set camera temperature, the camera wouldn't respond anymore. I disconnected from INDI and restarted the server, but in the next round, after init and focusing, when I tried to sync the mount in Align again no more connection.
After I had a third encounter of this type I went back to the previous INDI (1.8.0-16_g4d9b178d), with that no more issues.
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+ASI290 mini
1 week 2 days ago #41998

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 9

Replied by Marc2b on topic Latest INDI build and ASI cameras: Hickups

I have an ASI1600mm Pro + ASI290mm guiding. I have the last version of INDI too:

Here's the git log :
commit c9d909eaef7b6d66a583604f5b69cc193640c08b (HEAD -> master, origin/master, origin/HEAD)
Author: Jasem Mutlaq <This email address is being protected from spambots. You need JavaScript enabled to view it.>
Date: Mon Aug 12 23:56:56 2019 +0300

I'm using it right now to create a new set of dark frames. Everything works fine.

- Marc
1 week 2 days ago #42019

Please Log in or Create an account to join the conversation.

  • Posts: 162
  • Karma: 1
  • Thank you received: 28

Replied by DerPit on topic Latest INDI build and ASI cameras: Hickups

Thanks Marc!
Yes, the report probably was a false alarm. I've just recompiled with todays updates, and at the moment the camera seems to run flawlessly. But it's still daylight, so I can't really test focus/align stuff....
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+ASI290 mini
1 week 2 days ago #42020

Please Log in or Create an account to join the conversation.

  • Posts: 162
  • Karma: 1
  • Thank you received: 28

Replied by DerPit on topic Latest INDI build and ASI cameras: Hickups

Now it's dead again, after running autofocus. Starting an exposure it just shows the spinning icon, but no message :( Even 'disconnect' in the INDI control tab seems not to work. I had to disconnect and terminate the indiserver.
Just restarted everything, including debug. Ran autofocus, which did nonsense (it never went past the minimum, likely not even was close, but continued to go forth and back in the slope...)
So I stopped AF, wanted to restart - camera doesn't respond anymore.

Log is attached, but I couldn't see much in there. Maybe someone else does.
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+ASI290 mini
The following user(s) said Thank You: pug916
1 week 2 days ago #42027
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 162
  • Karma: 1
  • Thank you received: 28

Replied by DerPit on topic Latest INDI build and ASI cameras: Hickups

And again. This time I used only capture module. First a single exposure, then I used the continuous update. After a while I stopped it, after that camera is gone. So it's not the AF, but seemingly the fast/continuous readout?

Edit: The system log is full of usb reset messages,
Aug 13 21:54:58 astro1 kernel: usb 2-4: reset SuperSpeed Gen 1 USB device number 2 using xhci_hcd

usb 2-4 is the ASI1600.

Edit2: No, those I also get with the 1.8.0-16_g4d9b178d version, one for each started exposure.
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+ASI290 mini
Last edit: 1 week 2 days ago by DerPit.
1 week 2 days ago #42028

Please Log in or Create an account to join the conversation.

  • Posts: 191
  • Karma: 5
  • Thank you received: 83

Replied by jpaana on topic Latest INDI build and ASI cameras: Hickups

Yup, there's definitely something wrong with the current head, as compiling version from just before the C++ std::thread changes works fine, but current head gets stuck quite easily during autofocus with my ASI178MC. I thought at first that disabling subframing would have helped, but that was not the case after all, it just took a bit longer to hand. Have to debug that later, busy imaging tonight.
Remote observatory running Ubuntu 19.04 x64 with ScopeDome 2M, Skywatcher EQ8 and HEQ5, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, USB_Focus V3, Gemini SnapCap, USB_DewPoint, KomaHub
The following user(s) said Thank You: DerPit
1 week 2 days ago #42030

Please Log in or Create an account to join the conversation.

  • Posts: 162
  • Karma: 1
  • Thank you received: 28

Replied by DerPit on topic Latest INDI build and ASI cameras: Hickups

Thanks for the confirmation! And the promise to look at it ;)
Clear Skies for tonight!
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+ASI290 mini
1 week 2 days ago #42032

Please Log in or Create an account to join the conversation.

Replied by knro on topic Latest INDI build and ASI cameras: Hickups

I believe I found and fixed the issue. Please git pull and retest.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: jpaana
1 week 1 day ago #42044

Please Log in or Create an account to join the conversation.

  • Posts: 162
  • Karma: 1
  • Thank you received: 28

Replied by DerPit on topic Latest INDI build and ASI cameras: Hickups

knro wrote: I believe I found and fixed the issue. Please git pull and retest.


Yes, seems to help. I tried the method from yesterday, running frame looping in capture, and stop it. Several times, with different exposure times. No hang, next exposure works as expected :)
I'll also test again with the autofocus next night session, but that won't be before saturday...

(where is the thumb-up emoticon!?) :P
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+ASI290 mini
1 week 1 day ago #42047

Please Log in or Create an account to join the conversation.

Time to create page: 0.909 seconds