×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

New Pentax Driver Testing

  • Posts: 46
  • Thank you received: 6

Replied by Karl Rees on topic New Pentax Driver Testing

@Noideaforanae - As far as the 64 bit question, is StellarMate actually running on a 64 bit OS? I'm using a 32 bit OS (Raspberry Pi OS / Raspbian) since I didn't see an improvement when I tried 64 bit Ubuntu Mate. Long story short, PTP mode should work on the Rpi4, if you're using a 32 bit OS.

However, if you are in fact using a 64bit OS, that would rule out PTP mode removal as being a possible solution to your car charger problem, since the 64bit version of the driver already builds without it.

(I have debated removing PTP mode support to make things less confusing. I decided against that path originally because I wanted to provide the maximum possible support. But as more people provide feedback, if the possible scenarios in which PTP mode could be useful keeps dwindling, perhaps that is a decision to revisit. I could, after all, make a separate driver that supported PTP mode available to those who wanted to compile it themselves).
1 year 11 months ago #59267

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1

Replied by Ralph on topic New Pentax Driver Testing

@karlrees

Sorry... checked again... 32bit OS :blink: i think i messed something up. Since i am using a 32bit OS... PTP mode is still not working for me :huh: @drawsacircle Did you tried PTP mode and are you using a RPi4 too?

And you are right Karl. ISO settings in Ekos don't work. The ISO you set is written in the file header, but the cam is using heir ISO. Did some tests and checked the images. Look the same. One at ISO 100 and one at 102400. The second one should be only white and totally overexposed... but looks the same as the one shot at ISO 100 :(

Cheered too soon :whistle:
1 year 11 months ago #59273

Please Log in or Create an account to join the conversation.

  • Posts: 46
  • Thank you received: 6

Replied by Karl Rees on topic New Pentax Driver Testing

Last I remember, StellarMate was using Ubuntu Mate. Is that still the case? Also, did you install from the package, or compile it yourself? This may be the issue where the toolchain on Ubuntu Mate doesn't compile libricohcamerasdk correctly. (One of the many frustrations that could be solved if Ricoh would just open up the SDK, or even just recompile it).
1 year 11 months ago #59276

Please Log in or Create an account to join the conversation.

  • Posts: 83
  • Thank you received: 6
Just before the camera takes a picture, the screen blinks a couple of times, shows the ISO set on the camera. But when you check the FITS file afterwards it shows the ISO chosen in EKOS. I can also see the stretch values in the FITS viewer changes.
I just checked ISO800, not ISO102400, so you're right Noideaforaname, we did celebrate too early.
I'm pretty sure though, that I've been able to change ISO using PkTrigger, but I might be wrong.
Anyway, setting exposure time for me is a huge step :)
Last edit: 1 year 11 months ago by Keld Henningsen.
1 year 11 months ago #59277

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1

Replied by Ralph on topic New Pentax Driver Testing

@Karl

I tried to compile the drivers, pktriggercord etc while i was running Astroberry because 3rd party drivers are not included.

But 3rd Party indi drivers are included in Stellarmate. The last monthly update featured your work. Maybe something went wrong and Jasem can fix it.

PTP is working with short exposures while using the Gphoto CCD or Pentax legacy. But i think both don't use pktriggercord. So no help at all.

And both Gphoto and Pentax legacy set the pixel resolution to 3 and 8 bit instead 3.88 and 16bit.

And i stumbled another bug (on my rig). After i turned on debugging (K70) i wasn't able to turn it off again. Purge, load, deleting the files in the ./Indi folder... nothing worked. So i did a third fresh Install today :) time to use a second mirco SD Card for testing.

@DrawsACircle

I tried again to change the ISO and took a look at the values and not the histogram. They stay nearly the same (tried ISO 100 and then ISO 102400). I will try it again tomorrow, nightshift is calling.

Did you try PTP mode?
Last edit: 1 year 11 months ago by Ralph.
1 year 11 months ago #59287

Please Log in or Create an account to join the conversation.

  • Posts: 83
  • Thank you received: 6
I have not tried PTP mode, I will tomorrow.
I guess the FITS information is based on the Ekos settings and not the EXIF information, that’s why it said ISO800.

Edit: It’s tomorrow, my pc died while flying a Cessna 172 in Microsoft Flightsim 2020 last night :(
New motherboard and cpu ordered, arriving next Thursday.
Last edit: 1 year 11 months ago by Keld Henningsen.
1 year 11 months ago #59288

Please Log in or Create an account to join the conversation.

  • Posts: 83
  • Thank you received: 6
Just tried PTP mode with Pentax Native, ISO can be set, but not exposure time - I tried both Bulb modes - Start/Stop trigger pulse and constant pulse, no changes.
Nothing works in PTP mode with Pentax Legacy.
So, if we could have an exposure start pulse and an exposure stop pulse, that would make the day, It should be a feature you can activate/deactivate in case you use a camera like the KP or K-1 which is supposed to be working with the Pentax SDK.
1 year 11 months ago #59388

Please Log in or Create an account to join the conversation.

  • Posts: 46
  • Thank you received: 6

Replied by Karl Rees on topic New Pentax Driver Testing

Were you using a lens, or doing prime focus? For the K-70 at least, the SDK provided by Ricoh does not expose certain settings unless it detects a lens on the camera that supports those settings. I'm sure whoever decided on this limitation thought they were doing the user a favor by only exposing settings supported by the lens, but obviously they were not thinking about prime focus. Anyway, this means that PTP mode is severely handicapped if you're doing prime focus. Much to my frustration, I did not discover this until after I had already developed the PTP driver, as I probably would have started with MSC mode only had I been aware of the limitation.

The Ricoh SDK does not support bulb mode for PTP with the K-70 (or any camera, I suspect).
1 year 11 months ago #59391

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1

Replied by Ralph on topic New Pentax Driver Testing


Than the polar alignment tool in ekos would maybe also be possible using the K70 and a refresh rate around 1 - 2 seconds. Am i right?.
1 year 11 months ago #59393

Please Log in or Create an account to join the conversation.

  • Posts: 83
  • Thank you received: 6

I use my M200 f4 lens, manual prime.
For me, ISO is not that important, I tend to stick to ISO800.
@Noideadoeaname, you should be able to use your K-70 for proper polar alignment, I don’t know if 1-2sec exposure time is sufficient, if not, it will be difficult to control.
1 year 11 months ago #59400

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1

Replied by Ralph on topic New Pentax Driver Testing

That was just a flash of thought ;)

I managed to get 1 arcminute error on the K70 while using my guiding cam to do the polar alignment. Think that's okay for 750mm focal length while guiding.
1 year 11 months ago #59402

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1

Replied by Ralph on topic New Pentax Driver Testing

Anything new about the driver?
1 year 10 months ago #61429

Please Log in or Create an account to join the conversation.

Time to create page: 0.850 seconds