×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

DIY motorised roll-off observatory roof - what INDI driver?

  • Posts: 31
  • Thank you received: 0
Hello Tom
I do have a connection. I see it in Indi Control panel.
I am using the Arduino with a relay board and sensors connected testing on the bench. 
One relay for open another for close and 2 sensors for open and close.
I am using the rolloffino.standard file for the Arduino. That seems the closes match for what I have for testing.
I did manage to see some action on the Arduino today. I set the sensors as expected and Indi sees it as well.
If I hit the open or closed buttons in Indi I see the corresponding relay come on but then the Indi driver Rolloffino crashes and a few seconds later Kstars crashes.
I have attached a zipped folder with log files.

@ Jasem
You indicated that I should be able to use the same process from the HOWTO: Building latest libindi and Ekos on a macOS.
I tried that and get a message: "sudo: apt-get: command not found".
Do you perhaps know what I may be  doing wrong.

I have tried 
 
1 year 1 month ago #77377
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 277
  • Thank you received: 33
Krish,
On the MacOS. There is a good chance that the driver code will work on the Mac, but it will need to be built and installed according to Mac procedures. The present directions in the INSTALL file did not include any thought given to how that is done. For example the apt-get is a Ubuntu specific command. I did get a Mac but since you said it was the RPI4 you were going to use I have not done anything with it. If you intend to run a Mac in the observatory I can spend more time learning how to use it.

The files you posted appear to be the rolloff debug logs or fragments of, just showing the commands and results, most ending in timeouts. Was one of them in particular associated with the crash?
Do you have the KStars log associated with the crash? Did Kstars put up a message indicating the driver had crashed?
The only time I have had the driver crash was when the version of indi / Kstars it was built against was different from the one installed. Although that always happened when starting. If the version you built against in the ~/Projects tree was the one that was cloned into ~/Projects/indi then it would have been the nightly build.
The Kstars and indi versions running for the testing should be from a nightly or the current stable release since I have been using the driver on those and perhaps the previous release without a rebuild.

[ Edit ] Working with a breadboard you might be using the command buttons and receiving response with much different patterns and frequency than the normal open or close roof  while waiting without requesting other actions going on. So if you encounter a particular button or sequence of steps that can cause the crash it will be helpful in looking for the weakness in the drivers handling of them that results in a crash.
 
/Tom
Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro
Last edit: 1 year 1 month ago by wotalota.
1 year 1 month ago #77383

Please Log in or Create an account to join the conversation.

  • Posts: 277
  • Thank you received: 33
Krish,
Attached is a first pass to capture some of this for Jasem's suggestion for a HOWTO. Any suggestions that would make it easier to get started.

Should add, the Arduino section describes some edits no yet made.
 
Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro
The following user(s) said Thank You: Jasem Mutlaq
Last edit: 1 year 1 month ago by wotalota.
1 year 1 month ago #77387
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 0
Tom
A quick read of the HOWTO and I can say it will be very helpful.
I will work with it and come back with any ideas that may make it easier.
I have attached the log indi log files that show the crashes.
I am using Stellarmate 1.6 and KStars 3.5.5 Stable.build 2021-09-30T19:39:54Z.
I followed this for this link, from the iNSTALL, for the driver building process: indilib.org/forum/general/210-howto-buil...st-libindi-ekos.html
Then followed the INSTALL for the building the indi-rolloffino driver and associated files.
My Ekos Obs and Iindi Control panels are the same as your images.
Thanks

 
1 year 1 month ago #77401
Attachments:

Please Log in or Create an account to join the conversation.

Tom,

Thank you! This is great. I think I would probably just add a generic diagram at the top showing the overall components of the system and some arrows to make users see how things interact so.

Perhaps something like this: Rolloff roof --> motor --> relay --> arduino --> USB to raspberry pi --> INDI driver --> KStars

Just an overall system architecture. Would there be links to the different .ino files so that users can flash them?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 1 month ago #77402

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 0
Jasem
I am going to start afresh for the driver.
Will i be right in starting from section 1 of "indilib.org/forum/general/210-howto-buil...st-libindi-ekos.html" to build the indi_rolloffino driver seeing that I am using Stellarmate and KStars 3.5.5 on it or should I be starting from section 3? 
Thanks
 
1 year 1 month ago #77403

Please Log in or Create an account to join the conversation.

  • Posts: 277
  • Thank you received: 33
The Arduino examples are included in the install and left in place in the 3rdparty sub-directory. Will make that clearer and reference some Arduino SDK doc that describes how to use them.
Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro
1 year 1 month ago #77405

Please Log in or Create an account to join the conversation.

  • Posts: 277
  • Thank you received: 33
Krish,

From your info about what you are running there should not be a version mismatch issue. I don't understand the Ekos live and websocket relationships but no reason to suspect that or Stellarmate related.

If you have the debug log matching the Kstars log there might be additional info there.

From the Kstars log this is a startup situation, not the case where you were able to close relays and read the switches. It is probably the initial connection message that failed although the logging is not clear about that. What is strange is that it is the Arduino returning an error indicating a syntax error for what is probably the driver's initial canned request for its version number. This could happen I suppose if the baud rates between the two did not match or there was some other communication problem.
This initial exchange between the driver and the Arduino is taking place in the context of establishing the initialization and connection between Ekos and the driver. I think the failure to establish this causes the driver to be shutdown.
by the indiserver. Some debug logging might need elevating to error messages if there is anything helpful there.

Meanwhile perhaps you can watch out for communication errors and and see if there are cases that occur other than when first starting.
Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro
1 year 1 month ago #77412

Please Log in or Create an account to join the conversation.

  • Posts: 277
  • Thank you received: 33
Krish,
I updated the roolloff.ino.standard example with the same structure as the .ar1450 and the how-to description. Its setup is now for the Uno model using pullup resistors. Did a basic test of it using a Uno relay shield. There was an issue after uploading the sketch to the Uno the first use of the connection after that took several seconds to respond. The driver was modified to log a warning before continuing instead of an error. Consider running the build again to pick up these modified files.
Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro
1 year 3 weeks ago #77615

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 0
Thank you
I will try it in a few days and let you know.
1 year 3 weeks ago #77632

Please Log in or Create an account to join the conversation.

  • Posts: 277
  • Thank you received: 33
Added the updated html howto to
git clone github.com/wotalota/indi-rolloffino.git
Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro
1 year 3 weeks ago #77651

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 0
Tom
I tried this with your latest version.
It works just great.
Thank you very much for the work you put into it.
Now for me to pursue trying to load it onto my macOS. That is where I prefer running KStars with the RPI just being the server. macOS seems to be ok with building the folders and the libraries but does not want to accept the cmake commands.
Thanks again for your help.
1 year 3 weeks ago #77678

Please Log in or Create an account to join the conversation.

Time to create page: 0.714 seconds