×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Cannot connect to 2m Scopedome / Arduino

  • Posts: 35
  • Thank you received: 0
i patch the code to show cmdstatus frames received on indi from the arduino
just after connection (without pressing any button)
i see that the frame is correctly received, (shutter is see off in the frame )
but not updated in the GUI (seen as open)
if it can help you ......
1 year 1 month ago #69589

Please Log in or Create an account to join the conversation.

  • Posts: 413
  • Thank you received: 153
The fields are described in the protocol documentation that can be downloaded from www.scopedome.com/wp-content/uploads/202...uino_Info_5.2SDK.pdf but it's possible I've made a mistake assigning them to variables in the code and then to shutter status. So I'll override the responses from my controller with those you sent and check how the code behaves and there the error comes from.
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
1 year 1 month ago #69591

Please Log in or Create an account to join the conversation.

  • Posts: 413
  • Thank you received: 153
Long overdue status update after I've finally had a few evenings to work on the driver. Biggest new thing is that ethernet connection now works for me at least. Set connection mode to Ethernet / TCP and fill in the host name and username/password (port number isn't actually used, but doesn't hurt either) before connecting.

Quite a lot of small and larger fixes included too, namely I found from the Windows driver source that digital input and buttons are actually inverted in the status reply, so that caused shutter open/close status confusion among other things. I also added option to set home sensor polarity as it seems to be active low for Arduino cards where as USB Card 2.1 uses active high. So if find home command finds the sensor almost immediately without actually being near the sensor, that is most probably caused by wrong polarity setting.

Hopefully someone has time to test this and report if/when things don't work :)
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
The following user(s) said Thank You: Gorden Konieczek
1 year 3 weeks ago #70658

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0
good news !!, will test it ASAP
keep you update
Rgds
1 year 3 weeks ago #70663

Please Log in or Create an account to join the conversation.

  • Posts: 9
  • Thank you received: 0
I've tested the home sensor functionality as well as the shutter successfully last night. Board firmware was 5.7, Scopedome 3M.
Thank you, Jarno for your restless support.

Best,
Gorden
1 year 3 weeks ago #70690

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0
Hi did few test (Ethernet connection - 2m dome - firm 5.4)

CCW/CW works fine
Open / close shutter works fine
find home works fine
relays command works fine


the save configuration in option's tab does not works (may be not implemented yet)

will continue to play with

Regards
Eric
1 year 3 weeks ago #70777

Please Log in or Create an account to join the conversation.

  • Posts: 413
  • Thank you received: 153
Thanks for testing, sounds promising!

Saving configuration should work (it's mostly handled by the base INDI classes, I just save a few specific items in addition), definitely does for me. Does it create/update "~/.indi/ScopeDome Dome_config.xml" file and if it does, do the contents look valid?
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
1 year 3 weeks ago #70785

Please Log in or Create an account to join the conversation.

  • Posts: 9
  • Thank you received: 0
Eric,

how about movements to absolute positions? Is that working for you? And how about parking and slaving to the mount?

Cheers,
Gorden
1 year 3 weeks ago #70788

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0
HI

just checked , in fact configuration is correctly saved in the file "~/.indi/ScopeDome Dome_config.xml"
(i did the test with "close on park" and "open on unpark"
but when i restart i need to manually load it, it is not automatically done, looks like the default config is loaded instead.

for the slaving i have an issue the dome is trying to find the position but turn in an endless loop, the same with absolute position
(this is working with network and scopdome windows drivers) .

Eric
1 year 3 weeks ago #70794

Please Log in or Create an account to join the conversation.

  • Posts: 9
  • Thank you received: 0
Hi,

I have the same behavior when trying to enable slaving or moving to an absolute position. Jarno is working on it already.

Sometimes (not every time) after updating the INDI server I had the same with saving the config. Once I got the message that there was no config even though saving the config was reported to be successful.
What worked for me in these cases:
- disconnect everything and stop the server
- delete (or rename) the config (not the default config) from .indi folder
- start the INDI server, the driver config file is created from the default config.
- connect and repeat the settings, save the config file

Next time the driver is connecting the settings should be applied correctly.

Cheers.

Gorden
1 year 3 weeks ago #70798

Please Log in or Create an account to join the conversation.

  • Posts: 413
  • Thank you received: 153
I found possible reason for the problem with absolute position by reading the Windows driver source and there was a mysterious negation of the azimuth encoder delta value, which would explain the symptoms. The sequence would have been such that for example when you start from the home sensor position (let's say at azimuth 0) and set absolute position target as azimuth 30. The driver would calculate that "ok, need to move 30 degrees clock-wise" and would send appropriate command and dome would move to roughly the right place. However the missing negation of the encoder delta value would mean that the driver would think that the dome actually moved 30 degrees counter clockwise to azimuth 330 and would then conclude that it needed to do a refining move (it does that to correct for over/undershooting the wanted position, which happens sometimes even with the inertia table) of 60 degrees clockwise. Then the dome would move to azimuth 90 degrees but the counter value would still go the opposite direction and the driver would think the dome is at 270 degrees and so on...

I pushed the fix which does this negation which hopefully finally would fix this. If possible, please test that if you start by homing (after which the encoder delta is 0 and position should show correctly in any case) and then moving for example 10 degrees clock-wise and check if the absolute position reported by the driver behaves correctly or exactly the wrong way.
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
1 year 3 weeks ago #70808

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0
Hi Gorden
thanks for the info
did the test to remove the config files, but still the same , config file contains the right info but is not loaded
i also tried to modify the default file and when i load default config or saved config this is fine but at starting this is wrong

on my side i got no message that they were no config.

Eric
1 year 3 weeks ago #70829

Please Log in or Create an account to join the conversation.

Time to create page: 0.895 seconds