×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Cannot connect to 2m Scopedome / Arduino

  • Posts: 23
  • Thank you received: 0
Thank you very much for this good news.
Actually I am waiting for the repair of my dome electronics. I sent it to ScopeDome/Poland last week.
ScopeDome offered me a very fast repair and return.
Then I will test your driver as soon as possible.

My problem isn't pairing. I tried it by pressing the buttons outside of the box and after opening the boxes I tried to connect by pressing the button on the PCB directly.
Name: Frank Fleischmann
Interests: nature, technics, astronomy, optics, space
Developments: motor control, sensors, networking, radio detectors astronomy, cameras for spacecrafts
Using: 3m Baader dome, 2m ScopDome, GM4000, EQ8, and homebrewed ones, echelle spectrograph and ... INDI
1 year 9 months ago #61417

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 0
I tried to connect to both boxes via USB too.
lsusb has found the arduino card, but I wasn't able to get any answer by sending the commands listed in the pdf-manual :-( I tried many different combinations of baudrates and serial setups but no success.
But it was easy to connect via Ethernet 192.168.2.120 (default) and curl command.
Name: Frank Fleischmann
Interests: nature, technics, astronomy, optics, space
Developments: motor control, sensors, networking, radio detectors astronomy, cameras for spacecrafts
Using: 3m Baader dome, 2m ScopDome, GM4000, EQ8, and homebrewed ones, echelle spectrograph and ... INDI
1 year 9 months ago #61419

Please Log in or Create an account to join the conversation.

  • Posts: 425
  • Thank you received: 155
Both my cards work fine via USB at 9600 bauds, 8N1, used Arduino IDE's serial monitor to talk to them. Was a bit confusing at first because the older card uses 115200, but I guess 9600 is still quite enough.
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
1 year 9 months ago #61428

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0
Hi Jpaana

i also would be interested to control my 2m scopedome (arduino based) with Ekos, what is the status of your development ?
i can do beta testing too if needed

Regards
Eric
1 year 4 months ago #68657

Please Log in or Create an account to join the conversation.

  • Posts: 425
  • Thank you received: 155
Currently USB connection works fine and all basic features are in. I can't test them for real as I only have the controllers, they aren't connected to anything, but relays click like they should and some of the sensors give sane readings.

Unfortunately I have some regression with my own older USB Card v2.1 controller so I haven't switched over to this new version for my own use yet.

I also have a very hackish version that works with the HTTP/Ethernet connection, but it requires some changes to the INDI base classes, which I'll clean up before sending to Jasem for comments.

Up to date code can be found from github.com/jpaana/indi/tree/scopedome_update if you want to help with testing.
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
1 year 4 months ago #68659

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 0
Dear ScopeDomeFriends,

unfortunately we cannot test the new ArduinoVersion of the driver, due to hardware problems of the dome drive.

* Slip ring works unstable, sometimes there is no connection to the shutter-electronics

* temperature problem below 3°C. The motors stop suddenly while moving to destination position
then I have to wait for some minutes before they can be reanimated.

The Polish engineers want to help by online instruction, but we cannot do it by our own. Our local ScopeDomeDealer would accuse us to damage the hardware, but at the same time he don't want to fulfill European warranty regulations. Now we have to use lawyers and so on. Terrible situation never seen before!

Best regards

Frank
Name: Frank Fleischmann
Interests: nature, technics, astronomy, optics, space
Developments: motor control, sensors, networking, radio detectors astronomy, cameras for spacecrafts
Using: 3m Baader dome, 2m ScopDome, GM4000, EQ8, and homebrewed ones, echelle spectrograph and ... INDI
1 year 4 months ago #68672

Please Log in or Create an account to join the conversation.

  • Posts: 425
  • Thank you received: 155
That's very unfortunate, I ordered my dome from ScopeDome directly and they have been very reasonable to deal with. I've had to send the rotation motor/gear box/encoder for replacement as the motor stopped working under warranty and have changed the shutter closed limit switch and the main controller board over the years and everything has worked out well. Cold shouldn't be a problem, I use my dome below freezing temperatures most of the time as the dark time here in Finland is also quite cold :) I'm not sure if the settings for heaters are different as I specified the colder conditions when ordering.
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
1 year 4 months ago #68682

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0
HI Jpaana

i'm not familiar with the process to get the code from github and compile it on my raspberry PI4
i'm running the last version today 1.8.9

i've been doing lot's of embedded code on microcontrollers and on windows mainly in C
i did few on RPI too, but not big projects as Indi (i'm not so familiar with linux)

so i would need some step by step guide how to get the code, compile it with right options and where to store it on the RPI.

Regards
Eric
1 year 4 months ago #68702

Please Log in or Create an account to join the conversation.

  • Posts: 425
  • Thank you received: 155
It is a fairly straight forward process if you have ever compiled any projects using CMake. You can follow the instructions on building INDI from source at indilib.org/forum/general/210-howto-buil...st-libindi-ekos.html but just replace the command
git clone --depth=1 https://github.com/indilib/indi.git
 with
git clone --depth=1 -b scopedome_update https://github.com/jpaana/indi.git

This will build and install base drivers along with the base INDI library, which might not be compatible with the 3rd-party drivers you have installed, so it might be necessary to recompile those as well, instructions on that are on the same page.
 
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
Last edit: 1 year 4 months ago by Jarno Paananen.
1 year 4 months ago #68711

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0
Hi
the command "git clone --depth=1 -b scopedome_update github.com/jpaana/indi.git"
returns "fatal: repository 'github.com/jpaana/indi.git' does not exist"

and the commad "git clone --depth=1 github.com/indilib/indi.git" woks well

Eric
1 year 4 months ago #68715

Please Log in or Create an account to join the conversation.

  • Posts: 425
  • Thank you received: 155
Hm, it should work, did you have the https:// in the url, the forum software seems to eat that part? Ie. change "indilib" part to "jpaana" in the url that works for you and add -b (or --branch) scopedome_update to checkout the correct branch, or go to the resulting indi directory and run "git checkout scopedome_update" there.
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
1 year 4 months ago #68716

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0
yes i added the https and it is working ...still compiling will keep you update, should i see another scopdome model available or is it the same driver as your previous version that works with both ?
1 year 4 months ago #68717

Please Log in or Create an account to join the conversation.

Time to create page: 1.027 seconds