×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

Nexdome no longer syncing correctly with my mount in 3.5.3 stable

  • Posts: 455
  • Thank you received: 70
NOTE:  The Nexdome and CEM120 was working fine with KStars 3.5.2 - as far as synced slaving was concerned.I just updated to the stable release of 3.5.3, and now my Nexdome has a new problem.When I HOME my CEM120 mount - which of course is ZERO degrees azimuth, the Nexdome driver thinks it is at 90 degrees!If I move my mount to any location OTHER than home, the dome does slave to the correct spot and tracks.  But as soon as I direct my mount to slew and locate the HOME position - (90 DEC, 00 degrees Az),  the Nexdome driver rotates to 90 degrees Azimuth instead of zero.Is it looking at the mount's DEC and using that as the Azimuth direction?

LOG excerpt shows the dome calculating the wrong azimuth after the mount slews to home (0 degrees azimuth):

[2021-05-14T13:56:26.123 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] Processing event <XB->WaitAT> with value <WaitAT> "
[2021-05-14T13:56:26.123 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] Snooped RA 10:22:24 DEC 90:00:00 "
[2021-05-14T13:56:26.233 MDT DEBG ][     org.kde.kstars.ekos.mount] - Mount status changed from  "Slewing"  to  "Idle"
[2021-05-14T13:56:26.239 MDT DEBG ][           org.kde.kstars.indi] - iOptron CEM120 : "[DEBUG] CMD <:GLS#> "
[2021-05-14T13:56:26.306 MDT DEBG ][           org.kde.kstars.indi] - iOptron CEM120 : "[DEBUG] RES <-3821590045014100270231> "
[2021-05-14T13:56:26.307 MDT DEBG ][           org.kde.kstars.indi] - iOptron CEM120 : "[SCOPE] CMD <:GEP#> "
[2021-05-14T13:56:26.307 MDT DEBG ][           org.kde.kstars.indi] - iOptron CEM120 : "[SCOPE] RES <+3240000005601646521> "
[2021-05-14T13:56:26.340 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] Updated telescope Az: 0 - Alt: 35.0392 "
[2021-05-14T13:56:26.340 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] JD: 2.45935e+06 - MSD: 11.4592 "
[2021-05-14T13:56:26.341 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] MC.x: 0 - MC.y: -0.05 MC.z: 0.4 "
[2021-05-14T13:56:26.341 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] HA: -5.99121  Lng: -106.155 RA: 155.601 "
[2021-05-14T13:56:26.341 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] OTA_SIDE selection: 4 "
[2021-05-14T13:56:26.341 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] OTA_SIDE: 0 "
[2021-05-14T13:56:26.341 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] Mount OTA_SIDE: -1 "
[2021-05-14T13:56:26.341 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] OTA_OFFSET: 0.35  Lat: 35.0392 "
[2021-05-14T13:56:26.341 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] OC.x: 0 - OC.y: -0.05 OC.z: 0.4 "
[2021-05-14T13:56:26.341 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] Mount Az: 0  Alt: 35.0392 "
[2021-05-14T13:56:26.341 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] OV.x: 0 - OV.y: 0.81876 OV.z: 0.574136 "
[2021-05-14T13:56:26.341 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] Calculated target azimuth is 90.00. MinAz: 62.39, MaxAz: 117.61 "
[2021-05-14T13:56:26.342 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] CMD <@GSR,13770> "
[2021-05-14T13:56:26.414 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] RES <:right> "
[2021-05-14T13:56:26.415 MDT INFO ][           org.kde.kstars.indi] - NexDome :  "[INFO] Dome is moving to position 90.00 degrees azimuth... "
[2021-05-14T13:56:26.416 MDT DEBG ][org.kde.kstars.ekos.observatory] - Setting dome status to  2
[2021-05-14T13:56:26.416 MDT INFO ][org.kde.kstars.ekos.observatory] - "Dome is moving counter clockwise..."
[2021-05-14T13:56:26.417 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] Dome is syncing to position 90.00 degrees... "
[2021-05-14T13:56:26.456 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] Processing event <P44371> with value <44371> "
[2021-05-14T13:56:26.456 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] CMD <@SRR> "
[2021-05-14T13:56:26.509 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] RES <:SER,44374,0,55080,41334,61> "
[2021-05-14T13:56:26.512 MDT DEBG ][           org.kde.kstars.indi] - NexDome : "[DEBUG] Processing event <:SER,44374,0,55080,41334,61> with value <44374,0,55080,41334,61> "


 

 

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
Last edit: 1 month 4 days ago by Peter Kennett.
1 month 4 days ago #71305
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 956
  • Thank you received: 128
Go back to previous version, if all was good why did you update....?
 
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
1 month 4 days ago #71313

Please Log in or Create an account to join the conversation.

  • Posts: 455
  • Thank you received: 70
What's the process to do that?

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
1 month 4 days ago #71314

Please Log in or Create an account to join the conversation.

  • Posts: 455
  • Thank you received: 70
I reinstalled everything to the latest stable again, and the issue is still there.  The dome continues to think zero azimuth is 90 degrees.
I still do not know how to go back to 3.5.2, but that wont solve the issue going forward as new releases are published.  
Does anyone have any idea what is happening to cause this error?

 

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
1 month 1 day ago #71382

Please Log in or Create an account to join the conversation.

Time to create page: 0.439 seconds