×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Random Crash Ekos 3.5.3

  • Posts: 16
  • Thank you received: 1
Hi All, been having a few minor issues but what's really annoying are random crashes.
Running Ekos on a MacBook Pro 16" 2019 and OS 11.4 and using a RPi 4 as a server with Astroberry.
Everything was running smoothly last night then Ekos crashed, the Apple Analytics show that Thread 15 had crashed and lists some StellerSolver files.
Can anyone shed some light on this issue ?
 
Last edit: 3 months 4 days ago by Mark Rose.
3 months 4 days ago #73709
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 1

Replied by Mark Rose on topic Random Crash Ekos 3.5.3

Had another couple of crashes last night.
It was suggested that this might be due to the Fits Viewer and to close it.
No crashes after closing Fits.
3 months 3 days ago #73783

Please Log in or Create an account to join the conversation.

  • Posts: 36
  • Thank you received: 3
Hi Mark,

I had also several crashes the last few sessions and I'm still trying to find out how to reproduce them. I'm using nearly the same setup as you! One crash seems to be related perhaps with network issues where the Raspberry PI itself seems to crash and needs to be restarted. But one crash is the fits viewer itself. For any still unknown reason it crashes sometimes, especially when closing the window of the viewer during capturing images. I'm still unsure how exactly this can be reproduced (and during capturing images is especially a bad time trying to find a crash), but at least two times Ekos/KStars crashed when I was closing the fits viewer. I had also some crashes during stellar solving, but still not reproducible. However, I will compare it with your stack trace next time - maybe I will get the same stack trace within one of the pool threads. 
3 months 2 days ago #73806

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 1

Replied by Mark Rose on topic Random Crash Ekos 3.5.3

Well I had another crash last night, Thread 10 but pretty much the same list of files.
Fits viewer was off, halfway through an exposure, guiding was good then Pooof Gone !

Any experts around that could help?
3 months 2 days ago #73813

Please Log in or Create an account to join the conversation.

Both are happening in SEP Extractor. Will ask Robert to take a look.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 months 2 days ago #73814

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 1

Replied by Mark Rose on topic Random Crash Ekos 3.5.3

Hi Jasem, thank you so much.
3 months 2 days ago #73815

Please Log in or Create an account to join the conversation.

Time to create page: 0.548 seconds