×

INDI Library v1.9.4 Released (17 Jan 2022)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

WARNING: INDI Drivers for iOptron Mounts May Break AutoGuiding

  • Posts: 42
  • Thank you received: 1
After flashing my Raspberry Pi with the latest StellarMate OS running KStars 3.5.5, I ran into serious auto guiding issues that prevented me from imaging.  PHD2 would take 10-15 minutes to calibrate, and when it was done I would get a warning about the DEC and RA calibrations being far off.  When I reviewed the calibration data, I could see the RA axis had calibration points that were far outside of the norm.  When I tried to guide, I'd get a total RMS of 12 arcsec on an iOptron CEM40 that normally gets .6 arcsec.

 

After troubleshooting on the second night, I realized that the INDI Control Panel was set to ENABLE PEC even though PEC was disabled in the hand controller before connecting.  As everyone knows, you cannot auto guide when PEC is enabled on an iOptron mount.  Once I turned that off and saved the INDI driver configuration, my calibrations ran perfectly and my guiding was back down to ~0.6" total RMS.  The default behavior of the INDI driver should be to DISABLE PEC (since PEC is most often used for imaging, and imagers typically guide).

Another change I made to the iOptron INDI driver configuration was to disable tracking.  When I connect to the mount, I don't want it to track until I slew somewhere (e.g. I may be doing a polar alignment at startup).
Last edit: 3 months 1 week ago by MountainAir.
3 months 1 week ago #76525
Attachments:

Please Log in or Create an account to join the conversation.

Default behavior is to read PEC state from mount. If you start the driver again, PEC is detected as ON or OFF?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 months 1 week ago #76526

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 1
I am sure that the hand controller's PEC setting was off prior to the first connection from KStars/INDI. The last time I tried PEC on that mount was over a year ago (it was a disaster with auto guiding), but I did check it on the hand controller prior to connecting because it was the first time I set up that mount in a while and I wasn't sure if the RTC battery was good. The only other thing I changed was the Tracking option in the INDI driver (it started tracking immediately on connection, which is not something it did in the past).

Maybe this only affects the CEM40, I don't know... but because it caused me a lost night of imaging, I thought it important to post a notice for others.

Oh, and to answer your question, because I saved the driver config after making the change, it now stays off.  I didn't think of checking it a second time with the "default" config, but the next time I'm at the observatory I'll try with a backup RPi I have.
Last edit: 3 months 1 week ago by MountainAir.
3 months 1 week ago #76538

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 4
Saw same behaviour with my GEM45. I will check again, purging saved driver configuration and restarting from scratch.
The following user(s) said Thank You: MountainAir
3 months 1 week ago #76606

Please Log in or Create an account to join the conversation.

  • Posts: 621
  • Thank you received: 81
I know this is an old post - but I just discovered that the latest MacOSX INDI driver for the CEM120 also defaults to PEC being on. This is a problem because my CEM120 EC2 mount doesn't even have PEC. It's not an option, since the dual encoders make PEC not needed, and in fact, is not an option in the EC2 model's firmware. So this is not coming from my mount.

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
2 months 2 weeks ago #77292

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 1
Yes, I definitely didn't imagine the issue.   I also noticed tonight that the INDI driver also seems to set the mount to Parked upon startup.  I don't recall it doing this before (though maybe I set it to unparked and saved it).  If I forget to unpark it and try doing something like running a mount model, KStars won't be able to slew.  It won't explain why, but the whole application seems to hang and then eventually crashes.
2 months 2 weeks ago #77318

Please Log in or Create an account to join the conversation.

Time to create page: 0.597 seconds