×

INDI Library v1.9.4 Released (17 Jan 2022)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Plate solving not working again

  • Posts: 41
  • Thank you received: 1
I have erratic performance with plate solving but I've spent almost an hour and a half at it tonight and it's just not working at all. It takes about 10 minutes before it gives up and says there aren't enough stars but I can clearly see there are. I've tried slewing around, focusing, changing a few settings but nothing is having any effect. Is there anything I can do to diagnose this issue?
 
2 months 3 weeks ago #77248
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 752
  • Thank you received: 346
The usual recommendation is to disable the 'use position' and 'use scale' settings.
Definitely set your timeouts shorter too.
If the position/scale unsetting doesn't work,  please show more details about how plate solving is setup
e.g. click options and screenshot the "StellarSolver Options" tab, and the "scale and position" tab, 
and perhaps also the stellar solver params (e.g. clicking on the pencil and screenshot).
 
Orion Atlas Pro, William Optics ZS105, Moonlight V2 focuser, GSO RC10 w/RSF focuser
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm guidecam.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
2 months 3 weeks ago #77249

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 1
Thank you very much, I have unticked both and I'm running it again

Just after I posted up, the pi crashed completely. I power cycled it and it plate solved. It's now being quite hit and miss. I have reduced the timeout to 100 seconds (never noticed it before!)

Attached a screenshot of the requested tabs - I noticed the effective focal length is showing at a crazy number too now (also attached), something is not right!

 
2 months 3 weeks ago #77250
Attachments:

Please Log in or Create an account to join the conversation.

That's not right. Another trick is to edit the default align SEP profile and change FWHM to 1. That helped me solve the images faster. Set binning to 2x2 or 4x4.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 3 weeks ago #77260

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 1
Thanks, I will try that next time - had to give up last night after over 2 hours of failing :(
2 months 3 weeks ago #77261

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 1
Well, the problem remains. This has worked perfectly for months but now refuses, I tried 2x2 binning and relatively long exposures but nothing will solve for some reason

I looked for the FWHM setting but the only one I can see is already 1 (see attached)

Any other ideas?
2 months 3 weeks ago #77305
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 1
A lot of crazy just happened so I wrote it all down as it happened:

Changing the solving method from 'internal solver' to 'local astrometry' seems to have made it plate solve finally but very slowly

I put 'use scale' and 'use position' on to see if that would help

I started solving again and I caught sight of an error writing log file (screenshot attached) which caused kstars to lock up. I guess this must have been what happened last time too?

 

I managed to reboot the pi and, when it started back up again, I went straight to plate solve and it died again in the same way. I then went outside to see if the sky was clear and the mount was driving the telescope into the side of the observatory for some unknown reason. 

I reset the park position after the strike then slewed to my target (IC63) before plate solving yet again. It appeared to plate solve like it normally would BUT when it slewed to correct, it fired the scope to a crazy position nowhere near the target. 

I parked the scope, unparked it, slewed to IC63 and it pointed to a different random part of the sky. I decided that it was not going to recover so powered everything down to start again. 

After a power cycle, I unparked it, slewed to IC63 (correctly), plate solved again then it fired off towards the floor again. I checked the sky map and it knew that it was pointing at a random place.

 

I parked the mount, unparked, slewed to IC63, it went to another random position pointing at the observatory. 

I then set the park position to default again, clicked write data, it moved the scope to the correct position but the star map showed it in a completely different place (third picture). I closed kstars, reopened it and it moved to the right place (4th pic)?! There's a bug somewhere, I don't know know what but it's causing me some trouble!!

 
 
 
2 months 3 weeks ago #77308
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 1
I changed absolutely nothing and tried it tonight, slewed to target, plate solved, adjusted correctly and is all fine, how frustrating :(
2 months 2 weeks ago #77336

Please Log in or Create an account to join the conversation.

  • Posts: 752
  • Thank you received: 346
James,

Sorry things aren't going well. I'm not sure what your issue is, but why don't you try ASTAP just in case it falls into place easier for you. You need to install it first, and can get it here, www.hnsky.org/astap.htm and use the H18 star database since you have a long focal length. You'd then change the StellarSolver solving method setting to ASTAP, and definitely uncheck both use position and use scale. (Somethings definitely wrong with scale somehow, giving you those crazy focal lengths).

Also, go through this procedure: stellarmate.com/support/faq/mounts.html?view=faq&faqid=33 I do that whenever my mount is acting strangely.

Finally, when you're having solving issues, definitely capture a fits file with the same settings as you capture for align, and upload it somewhere so that you and we can debug it offline.

Hy
Orion Atlas Pro, William Optics ZS105, Moonlight V2 focuser, GSO RC10 w/RSF focuser
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm guidecam.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
2 months 2 weeks ago #77337

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 1
Thanks for the suggestion, if it plays up again I'll do exactly that. The confusion is why it suddenly started going wrong as I've used it dozens of times without issue, will keep you posted if I have more issues
2 months 2 weeks ago #77339

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 1
Believe it or not this is the first clear night I have been able to get out since the last post. I fired everything up and it plate solved once, corrected, solved again, corrected and then failed and repeated failures similar to all the above. I reset everything to default settings, turned off 'use scale' and it has now started solving again. I haven't resorted to ASTAP yet but hopefully I am running for now!
1 month 4 weeks ago #78141

Please Log in or Create an account to join the conversation.

Time to create page: 1.193 seconds