×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Ekos Optical Trains

Replied by Jasem Mutlaq on topic Ekos Optical Trains

Video on optical trains:
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Gonzothegreat, Magnus Larsson, Sonny Cavazos, Konstantin Baranov
2 months 3 weeks ago #86105

Please Log in or Create an account to join the conversation.

  • Posts: 415
  • Thank you received: 99

Replied by Kevin Ross on topic Ekos Optical Trains

I just pulled the latest git, and now when I start up Ekos, all the controls on all the tabs are grayed out, until I change to a different optical train and then change it back.

It's not a showstopper, but it is inconvenient. :)

2 months 1 week ago #86396
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 415
  • Thank you received: 99

Replied by Kevin Ross on topic Ekos Optical Trains

Never mind. I made the mistake of doing a build without a clean first. Did a clean build, and it's working properly now.

Nothing to see here. Move along. :)
The following user(s) said Thank You: Jasem Mutlaq
2 months 1 week ago #86399

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic Ekos Optical Trains

Thanks for the testing! Next KStars is due on 29th and we would appreciate all the testing we can get for the beta now!
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Gonzothegreat
2 months 1 week ago #86404

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 1

Replied by Jordi Sesé on topic Ekos Optical Trains

I am testing latest OSX beta (Build: 2022-09-17T18:07:01Z). It seems that it does not like duplicated drivers...

I wanted to check dual camera setup with simulators (if not simultaneous, at least alternative). I created a driver alias of the CCD Simulator driver and named it 'CCD Simulator_2'.

I then added it in a profile as Aux1 (since there's no other option right now) and CCD Simulator as main CCD camera. The result was that the Optical Trains interface stopped working. It did not appear when connecting drivers, and when called, it was blank, and it closed the app when clicking the '+' button to add a train.

This also happened when modifying an existing profile with just one camera when adding the alias as Aux, not just with new profiles.

I guess it is easy to reproduce. If you need any more info, just let me know.

Thanks for your time, and regards from Barcelona.
2 months 1 week ago #86408

Please Log in or Create an account to join the conversation.

  • Posts: 825
  • Thank you received: 96

Replied by Peter Kennett on topic Ekos Optical Trains

Jason will the weather charting work again?

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD and William Optics Star71
ASI 1600MM Pro, ASI 462MC
Moonlight Litecrawler (C11) and Motorfocus (WOStar71)
LodeStar X2 and ZWO OAG
Nextdome, AAG Cloudwatcher
MacMini
2 months 1 week ago #86414

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205

Replied by Gonzothegreat on topic Ekos Optical Trains

3.6.1 on OSX
I have added an additional train. From the sequence window, you don't know which train is what. It would be good to have another column to show that info.
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
2 months 1 week ago #86418
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205

Replied by Gonzothegreat on topic Ekos Optical Trains

Might not be possible right now, so just an idea for now... from the sequence window we should have the ability to run 2 train (cameras) at the same time.
ie: an option box to link 2 sequences to fire at the same time.
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
2 months 1 week ago #86419

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic Ekos Optical Trains

That could be supported in the future but it's not possible in 3.6.1
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 1 week ago #86420

Please Log in or Create an account to join the conversation.

  • Posts: 825
  • Thank you received: 96

Replied by Peter Kennett on topic Ekos Optical Trains

I think I need to delete the Optical Train config data. Where is it located on MaxOSX?
(KStars crashes whenever I try and create a new train)

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD and William Optics Star71
ASI 1600MM Pro, ASI 462MC
Moonlight Litecrawler (C11) and Motorfocus (WOStar71)
LodeStar X2 and ZWO OAG
Nextdome, AAG Cloudwatcher
MacMini
2 months 1 week ago #86460

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205

Replied by Gonzothegreat on topic Ekos Optical Trains

I believe the info is located in userdb.sqlite in the directory
/Users/USERNAME/Library/Application Support/kstars
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
2 months 1 week ago #86468

Please Log in or Create an account to join the conversation.

  • Posts: 825
  • Thank you received: 96

Replied by Peter Kennett on topic Ekos Optical Trains

Thanks!
I deleted that file, and after restarting KStars and rebuilding my profile, all seems to be working now.

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD and William Optics Star71
ASI 1600MM Pro, ASI 462MC
Moonlight Litecrawler (C11) and Motorfocus (WOStar71)
LodeStar X2 and ZWO OAG
Nextdome, AAG Cloudwatcher
MacMini
2 months 1 week ago #86474

Please Log in or Create an account to join the conversation.

Time to create page: 0.442 seconds