×

INDI Library v1.9.6 Released (Yesterday)

Bi-monthly INDI Library released with new drivers and bug fixes.

Dither failure while guiding is good

  • Posts: 17
  • Thank you received: 3
Hey,

I am new to autoguiding and EKOS. I was testing things out tonight and was able to get guiding working as expected for my mount. However I was having issues with dithering. It would hang and then fail during the dither.

I am not exactly sure why it is failing. Looking at the logs I can see it start the dither, try a number of times capturing a image and sending a command to EQMod, print that it failed, and then print that it succeeded. Can anyone make heads or tails of what is happening? As I mentioned guiding corrections seem to go through no problem.

I have a RA only tracker, fyi.
4 months 2 weeks ago #78956
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
I am Facing the Same. Did you found any Solution?
4 months 2 weeks ago #78957

Please Log in or Create an account to join the conversation.

Before checking the log, if I had to guess it's because of the RA-only since it tries to pulse in both direction but obviously fails in DE.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 months 2 weeks ago #78963

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 3
In the log it is sending 0ms DEC pulses. I had RA guiding only on, and the two axis calibration was off, so RA only guiding was working fine. Manual dithers failed as well.

[2021-12-30T22:26:25.208 PST DEBG ][     org.kde.kstars.ekos.guide] - Dithering in progress. Current 112.23 310.043 Target 122.317 310.523 Diff star X: -0.152848 Y: -10.0973
[2021-12-30T22:26:25.208 PST INFO ][     org.kde.kstars.ekos.guide] - "Warning: Dithering failed. Autoguiding shall continue as set in the options in case of dither failure."

Checking the log it is reporting an offset in X before failure.

Looking at the code leads me to this line here :
github.com/KDE/kstars/blob/master/kstars...ernalguider.cpp#L277

So X and Y offset must be under 1 for the dither to complete. That can't happen if we are only guiding in RA.

The internal guider should be checking the RA and DEC settings to determine the directional vector, and/or it should ignore discrepancies in an axis for which guiding is disabled.

Let me know if this should be a support ticket. Dithering was one of the 2 big reasons I wanted to start guiding.
4 months 2 weeks ago #78965

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 3
Pardon my suggestion, but it seems like this could solve the issue. Basically not considering deltaRA and deltaDEC if that part of guiding is disabled:
if ((!Options::rAGuideEnabled() || fabs(driftRA) < 1) && (!Options::dECGuideEnabled() || fabs(driftDEC) < 1))

There might be other code paths related to manual dithering that I did not check. Also feel free to ignore as I am not super familiar with the codebase haha.
4 months 2 weeks ago #78966

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 3
In the mean time, I think the dither is working as far as the RA component is concerned. So what I will do is set the dither retries to 0 or 1 and it should abort after the first failed attempt ( which is actually correct as far as what we can do is concerned ).

It would still be nice if there was an option for this. PHD2 has a checkbox for RA only dither, as these mounts are fairly popular in the community. It would be great if we could either have a RA only dither option, or take into account the guiding controls as I have suggested above.
4 months 2 weeks ago #78993

Please Log in or Create an account to join the conversation.

Time to create page: 0.587 seconds