×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Kstar and Ekos crash

  • Posts: 35
  • Thank you received: 0
Hi
i  have the following issue since a while that crash Kstars during automatic cession 
so each time bad mood in the morning when i see that it stops just 30min after going to bed.
 

in my last cession i was imaging M101 for 150 pictures of 30 sec exposure
it runs fine, from files 1 to 71 and after the next four files were with index stuck to 71 and then EKOS/KSTAR crashed.

i checked the log file and i found this line  : [2022-01-21T02:28:02.000 CET WARN ][                       default] - QProcessPrivate::createPipe: Cannot create pipe 0xc5e370c: Too many open files

seem that this is the source of the crash issue. i've nothing else than kstars and ekos running on the RPI4
any idea of the origin of this message from which process it is coming from  ?

thanks for your help there as this is a very boring issue.

Regards
Eric
10 months 3 days ago #79877

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic Kstar and Ekos crash

Settings --> Configure Notifications --> Turn off all sounds.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Eric TINLOT
10 months 3 days ago #79880

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 0

Replied by Eric TINLOT on topic Kstar and Ekos crash

Hi Jasem

will try that , thanks for your help , greatly appreciated

Rgds
Eric
10 months 3 days ago #79881

Please Log in or Create an account to join the conversation.

  • Posts: 238
  • Thank you received: 49

Replied by Gene N on topic Kstar and Ekos crash

Eric,

If you -need (or want)- notifications, you can try upping the open files limit.
You can find the current limits:
ulimit -Hn
and
ulimit -Sn

For the hard and soft limits
On Astroberry I see
astroberry@astroberry:~ $ ulimit -Hn
1048576
astroberry@astroberry:~ $ ulimit -Sn
1024

On a normal PI I see
pi@pi:~ $ ulimit -Hn
1024
pi@pi:~ $ ulimit -Sn
1024


You can change them for all users except root by adding two lines to near end of the file
Change the '2048' in lines below to say double what you see in the -Hn and -Sn commands above
/etc/security/limits.conf
Add
* hard nofile 2048
* soft nofile 2048

To up it for root user add
root hard nofile 2048
root soft nofile 2048

And restart.
Verify they new limits hold
ulimit -Sn
ulimit -Hn


Gene


Add these two lines
10 months 3 days ago #79905

Please Log in or Create an account to join the conversation.

Time to create page: 0.413 seconds