×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Hard day's night...

  • Posts: 106
  • Thank you received: 12
Bad night last night ... The EQ6 altitude adjustment screw breakage (hopefully, i have also an heq5), cable problems, and EKOS that crashes when I want to access the directories or save a sequence. I'll try to arrange the rest, but to EKOS, what can I do?
I made screencasts of the bug that I could reproduce in simulation:
ekos save seq. crash
ekos change directory crash

I'm on ubuntu 15.10 64 bits, gnome-shell, last version of kstars/ekos, nomadic installation (no observatory)
6 years 9 months ago #7797

Please Log in or Create an account to join the conversation.

  • Posts: 285
  • Thank you received: 43

Replied by Markku on topic Hard day's night...

Hi there..

That looks exactly as my setup started to do last week, so I thought maybe I did install something that interfered with Kstars, so last night I did a fresh install of Kubuntu 16.04 Beta 2 and updated everything and also installed Kstars from PPA.
When defining a sequence works well, but when removing a sequence makes Kstars to dump core, the problem with loosing connection has disappeared, I did some sniffing with Wireshark and found out when any button is pressed that opens/saves a file there is a network packet sent that ends the network communication to the server, unfortunately I forgot to backup the logfile from Wireshark but I still have another computer running Ubuntu 15.10 at work so maybe I can produce a new log on that.
Br.
/Markku
EQ8, Small scope SW200, Big scope SW300, Xagyl FW, Guidescope Celestron 80mm, SX LodestarX2, SXVR-H9.
RPi4, Ubuntu Server 20.04.3 LTS x64, and many Arduinos..
6 years 9 months ago #7798

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic Hard day's night...

Version of KStars? I can't replicate those issues here, it's very strange if you open directory.
dpkg -s kstars-bleeding | grep 'Version'
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
6 years 9 months ago #7803

Please Log in or Create an account to join the conversation.

  • Posts: 106
  • Thank you received: 12

Replied by Eric Magnien on topic Hard day's night...

Version: 5:15.12+r5662.251~ubuntu15.10.1
6 years 9 months ago #7806

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic Hard day's night...

Send me teamviewer details.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
6 years 9 months ago #7807

Please Log in or Create an account to join the conversation.

  • Posts: 106
  • Thank you received: 12

Replied by Eric Magnien on topic Hard day's night...

I just downloaded teamviewer, it's done now
6 years 9 months ago #7809

Please Log in or Create an account to join the conversation.

  • Posts: 106
  • Thank you received: 12

Replied by Eric Magnien on topic Hard day's night...

I also forgot it : same trouble with load & slew in alignment module
6 years 9 months ago #7811

Please Log in or Create an account to join the conversation.

  • Posts: 106
  • Thank you received: 12

Replied by Eric Magnien on topic Hard day's night...

I thought the problem was solved, but it is not. However, if I change the fits images default directory each time (even without changing the actually directory), it works
6 years 9 months ago #7816

Please Log in or Create an account to join the conversation.

  • Posts: 106
  • Thank you received: 12

Replied by Eric Magnien on topic Hard day's night...

Here is my last screencast

bypass bug

The only time it works is when I go into the kstars configuration and I interact with the fits images default folder setting. And I have to do it every time I open kstars ...
6 years 9 months ago #7817

Please Log in or Create an account to join the conversation.

  • Posts: 106
  • Thank you received: 12

Replied by Eric Magnien on topic Hard day's night...

New try this evening. With kde environment that I just reinstalled, open a folder works fine in Ekos. In unity or gnome-shell, ekos crashes. Could it be a file manager issue between desktop environments?
6 years 9 months ago #7837

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375

Replied by Radek Kaczorek on topic Hard day's night...

I do confirm this behaviour on Ubuntu 15.10 and KStars 5:15.12+r5669.251~ubuntu15.10.1
I suspect that Directory variable is not set properly in EKOS. If you click (or enter new) text in Directory field BEFORE clicking Open/Save button this would work just fine.
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
6 years 9 months ago #7838

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic Hard day's night...

I committed a trivial update that might resolve this issue.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
6 years 9 months ago #7840

Please Log in or Create an account to join the conversation.

Time to create page: 0.285 seconds