×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Missing stored files

  • Posts: 7
  • Thank you received: 0

Missing stored files was created by LoloIO

Hello

I would like to have your opinion ona problem I had last week.
I use astroberry (Kstars/Ekos/Indi) on a Raspberry PI 4
I wanted to do a session of EKOS with 540x light(10s) 100x dark(10s), 60x light(120s) and 30x(120s) dark.
The job was done.

But written files didn't match the sequence. I explain.
On the micro SD Card I have only 478 images (10s), only one image (120s), only one dark (10s) and only one dark (120s) !!

I don't understand why I don't have all files written on the micro SD card.
Since the 478 image, EKOS saves following images with the same name. And for following sequences it use the same name to different step of the sequence. Ex: to the sequence of 60x light, all the saved files had the same name "Light-120s-001.fit".

If you want, I made a transfert wih some screenshots, the log file and the analyze file: Exemple File: we.tl/t-kbrWAjWFQU

I hope my explaination is understantable.

Have you ever encountered the same problem ?

Do you have any idea to the reason of this problem ?
1 month 3 weeks ago #85175

Please Log in or Create an account to join the conversation.

  • Posts: 927
  • Thank you received: 127
There had been a similar thread a few days ago. A quick fix seems to be to use timestamps in filenames
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
The following user(s) said Thank You: LoloIO
1 month 3 weeks ago #85177

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0

Replied by LoloIO on topic Missing stored files

Thank you very much.
This is the right solution.
I tested it last night and it worked well.
Thanks again.
1 month 3 weeks ago #85188

Please Log in or Create an account to join the conversation.

  • Posts: 927
  • Thank you received: 127
Good you managed to work around it.

Could you nevertheless specify what version of KStars/EKOS you use? The developers think it was an issue of an older version, so it is important to know if it happens with recent versions, too.
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
1 month 3 weeks ago #85191

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0

Replied by LoloIO on topic Missing stored files

Sorrry for my latet reply.
I use the v3.5.8 version of Kstars/EKOS.
I didn't found the version of Indi.
I hope this information will be useful.
1 month 2 weeks ago #85278

Please Log in or Create an account to join the conversation.

  • Posts: 376
  • Thank you received: 27

Replied by Paul on topic Missing stored files

Yes, I do hope they resolve this soon, it has been over 12 months since I first reported it and it continues to be a major source of frustration.

indilib.org/forum/ekos/9913-image-counte...ages-to-be-lost.html

Paul
Losmandy G11 with Gemini 2 controller
QSI 583/683 monochrome camera with filter wheel
Starlight Xpress Lodestar X2 guide camera
Microtouch Focuser controlled using Arduino UNO emulating Feathertouch controller
Raspberry Pi 2GB with Raspberry Pi OS 64bit Buster
1 month 2 weeks ago #85279

Please Log in or Create an account to join the conversation.

  • Posts: 927
  • Thank you received: 127
Well, 3.5.8 is also quite old, so the first thing would be to try a recent version before claiming it's not fixed, is it?
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
The following user(s) said Thank You: LoloIO
1 month 2 weeks ago #85287

Please Log in or Create an account to join the conversation.

  • Posts: 376
  • Thank you received: 27

Replied by Paul on topic Missing stored files

Peter,

I can guarantee it is happening with a version I built around 3 weeks ago, which is running 64 bit Buster.

I haven't yet got a fully working version on Bullseye, but believe I am close to succeeding.

Paul
Losmandy G11 with Gemini 2 controller
QSI 583/683 monochrome camera with filter wheel
Starlight Xpress Lodestar X2 guide camera
Microtouch Focuser controlled using Arduino UNO emulating Feathertouch controller
Raspberry Pi 2GB with Raspberry Pi OS 64bit Buster
Last edit: 1 month 2 weeks ago by Paul.
1 month 2 weeks ago #85290

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0

Replied by LoloIO on topic Missing stored files

I will try the last version. May be next week, or next one.
I will comeback here to tell you if the problem is ok, or not.
1 month 2 weeks ago #85327

Please Log in or Create an account to join the conversation.

  • Posts: 985
  • Thank you received: 297
Could you please provide the logs from such a session where the problem occurs?
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
1 month 2 weeks ago #85335

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0

Replied by LoloIO on topic Missing stored files

You can download it with the link in the first message of this topic.
If you have a problem tell me it and I send you just the log file.
1 month 2 weeks ago #85336

Please Log in or Create an account to join the conversation.

  • Posts: 985
  • Thank you received: 297
It looks like we have a problem with file handles:
[2022-08-07T22:40:32.973 CEST INFO ][   org.kde.kstars.ekos.capture] - "Reçu une image 479 de 540."
[2022-08-07T22:40:32.976 CEST INFO ][   org.kde.kstars.ekos.capture] - "/home/astroberry/20220807-TestAcquisition/Light/Luminance/Light_10_secs_478.fits capturé"
[2022-08-07T22:40:32.997 CEST WARN ][                       default] - QProcessPrivate::createPipe: Cannot create pipe 0x8bd890c: Too many open files
At least we have now an indication that could cause the problem.
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
1 month 2 weeks ago #85343

Please Log in or Create an account to join the conversation.

Time to create page: 1.031 seconds