×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

KStars crashing

  • Posts: 161
  • Thank you received: 25

KStars crashing was created by Ron DeBry

Ubuntu-mate 22.04 LTS on a mini-pc
KStars stable installed from ppa

Ran well a couple of nights, including an all-night session last night. Ekos stopped as normal at dawn, with KStars still open as normal. I tried to start a new Ekos session with the "main camera+simulators" profile to take flats (this is an existing profile I have used before), and KStars crashed.

Kstars now crashes very nearly every time I try to run it, regardless of the profile chosen. Have rebooted, power-cycled, run apt-get update, etc. no change. I unplugged every usb device and tried with only the simulators.

With the simulators profile, when KStars crashes I have hit the Run button and the INDI control panel window comes up, but there is no information in the Telescope Simulator tab (it's blank).

Ran kstars with dbg, and it says:

Thread 1 "kstars" received signal SIGSEGV, Segmentation fault.
__strlen_sse2 () at ../sysdeps/x86_64/multiarch/strlen-vec.S:126
126 ../sysdeps/x86_64/multiarch/strlen-vec.S: No such file or directory.

I did type bt, but I'm not sure how to capture the information - should I pipe it to something that will save the text to a file? (I used unix 35 years ago, but have forgotten 99.9% of what little I knew back then)

If I had to guess, given that there were no software or hardware changes in between 5:15am (dawn shutdown) and 8:00am, something on the hard drive may have gotten corrupted?

Is there a least painful way to re-install Kstars?
3 months 2 weeks ago #85416

Please Log in or Create an account to join the conversation.

  • Posts: 56
  • Thank you received: 9

Replied by Ray on topic KStars crashing

Hi, Not had the same experience but I did start to get crashes when opening indi drivers for no apparent reason. What fixed it for me was to delete the corresponding xxxx_config.xml file. In my Ubuntu setup they're in /home/'user'/.indi
3 months 2 weeks ago #85434

Please Log in or Create an account to join the conversation.

  • Posts: 161
  • Thank you received: 25

Replied by Ron DeBry on topic KStars crashing

Thanks, Ray. I'm not sure there's a particular xxxx_config.xml file involved and it does not *look* to be related to an INDI driver. Seems to be Kstars itself crashing.

I have noticed a few times on my Ubuntu Mate install that it reports the Marco window manager has crashed, and I have a couple of odd-seeming issues that could be related to the window manager (a fair number of windows within Ekos and within PHD2 appear without any 'minimize' or 'close' widgets).

I am installing the nightly, to see if that will write a new version of some KStars file that might have gotten corrupted. If worst comes to worst I might need to back all the way up and install an earlier version of Ubuntu.

A few tries starting and stopping KStars/Ekos with the nightly have not crashed. So far...
Last edit: 3 months 2 weeks ago by Ron DeBry.
3 months 2 weeks ago #85435

Please Log in or Create an account to join the conversation.

  • Posts: 161
  • Thank you received: 25

Replied by Ron DeBry on topic KStars crashing

The nightly seems to not crash, but when I played around with the telescope simulator it kept getting caught in some kind of loop - flickering back and forth between a couple of messages about a meridian flip failing (I had sent it to a position that should have been at least 3 hours away from a meridian flip...)

I didn't want to risk that happening when connected to my mount, so I reverted back to stable. Still crashing, but I have found what might be a workaround. I open Kstars, start Ekos - the IND panel shows up unpopulated by any settings / switches, then after a second or two Kstars crashes. If I restart Kstars and tell it to *not* close the existing INDI server, it *seems* to work correctly from then on.
3 months 2 weeks ago #85439

Please Log in or Create an account to join the conversation.

  • Posts: 277
  • Thank you received: 33

Replied by wotalota on topic KStars crashing

If auto starting the drivers, could try manually starting them one at a time and see if that works.
I found starting them all using indiserver directly, before running Ekos avoided startup crashes.
Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro
3 months 2 weeks ago #85447

Please Log in or Create an account to join the conversation.

Time to create page: 1.676 seconds